aboutsummaryrefslogtreecommitdiff
path: root/net-im/wooztalk
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 05:51:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 05:51:05 +0000
commit903a852cd134b7bf493e62850be4fd8f8f23e69f (patch)
tree737deb3b71c0423200eaa75b1bb0b57b02653dce /net-im/wooztalk
parent60dcc666d94f4d8476da55f0558e1f2f8fc029ba (diff)
downloadports-903a852cd134b7bf493e62850be4fd8f8f23e69f.tar.gz
ports-903a852cd134b7bf493e62850be4fd8f8f23e69f.zip
Notes
Diffstat (limited to 'net-im/wooztalk')
-rw-r--r--net-im/wooztalk/Makefile51
-rw-r--r--net-im/wooztalk/distinfo3
-rw-r--r--net-im/wooztalk/pkg-descr8
-rw-r--r--net-im/wooztalk/pkg-message1
-rw-r--r--net-im/wooztalk/pkg-plist79
5 files changed, 142 insertions, 0 deletions
diff --git a/net-im/wooztalk/Makefile b/net-im/wooztalk/Makefile
new file mode 100644
index 000000000000..1f61091d4126
--- /dev/null
+++ b/net-im/wooztalk/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: wooztalk
+# Date created: 2008-07-18
+# Whom: David <tech@wooztalk.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wooztalk
+PORTVERSION= 0.9.8b
+CATEGORIES= net-im
+MASTER_SITES= http://www.wooztalk.com/common/download/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}-freebsd
+
+MAINTAINER= tech@wooztalk.com
+COMMENT= Meet your World Wide Web neighbors
+
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
+ boost_serialization.4:${PORTSDIR}/devel/boost \
+ boost_regex.4:${PORTSDIR}/devel/boost \
+ boost_filesystem.4:${PORTSDIR}/devel/boost \
+ curl.4:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= ${LOCALBASE}/lib/xpi/firefoxonwooztalk@kurioos-itech.com:${PORTSDIR}/www/xpi-firefoxonwooztalk
+
+USE_BZIP2= yes
+NO_BUILD= yes
+USE_WX= 2.8
+WX_UNICODE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= run only on 7.x
+.endif
+
+do-install:
+ @${MKDIR} ${DATADIR}/img
+ @${MKDIR} ${DATADIR}/sounds
+ @${MKDIR} ${PREFIX}/share/locale/en
+ @${MKDIR} ${PREFIX}/share/locale/fr
+ @${INSTALL_PROGRAM} ${WRKSRC}/wooztalk ${PREFIX}/bin/wooztalk
+ @${INSTALL_DATA} ${WRKSRC}/WoozTalk.ico ${DATADIR}/
+ @${INSTALL_DATA} ${WRKSRC}/wooztalk.pem ${DATADIR}/
+ @${INSTALL_DATA} ${WRKSRC}/img/*.* ${DATADIR}/img/
+ @${INSTALL_DATA} ${WRKSRC}/sounds/*.* ${DATADIR}/sounds/
+ @${INSTALL_DATA} ${WRKSRC}/resources/en/wooztalk.po ${PREFIX}/share/locale/en/LC_MESSAGES/wooztalk.po
+ @${INSTALL_DATA} ${WRKSRC}/resources/fr/wooztalk.po ${PREFIX}/share/locale/fr/LC_MESSAGES/wooztalk.po
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-im/wooztalk/distinfo b/net-im/wooztalk/distinfo
new file mode 100644
index 000000000000..88f7e690f3d4
--- /dev/null
+++ b/net-im/wooztalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (wooztalk_v0.9.8b-freebsd.tar.bz2) = 25e40824b79139645da51889922c52af
+SHA256 (wooztalk_v0.9.8b-freebsd.tar.bz2) = afbdbe368992ff01850e02811a502a2efe0f643344d1a4bd981b6ebfc0cdb8c4
+SIZE (wooztalk_v0.9.8b-freebsd.tar.bz2) = 1107590
diff --git a/net-im/wooztalk/pkg-descr b/net-im/wooztalk/pkg-descr
new file mode 100644
index 000000000000..783accefc098
--- /dev/null
+++ b/net-im/wooztalk/pkg-descr
@@ -0,0 +1,8 @@
+WoozTalk is a new innovative and free Internet service that let you see and chat
+with anyone else visiting the same website.
+
+As soon as you install WoozTalk, when you visit one of your favorite websites,
+you will see others net surfers currently connected and you will be able to chat
+with them!
+
+WWW: http://www.wooztalk.com
diff --git a/net-im/wooztalk/pkg-message b/net-im/wooztalk/pkg-message
new file mode 100644
index 000000000000..32b160f27607
--- /dev/null
+++ b/net-im/wooztalk/pkg-message
@@ -0,0 +1 @@
+Please restart firefox to enable the WoozTalk extension.
diff --git a/net-im/wooztalk/pkg-plist b/net-im/wooztalk/pkg-plist
new file mode 100644
index 000000000000..0d744233757e
--- /dev/null
+++ b/net-im/wooztalk/pkg-plist
@@ -0,0 +1,79 @@
+bin/wooztalk
+%%DATADIR%%/WoozTalk.ico
+%%DATADIR%%/wooztalk.pem
+%%DATADIR%%/img/about.png
+%%DATADIR%%/img/add.png
+%%DATADIR%%/img/ampoule.png
+%%DATADIR%%/img/arrow_left.png
+%%DATADIR%%/img/arrow_right.png
+%%DATADIR%%/img/bell.png
+%%DATADIR%%/img/belldef.png
+%%DATADIR%%/img/bigbell.png
+%%DATADIR%%/img/bigpopup.png
+%%DATADIR%%/img/blush.png
+%%DATADIR%%/img/chat.png
+%%DATADIR%%/img/chatnotsubscribed.png
+%%DATADIR%%/img/chatsubscribed.png
+%%DATADIR%%/img/cheeky.png
+%%DATADIR%%/img/configURL.png
+%%DATADIR%%/img/confused.png
+%%DATADIR%%/img/cool.png
+%%DATADIR%%/img/crying.png
+%%DATADIR%%/img/defaultavatar.png
+%%DATADIR%%/img/disconnect.png
+%%DATADIR%%/img/emptybell.png
+%%DATADIR%%/img/emptypopup.png
+%%DATADIR%%/img/exit.png
+%%DATADIR%%/img/firefox.png
+%%DATADIR%%/img/firefox_dis.png
+%%DATADIR%%/img/happy.png
+%%DATADIR%%/img/mars.png
+%%DATADIR%%/img/newmsg.png
+%%DATADIR%%/img/nochat.png
+%%DATADIR%%/img/nogender.png
+%%DATADIR%%/img/popup.png
+%%DATADIR%%/img/popupdef.png
+%%DATADIR%%/img/postit.png
+%%DATADIR%%/img/preferences.png
+%%DATADIR%%/img/question.png
+%%DATADIR%%/img/reconnect.png
+%%DATADIR%%/img/redclose.png
+%%DATADIR%%/img/roomempty.png
+%%DATADIR%%/img/roomgreen.png
+%%DATADIR%%/img/roomgrey.png
+%%DATADIR%%/img/roomred.png
+%%DATADIR%%/img/sad.png
+%%DATADIR%%/img/sendfile.png
+%%DATADIR%%/img/smallpostit.png
+%%DATADIR%%/img/smileys.png
+%%DATADIR%%/img/tb_away.ico
+%%DATADIR%%/img/tb_busy.ico
+%%DATADIR%%/img/tb_disconnected.ico
+%%DATADIR%%/img/tb_noactivity.ico
+%%DATADIR%%/img/tb_offline.ico
+%%DATADIR%%/img/tb_online.ico
+%%DATADIR%%/img/texte.png
+%%DATADIR%%/img/treeclosed.xpm
+%%DATADIR%%/img/treeempty.xpm
+%%DATADIR%%/img/treeopened.xpm
+%%DATADIR%%/img/updownload.png
+%%DATADIR%%/img/user.png
+%%DATADIR%%/img/users.png
+%%DATADIR%%/img/users2.png
+%%DATADIR%%/img/venus.png
+%%DATADIR%%/img/wait.png
+%%DATADIR%%/img/website.png
+%%DATADIR%%/img/close.png
+%%DATADIR%%/img/wink.png
+%%DATADIR%%/img/wooztalk.png
+%%DATADIR%%/img/woozie.png
+%%DATADIR%%/sounds/message.wav
+%%DATADIR%%/sounds/offline.wav
+%%DATADIR%%/sounds/online.wav
+share/locale/fr/LC_MESSAGES/wooztalk.po
+share/locale/en/LC_MESSAGES/wooztalk.po
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/fr/LC_MESSAGES