aboutsummaryrefslogtreecommitdiff
path: root/net-im/wooztalk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-22 11:28:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-22 11:28:04 +0000
commitd44bc27a060de894ff573ec595b7ec503fc375c3 (patch)
treee110d9cc0ddc984ab1143957fc6d68f47a5653ac /net-im/wooztalk
parent9c1b1b92c244ac9d0996baccddef58af3a1c7aef (diff)
downloadports-d44bc27a060de894ff573ec595b7ec503fc375c3.tar.gz
ports-d44bc27a060de894ff573ec595b7ec503fc375c3.zip
Notes
Diffstat (limited to 'net-im/wooztalk')
-rw-r--r--net-im/wooztalk/Makefile54
-rw-r--r--net-im/wooztalk/distinfo6
-rw-r--r--net-im/wooztalk/pkg-descr5
-rw-r--r--net-im/wooztalk/pkg-message3
-rw-r--r--net-im/wooztalk/pkg-plist26
5 files changed, 72 insertions, 22 deletions
diff --git a/net-im/wooztalk/Makefile b/net-im/wooztalk/Makefile
index 1976227641ad..dbfc20db2d47 100644
--- a/net-im/wooztalk/Makefile
+++ b/net-im/wooztalk/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= wooztalk
-PORTVERSION= 0.9.8d
-PORTREVISION= 1
+PORTVERSION= 0.9.9a
CATEGORIES= net-im
-MASTER_SITES= http://www.wooztalk.com/common/download/
+MASTER_SITES= http://www.wooztalk.com/download/
DISTNAME= ${PORTNAME}_v${PORTVERSION}-freebsd
MAINTAINER= tech@wooztalk.com
@@ -26,12 +25,57 @@ NO_BUILD= yes
USE_WX= 2.8
WX_UNICODE= yes
-OPTIONS= FIREFOX "Install Firefox extension (required)" On
+OPTIONS= FIREFOX "Firefox extension (required)" On \
+ DAILYMOTION "Dailymotion extension" On \
+ DEEZER "Deezer extension" On \
+ GOOGLEVIDEO "GoogleVideo extension" On \
+ IMEEM "Imeem extension" On \
+ JIWA "Jiwa extension" On \
+ LASTFM "Last.fm extension" On \
+ VIMEO "Vimeo extension" On \
+ VLC "VLC extension" On \
+ YOUTUBE "Youtube extension" On
.include <bsd.port.pre.mk>
.if defined(WITH_FIREFOX)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/firefoxonwooztalk@kurioos-itech.com:${PORTSDIR}/www/xpi-firefoxonwooztalk
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/firefoxonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-firefoxonwooztalk
+.endif
+
+.if defined(WITH_DAILYMOTION)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/dailymotiononwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-dailymotiononwooztalk
+.endif
+
+.if defined(WITH_DEEZER)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/deezeronwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-deezeronwooztalk
+.endif
+
+.if defined(WITH_GOOGLEVIDEO)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/googlevideoonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-googlevideoonwooztalk
+.endif
+
+.if defined(WITH_IMEEM)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/imeemonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-imeemonwooztalk
+.endif
+
+.if defined(WITH_JIWA)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/jiwaonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-jiwaonwooztalk
+.endif
+
+.if defined(WITH_LASTFM)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/lastfmonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-lastfmonwooztalk
+.endif
+
+.if defined(WITH_VIMEO)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/vimeoonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-vimeoonwooztalk
+.endif
+
+.if defined(WITH_VLC)
+RUN_DEPENDS+= ${LOCALBASE}/share/vlc/http/wooztalk.html:${PORTSDIR}/multimedia/vlconwooztalk
+.endif
+
+.if defined(WITH_YOUTUBE)
+RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/youtubeonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-youtubeonwooztalk
.endif
.if ${OSVERSION} < 700000
diff --git a/net-im/wooztalk/distinfo b/net-im/wooztalk/distinfo
index 918775092f26..5716084e1144 100644
--- a/net-im/wooztalk/distinfo
+++ b/net-im/wooztalk/distinfo
@@ -1,3 +1,3 @@
-MD5 (wooztalk_v0.9.8d-freebsd.tar.bz2) = f41610d1a1f89daf92cd8b9d7289d909
-SHA256 (wooztalk_v0.9.8d-freebsd.tar.bz2) = c032f5d7842a924b095078dcb0039aae3e41c442abf210fc45418f3c950c1282
-SIZE (wooztalk_v0.9.8d-freebsd.tar.bz2) = 1348268
+MD5 (wooztalk_v0.9.9a-freebsd.tar.bz2) = 1de87018c7048fc9eb670d561f1c0793
+SHA256 (wooztalk_v0.9.9a-freebsd.tar.bz2) = a5432a7534ee46443f1243cb44f4eec3d72d8e053e9bda50730129fe7b3b03d2
+SIZE (wooztalk_v0.9.9a-freebsd.tar.bz2) = 1358516
diff --git a/net-im/wooztalk/pkg-descr b/net-im/wooztalk/pkg-descr
index 783accefc098..d8d3fc2b3baf 100644
--- a/net-im/wooztalk/pkg-descr
+++ b/net-im/wooztalk/pkg-descr
@@ -1,5 +1,6 @@
-WoozTalk is a new innovative and free Internet service that let you see and chat
-with anyone else visiting the same website.
+WoozTalk is a new innovative and free Internet service that let you see and
+chat with anyone else visiting the same website, listening to the same music,
+or watching the same video at the same time as you!
As soon as you install WoozTalk, when you visit one of your favorite websites,
you will see others net surfers currently connected and you will be able to chat
diff --git a/net-im/wooztalk/pkg-message b/net-im/wooztalk/pkg-message
index 32b160f27607..aa7a65ea5dce 100644
--- a/net-im/wooztalk/pkg-message
+++ b/net-im/wooztalk/pkg-message
@@ -1 +1,2 @@
-Please restart firefox to enable the WoozTalk extension.
+
+Please restart firefox and vlc to enable WoozTalk extensions.
diff --git a/net-im/wooztalk/pkg-plist b/net-im/wooztalk/pkg-plist
index 0db58b541431..367821c5dac4 100644
--- a/net-im/wooztalk/pkg-plist
+++ b/net-im/wooztalk/pkg-plist
@@ -1,7 +1,6 @@
bin/wooztalk
-share/locale/en/LC_MESSAGES/wooztalk.po
-share/locale/fr/LC_MESSAGES/wooztalk.po
%%DATADIR%%/WoozTalk.ico
+%%DATADIR%%/wooztalk.pem
%%DATADIR%%/img/about.png
%%DATADIR%%/img/add.png
%%DATADIR%%/img/all.png
@@ -19,7 +18,6 @@ share/locale/fr/LC_MESSAGES/wooztalk.po
%%DATADIR%%/img/chatsubscribed.png
%%DATADIR%%/img/check.png
%%DATADIR%%/img/cheeky.png
-%%DATADIR%%/img/close.png
%%DATADIR%%/img/close_event.png
%%DATADIR%%/img/configURL.png
%%DATADIR%%/img/confused.png
@@ -36,6 +34,7 @@ share/locale/fr/LC_MESSAGES/wooztalk.po
%%DATADIR%%/img/newmsg.png
%%DATADIR%%/img/nochat.png
%%DATADIR%%/img/nogender.png
+%%DATADIR%%/img/plugins_config.png
%%DATADIR%%/img/popup.png
%%DATADIR%%/img/popupdef.png
%%DATADIR%%/img/postit.png
@@ -78,18 +77,23 @@ share/locale/fr/LC_MESSAGES/wooztalk.po
%%DATADIR%%/img/venus.png
%%DATADIR%%/img/wait.png
%%DATADIR%%/img/website.png
+%%DATADIR%%/img/close.png
%%DATADIR%%/img/wink.png
-%%DATADIR%%/img/woozie.png
%%DATADIR%%/img/wooztalk.png
-%%DATADIR%%/resources/en/wooztalk.po
-%%DATADIR%%/resources/fr/wooztalk.po
+%%DATADIR%%/img/woozie.png
%%DATADIR%%/sounds/message.wav
%%DATADIR%%/sounds/offline.wav
%%DATADIR%%/sounds/online.wav
-%%DATADIR%%/wooztalk.pem
-@dirrm %%DATADIR%%/sounds
-@dirrmtry %%DATADIR%%/resources/fr
-@dirrmtry %%DATADIR%%/resources/en
-@dirrmtry %%DATADIR%%/resources
+%%DATADIR%%/resources/fr/wooztalk.po
+%%DATADIR%%/resources/en/wooztalk.po
+share/locale/fr/LC_MESSAGES/wooztalk.po
+share/locale/en/LC_MESSAGES/wooztalk.po
+@dirrm %%DATADIR%%/resources/fr
+@dirrm %%DATADIR%%/resources/en
+@dirrm %%DATADIR%%/resources
@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/sounds
+@dirrmtry %%DATADIR%%/plugins
@dirrmtry %%DATADIR%%
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/fr/LC_MESSAGES