aboutsummaryrefslogtreecommitdiff
path: root/net-im/ysm
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@FreeBSD.org>2003-06-01 23:49:18 +0000
committercvs2svn <cvs2svn@FreeBSD.org>2003-06-01 23:49:18 +0000
commit6a294c20389911c409eb5f6f05033eaf6c6975ab (patch)
treeb621d2670693545124e161f6048aa76ec80ae631 /net-im/ysm
parentef70e9816ef935802e3a1e27b44f1c499b5cb27b (diff)
Notes
Diffstat (limited to 'net-im/ysm')
-rw-r--r--net-im/ysm/Makefile33
-rw-r--r--net-im/ysm/distinfo1
-rw-r--r--net-im/ysm/files/patch-Makefile.in13
-rw-r--r--net-im/ysm/files/patch-YSM_Network.c40
-rw-r--r--net-im/ysm/files/patch-YSM_ToolBox.c11
-rw-r--r--net-im/ysm/files/patch-setup12
-rw-r--r--net-im/ysm/pkg-descr7
-rw-r--r--net-im/ysm/pkg-plist1
8 files changed, 0 insertions, 118 deletions
diff --git a/net-im/ysm/Makefile b/net-im/ysm/Makefile
deleted file mode 100644
index 994ee5888ade..000000000000
--- a/net-im/ysm/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# New ports collection makefile for: ysm
-# Date created: May 28, 2002
-# Whom: vampiro
-#
-# $FreeBSD$
-#
-
-PORTNAME= ysm
-PORTVERSION= 7.2.8.1
-PORTREVISION= 1
-CATEGORIES= net
-MASTER_SITES= ftp://vampiro.rootshell.ru/pub/FreeBSD/distfiles/ \
- http://vampiro.rootshell.ru/ \
- ftp://ftp.treasury.ru/pub/unix/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ysmv7_2_8_1
-
-MAINTAINER= vampiro@rusunix.org
-COMMENT= Command line ICQ client with ICQ2000 and recoding support
-
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- CFLAGS="-DYSM_USE_ICONV ${PTHREAD_CFLAGS}" \
- LDFLAGS="${PTHREAD_LIBS} -lcipher -L${LOCALBASE}/lib -liconv"
-
-MAN1= ysm.1
-
-.include <bsd.port.mk>
diff --git a/net-im/ysm/distinfo b/net-im/ysm/distinfo
deleted file mode 100644
index 2a0dd2f2c157..000000000000
--- a/net-im/ysm/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (ysmv7_2_8_1.tar.bz2) = a01d246644b8c55be80e0bb3ab1b707a
diff --git a/net-im/ysm/files/patch-Makefile.in b/net-im/ysm/files/patch-Makefile.in
deleted file mode 100644
index 6fab81ddcb7e..000000000000
--- a/net-im/ysm/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.in.orig Fri Nov 1 16:26:19 2002
-+++ src/Makefile.in Fri Nov 1 16:26:30 2002
-@@ -6,8 +6,8 @@
-
- CC= @CC@
- CFLAGS= @CFLAGS@
--CPPFLAGS= -I. -Irijndael
--LIBS= @LIBS@
-+CPPFLAGS= -I. -Irijndael @CPPFLAGS@
-+LIBS= @LIBS@ @LDFLAGS@
-
- INSTALL= @INSTALL@
- prefix= @prefix@
diff --git a/net-im/ysm/files/patch-YSM_Network.c b/net-im/ysm/files/patch-YSM_Network.c
deleted file mode 100644
index 343da5c304f5..000000000000
--- a/net-im/ysm/files/patch-YSM_Network.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/YSM_Network.c.orig Wed Nov 13 18:18:35 2002
-+++ src/YSM_Network.c Wed Nov 13 18:26:12 2002
-@@ -3977,6 +3977,7 @@
- /* offline message variables */
- int uin,mlen;
- char *message,MsgType,MsgFlags,Msglen[2];
-+char *data_conv = 0;
- char o_month = 0, o_day = 0, o_hour = 0, o_minutes = 0;
- YSM_SLAVE *YSM_Query;
-
-@@ -4140,13 +4141,28 @@
- o_hour,
- o_minutes,
- NORMAL);
--
-+#ifdef YSM_USE_ICONV
-+ if( YSM_Iconv( YSM_SETTING_CHARSET_TRANS,
-+ YSM_SETTING_CHARSET_LOCAL,
-+ message,
-+ &data_conv,
-+ YSM_ICONV_MAXLEN) < 0 )
-+ data_conv = strdup (message);
-+ YSM_DisplayMsg (YSM_MESSAGE_NORMAL,
-+ uin,
-+ 0x0,
-+ mlen, data_conv,
-+ YSM_Query ? YSM_Query->NickName : NULL,
-+ YSM_Query ? YSM_Query->LogFlag : 0x0);
-+ free(data_conv);
-+#else
- YSM_DisplayMsg (YSM_MESSAGE_NORMAL,
- uin,
- 0x0,
- mlen, message,
- YSM_Query ? YSM_Query->NickName : NULL,
- YSM_Query ? YSM_Query->LogFlag : 0x0);
-+#endif
-
- break;
-
diff --git a/net-im/ysm/files/patch-YSM_ToolBox.c b/net-im/ysm/files/patch-YSM_ToolBox.c
deleted file mode 100644
index 614d96b74719..000000000000
--- a/net-im/ysm/files/patch-YSM_ToolBox.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/YSM_ToolBox.c.orig Wed Nov 13 18:26:47 2002
-+++ src/YSM_ToolBox.c Wed Nov 13 18:28:38 2002
-@@ -468,7 +468,7 @@
- return 1;
- }
-
-- bytes_res = iconv(conv_d, &inptr,
-+ bytes_res = iconv(conv_d, (const char **)&inptr,
- &bytes_in, &outptr, &bytes_out);
- iconv_close(conv_d);
-
diff --git a/net-im/ysm/files/patch-setup b/net-im/ysm/files/patch-setup
deleted file mode 100644
index d286710e8713..000000000000
--- a/net-im/ysm/files/patch-setup
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/YSM_Setup.c.orig Fri Nov 1 15:34:33 2002
-+++ src/YSM_Setup.c Fri Nov 1 15:34:56 2002
-@@ -596,8 +596,7 @@
-
- fprintf(YSM_CFGFD,"\n# TRANS_CHARSET is charset for transfering/receiving of messages");
- fprintf(YSM_CFGFD,"\n# LOCAL_CHARSET is charset for displaying/inputting of messages");
-- fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8R");
-- fprintf(YSM_CFGFD,"\n# FreeBSD users please use those in lowercase.\n");
-+ fprintf(YSM_CFGFD,"\n# Russian Generic are TRANS: CP1251 LOCAL: KOI8-R");
- fprintf(YSM_CFGFD,"\nCHARSET_TRANS>0");
- fprintf(YSM_CFGFD,"\nCHARSET_LOCAL>0");
- #endif
diff --git a/net-im/ysm/pkg-descr b/net-im/ysm/pkg-descr
deleted file mode 100644
index 9d8f03625e03..000000000000
--- a/net-im/ysm/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-You Sick Me - command line ICQ client with ICQ2000 and recoding support
-
-YSM (You Sick Me) v7 is an ICQ console client. It was originally meant to
-run in Linux, but it has been successfully tested in FreeBSD, Win32, BeOS,
-and QNX. YSM is based on the last ICQ protocol version, v7/8.
-
-WWW: http://ysmv7.sourceforge.net/
diff --git a/net-im/ysm/pkg-plist b/net-im/ysm/pkg-plist
deleted file mode 100644
index 41b2ae474002..000000000000
--- a/net-im/ysm/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/ysm