aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-10-09 18:06:15 +0000
committerSteve Wills <swills@FreeBSD.org>2018-10-09 18:06:15 +0000
commit1a80bb1732211eef4eb8d698afc4050602782c29 (patch)
treed94c4d4afff03b3c32fdc5ce92ff4d70ee29eda4 /net-im
parentc68a39284ea1f79b0dbbead4606da8bdac85cd0f (diff)
downloadports-1a80bb1732211eef4eb8d698afc4050602782c29.tar.gz
ports-1a80bb1732211eef4eb8d698afc4050602782c29.zip
net-im/fractal: create port
Fractal is a Gtk+ Matrix messaging client written in Rust. Its interface is optimized for collaboration in large groups such as free software projects. WWW: https://wiki.gnome.org/Apps/Fractal PR: 226683 Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=481644
Diffstat (limited to 'net-im')
-rw-r--r--net-im/fractal/Makefile39
-rw-r--r--net-im/fractal/distinfo3
-rw-r--r--net-im/fractal/files/patch-scripts_cargo.sh11
-rw-r--r--net-im/fractal/pkg-descr5
-rw-r--r--net-im/fractal/pkg-plist21
5 files changed, 79 insertions, 0 deletions
diff --git a/net-im/fractal/Makefile b/net-im/fractal/Makefile
new file mode 100644
index 000000000000..251fc4eb59a9
--- /dev/null
+++ b/net-im/fractal/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= fractal
+DISTVERSION= 3.30.0
+CATEGORIES= net-im
+MASTER_SITES= https://gitlab.gnome.org/World/fractal/uploads/${GL_HASH}/
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= GTK+ Matrix IM client
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+# gmake for the backtrace-sys crate
+BUILD_DEPENDS= cargo:lang/rust \
+ gmake:devel/gmake
+LIB_DEPENDS= libdbus-1.so:devel/dbus \
+ libgmp.so:math/gmp \
+ libgspell-1.so:textproc/gspell
+
+USES= gettext gnome meson pkgconfig python:3.5+,build ssl tar:xz
+USE_GNOME= cairo gtk30 gtksourceview3
+USE_GSTREAMER1= bad
+
+GL_HASH= cc46d6b9702ce5d0b1f3073f516a58c3
+BINARY_ALIAS= python3=${PYTHON_CMD}
+GLIB_SCHEMAS= org.gnome.Fractal.gschema.xml
+INSTALLS_ICONS= yes
+WITHOUT_FBSD10_FIX= yes # changes libbacktrace conf script's checksum
+
+# for the gettext-sys crate
+MAKE_ENV+= GETTEXT_BIN_DIR=${LOCALBASE}/bin \
+ GETTEXT_LIB_DIR=${LOCALBASE}/lib \
+ GETTEXT_INCLUDE_DIR=${LOCALBASE}/include
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fractal
+
+.include <bsd.port.mk>
diff --git a/net-im/fractal/distinfo b/net-im/fractal/distinfo
new file mode 100644
index 000000000000..04261c9ee4c6
--- /dev/null
+++ b/net-im/fractal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536754711
+SHA256 (fractal-3.30.0.tar.xz) = 4782a0ab59c5da2470a380700374d5c3d736085a66cf0de1fca9b2921c1f8363
+SIZE (fractal-3.30.0.tar.xz) = 11603220
diff --git a/net-im/fractal/files/patch-scripts_cargo.sh b/net-im/fractal/files/patch-scripts_cargo.sh
new file mode 100644
index 000000000000..58e3cdab179c
--- /dev/null
+++ b/net-im/fractal/files/patch-scripts_cargo.sh
@@ -0,0 +1,11 @@
+--- scripts/cargo.sh.orig 2018-09-12 12:22:27 UTC
++++ scripts/cargo.sh
+@@ -7,7 +7,7 @@ export FRACTAL_NAME_SUFFIX="$5"
+ export FRACTAL_VERSION="$6"
+ export FRACTAL_PROFILE="$7"
+
+-if [[ "$FRACTAL_PROFILE" == "Devel" ]]
++if [ "$FRACTAL_PROFILE" = "Devel" ]
+ then
+ echo "DEBUG MODE"
+ cargo build --manifest-path $1/Cargo.toml -p fractal-gtk && cp $1/target/debug/fractal-gtk $2
diff --git a/net-im/fractal/pkg-descr b/net-im/fractal/pkg-descr
new file mode 100644
index 000000000000..fabb033c5c9b
--- /dev/null
+++ b/net-im/fractal/pkg-descr
@@ -0,0 +1,5 @@
+Fractal is a Gtk+ Matrix messaging client written in Rust.
+Its interface is optimized for collaboration in large groups
+such as free software projects.
+
+WWW: https://wiki.gnome.org/Apps/Fractal
diff --git a/net-im/fractal/pkg-plist b/net-im/fractal/pkg-plist
new file mode 100644
index 000000000000..6115be0173e8
--- /dev/null
+++ b/net-im/fractal/pkg-plist
@@ -0,0 +1,21 @@
+bin/fractal
+share/applications/org.gnome.Fractal.desktop
+share/icons/hicolor/16x16/apps/org.gnome.Fractal.png
+share/icons/hicolor/22x22/apps/org.gnome.Fractal.png
+share/icons/hicolor/24x24/apps/org.gnome.Fractal.png
+share/icons/hicolor/32x32/apps/org.gnome.Fractal.png
+share/icons/hicolor/48x48/apps/org.gnome.Fractal.png
+share/icons/hicolor/512x512/apps/org.gnome.Fractal.png
+share/icons/hicolor/scalable/apps/org.gnome.Fractal-symbolic.svg
+share/locale/ca/LC_MESSAGES/fractal.mo
+share/locale/cs/LC_MESSAGES/fractal.mo
+share/locale/de/LC_MESSAGES/fractal.mo
+share/locale/es/LC_MESSAGES/fractal.mo
+share/locale/fi/LC_MESSAGES/fractal.mo
+share/locale/fr/LC_MESSAGES/fractal.mo
+share/locale/fur/LC_MESSAGES/fractal.mo
+share/locale/pl/LC_MESSAGES/fractal.mo
+share/locale/pt_BR/LC_MESSAGES/fractal.mo
+share/locale/sk/LC_MESSAGES/fractal.mo
+share/locale/sv/LC_MESSAGES/fractal.mo
+share/metainfo/org.gnome.Fractal.appdata.xml