aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2015-02-10 13:09:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2015-02-10 13:09:11 +0000
commitb2e21bc1988760823e17170117441fe6500a5802 (patch)
treea837d959e273b53da313e60315fb4197fe0c69ad /net-im
parenta5959f9cd111238a81d6986ee6f2dda67478e490 (diff)
downloadports-b2e21bc1988760823e17170117441fe6500a5802.tar.gz
ports-b2e21bc1988760823e17170117441fe6500a5802.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/proxy65/Makefile65
-rw-r--r--net-im/proxy65/distinfo2
-rw-r--r--net-im/proxy65/files/proxy65.in38
-rw-r--r--net-im/proxy65/files/proxy65.ini.sample5
-rw-r--r--net-im/proxy65/pkg-descr6
-rw-r--r--net-im/proxy65/pkg-plist1
7 files changed, 118 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 3ddbbfcda9d6..e830ae9d7040 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -115,6 +115,7 @@
SUBDIR += poezio
SUBDIR += pork
SUBDIR += prosody
+ SUBDIR += proxy65
SUBDIR += psi
SUBDIR += psimedia
SUBDIR += pwytter
diff --git a/net-im/proxy65/Makefile b/net-im/proxy65/Makefile
new file mode 100644
index 000000000000..72b8ed7c203a
--- /dev/null
+++ b/net-im/proxy65/Makefile
@@ -0,0 +1,65 @@
+# $FreeBSD$
+
+PORTNAME= proxy65
+PORTVERSION= 1.2.0.20150210
+CATEGORIES= net-im
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= XEP-0065 SOCKS5 Bytestreams external component for Jabber
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= mmatuska
+GH_COMMIT= 4e76bf2
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SINGLE= SERVER
+OPTIONS_SINGLE_SERVER= NOJABBER JABBER JABBERD EJABBERD
+OPTIONS_DEFAULT= NOJABBER
+NOJABBER_DESC= Do not depend on a jabber server
+JABBER_DESC= Use with jabberd14 (net-im/jabber)
+JABBERD_DESC= Use with jabberd 2.x (net-im/jabberd)
+EJABBERD_DESC= Use with ejabberd (net-im/ejabberd)
+
+USE_PYTHON= distutils autoplist
+USES= python:2 twisted:words
+USE_RC_SUBR= proxy65
+
+PORTDOCS= README
+
+PROXY65_USER= proxy65
+PROXY65_GROUP= proxy65
+USERS= ${PROXY65_USER}
+GROUPS= ${PROXY65_GROUP}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNOJABBER}
+# No jabber depends
+.elif ${PORT_OPTIONS:MJABBER}
+JABBER_REQUIRE?= jabber
+RUN_DEPENDS+= jabberd14:${PORTSDIR}/net-im/jabber
+.elif ${PORT_OPTIONS:MJABBERD}
+JABBER_REQUIRE?= jabberd
+RUN_DEPENDS+= jabberd:${PORTSDIR}/net-im/jabberd
+.elif ${PORT_OPTIONS:MEJABBERD}
+JABBER_REQUIRE?= ejabberd
+RUN_DEPENDS+= ejabberdctl:${PORTSDIR}/net-im/ejabberd
+.endif
+
+SUB_LIST+= PYTHON_CMD="${PYTHON_CMD}" \
+ JABBER_REQUIRE="${JABBER_REQUIRE}" \
+ PROXY65_USER=${PROXY65_USER} \
+ PROXY65_GROUP=${PROXY65_GROUP}
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} -m 0640 ${FILESDIR}/proxy65.ini.sample ${STAGEDIR}${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/net-im/proxy65/distinfo b/net-im/proxy65/distinfo
new file mode 100644
index 000000000000..cfb1b435ce04
--- /dev/null
+++ b/net-im/proxy65/distinfo
@@ -0,0 +1,2 @@
+SHA256 (proxy65-1.2.0.20150210.tar.gz) = ea3c03e0dd5dc14e44ce75335ff6843f8af9c94152654c1cd43ed1f679480f54
+SIZE (proxy65-1.2.0.20150210.tar.gz) = 9416
diff --git a/net-im/proxy65/files/proxy65.in b/net-im/proxy65/files/proxy65.in
new file mode 100644
index 000000000000..7a82ce4911b6
--- /dev/null
+++ b/net-im/proxy65/files/proxy65.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: proxy65
+# REQUIRE: DAEMON %%JABBER_REQUIRE%%
+
+. /etc/rc.subr
+
+#
+# Extra variables:
+# proxy65_jid = JID
+# proxy65_config = configuration file
+
+name="proxy65"
+rcvar=proxy65_enable
+command="%%PREFIX%%/bin/twistd"
+
+load_rc_config $name
+
+proxy65_enable=${proxy65_enable-"NO"}
+proxy65_uid=${proxy65_uid-"%%PROXY65_USER%%"}
+proxy65_gid=${proxy65_gid-"%%PROXY65_GROUP%%"}
+proxy65_logfile=${proxy65_logfile-"/var/log/proxy65.log"}
+proxy65_pidfile=${proxy65_pidfile-"/var/run/proxy65.pid"}
+proxy65_config=${proxy65_config-"%%PREFIX%%/etc/proxy65.ini"}
+
+required_files="${proxy65_config}"
+command_interpreter="%%PYTHON_CMD%%"
+pidfile=${proxy65_pidfile}
+
+if [ -n "${proxy65_jid}" ]; then
+ proxy65args="--jid ${proxy65_jid}"
+fi
+
+command_args="--originalname -u ${proxy65_uid} -g ${proxy65_gid} --pidfile ${pidfile} -l ${proxy65_logfile} proxy65 -c ${proxy65_config} ${proxy65args}"
+
+run_rc_command "$1"
diff --git a/net-im/proxy65/files/proxy65.ini.sample b/net-im/proxy65/files/proxy65.ini.sample
new file mode 100644
index 000000000000..1caa5ff1759a
--- /dev/null
+++ b/net-im/proxy65/files/proxy65.ini.sample
@@ -0,0 +1,5 @@
+[proxy65]
+rhost = 127.0.0.1
+rport = 6000
+secret = changeme
+proxyips = 0.0.0.0:7777
diff --git a/net-im/proxy65/pkg-descr b/net-im/proxy65/pkg-descr
new file mode 100644
index 000000000000..c657b8ca3b91
--- /dev/null
+++ b/net-im/proxy65/pkg-descr
@@ -0,0 +1,6 @@
+The proxy65 project is an external component (written on top of the Twisted
+Python library) that can be hooked up to existing Jabber/XMPP server to provide
+SOCKS5 Bytestreams functionality for file transfer between Jabber users, as
+specified in XEP-0065.
+
+WWW: https://github.com/mmatuska/proxy65/
diff --git a/net-im/proxy65/pkg-plist b/net-im/proxy65/pkg-plist
new file mode 100644
index 000000000000..bb1a3812264e
--- /dev/null
+++ b/net-im/proxy65/pkg-plist
@@ -0,0 +1 @@
+@sample etc/proxy65.ini.sample