aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /net-im
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centerim-devel/Makefile1
-rw-r--r--net-im/gale/Makefile13
-rw-r--r--net-im/gale/files/patch-iconvtest.c11
-rw-r--r--net-im/imspector/files/patch-icqprotocolplugin.cpp9
-rw-r--r--net-im/licq/Makefile9
-rw-r--r--net-im/licq/files/patch-cmake-Modules-FindIconv.cmake31
-rw-r--r--net-im/zephyr/Makefile15
7 files changed, 61 insertions, 28 deletions
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index 2a8a77a6aaf1..034d1629d434 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -21,6 +21,7 @@ USE_PERL5= run
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --with-openssl
+CPPFLAGS+= -I${LOCALBASE}/include
CONFLICTS= centericq-[0-9]* centerim-[0-9]*
SHEBANG_FILES= misc/cimformathistory misc/cimextracthistory.pl
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index cb39a8a27960..ce4e9910ec31 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gale
PORTVERSION= 0.99f
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-im
MASTER_SITES= http://download.ofb.net/${PORTNAME}/
DISTNAME= ${PORTNAME}-${PORTVERSION}ruit
@@ -22,14 +22,13 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/w3c-libwww
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
-# cheesy hack - test-oop doesn't build, but we don't care.
-pre-configure:
- ${REINPLACE_CMD} -e 's/\(^noinst_PROGRAMS =.*\)test-oop/\1/' \
+post-patch:
+ @${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/\(^noinst_PROGRAMS =.*\)test-oop/\1/' \
${WRKSRC}/liboop/Makefile.in
.include <bsd.port.mk>
diff --git a/net-im/gale/files/patch-iconvtest.c b/net-im/gale/files/patch-iconvtest.c
new file mode 100644
index 000000000000..7135ac2b2d22
--- /dev/null
+++ b/net-im/gale/files/patch-iconvtest.c
@@ -0,0 +1,11 @@
+--- iconvtest.c.orig 2000-11-18 06:38:47 UTC
++++ iconvtest.c
+@@ -27,7 +27,7 @@ int main() {
+ || utf[0] != 0x7f
+ || utf[1] != 0xdf || utf[2] != 0xbf
+ || utf[3] != 0xef || utf[4] != 0xbf || utf[5] != 0xbf) exit(1);
+- inbuf = utf; inbytes = 6;
++ inbuf = (char *) utf; inbytes = 6;
+ outbuf = (char *) wch; outbytes = sizeof(wch);
+ if (0 != iconv(from,&inbuf,&inbytes,&outbuf,&outbytes)
+ || 0 != inbytes || (sizeof(wch) - 3*sizeof(wchar_t)) != outbytes
diff --git a/net-im/imspector/files/patch-icqprotocolplugin.cpp b/net-im/imspector/files/patch-icqprotocolplugin.cpp
index 02e0d38e18fc..79143f26763e 100644
--- a/net-im/imspector/files/patch-icqprotocolplugin.cpp
+++ b/net-im/imspector/files/patch-icqprotocolplugin.cpp
@@ -8,15 +8,6 @@
#define PLUGIN_NAME "ICQ-AIM IMSpector protocol plugin"
#define PROTOCOL_NAME "ICQ-AIM"
-@@ -675,7 +676,7 @@
- size_t inbytesleft = mylength - 4;
- size_t outbytesleft = BUFFER_SIZE - 1; /* Trailing \0 */
- size_t result = iconv(iconv_utf16be_utf8,
-- &inbuf, &inbytesleft, &outbuf, &outbytesleft);
-+ (const char**) &inbuf, &inbytesleft, &outbuf, &outbytesleft);
-
- if (result == (size_t) -1)
- {
@@ -810,7 +811,7 @@
GET_TYPE(uint16_t)
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 4dba02d02883..c09a53737703 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -3,6 +3,7 @@
PORTNAME= base
PORTVERSION= ${LICQ_VER}
+PORTREVISION= 1
CATEGORIES= net-im
PKGNAMESUFFIX= ${SOCKS_SUFFIX}${PKGNAMESUFFIX2}
@@ -17,17 +18,13 @@ USES= cmake iconv
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
-# workaround for installed autoconf/automake
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib ${ICONV_LIB} -Wl,--export-dynamic
-CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -Wl,--export-dynamic -DGTEST_USE_OWN_TR1_TUPLE
+CXXFLAGS+= -DGTEST_USE_OWN_TR1_TUPLE
-OPTIONS_DEFINE= OPENSSL
+OPTIONS_DEFINE= NLS OPENSSL
OPTIONS_DEFAULT=OPENSSL
OPENSSL_USE= OPENSSL=yes
-OPENSSL_CONFIGURE_ON= --with-openssl-inc=${OPENSSLINC} --with-openssl-lib=${OPENSSLLIB}
.include <bsd.port.options.mk>
diff --git a/net-im/licq/files/patch-cmake-Modules-FindIconv.cmake b/net-im/licq/files/patch-cmake-Modules-FindIconv.cmake
new file mode 100644
index 000000000000..caa0375c4808
--- /dev/null
+++ b/net-im/licq/files/patch-cmake-Modules-FindIconv.cmake
@@ -0,0 +1,31 @@
+--- cmake/Modules/FindIconv.cmake.orig 2014-06-01 19:16:42 UTC
++++ cmake/Modules/FindIconv.cmake
+@@ -10,6 +10,7 @@
+ #
+ include(CheckCCompilerFlag)
+ include(CheckCXXSourceCompiles)
++include(CheckFunctionExists)
+
+ IF (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+ # Already in cache, be silent
+@@ -18,11 +19,15 @@ ENDIF (ICONV_INCLUDE_DIR AND ICONV_LIBRA
+
+ FIND_PATH(ICONV_INCLUDE_DIR iconv.h)
+
+-FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv c)
+-
+-IF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+- SET(ICONV_FOUND TRUE)
+-ENDIF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
++IF(ICONV_INCLUDE_DIR)
++ CHECK_FUNCTION_EXISTS(iconv ICONV_FOUND)
++ IF(NOT ICONV_FOUND)
++ FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2)
++ IF(ICONV_LIBRARIES)
++ SET(ICONV_FOUND TRUE)
++ ENDIF(ICONV_LIBRARIES)
++ ENDIF(NOT ICONV_FOUND)
++ENDIF(ICONV_INCLUDE_DIR)
+
+ set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR})
+ set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})
diff --git a/net-im/zephyr/Makefile b/net-im/zephyr/Makefile
index 948d8b29c06a..20231fd40748 100644
--- a/net-im/zephyr/Makefile
+++ b/net-im/zephyr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zephyr
DISTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= http://zephyr.1ts.org/export/2642/distribution/
@@ -13,6 +13,8 @@ COMMENT= Enterprise-scale distributed messaging system
LICENSE= MIT
GNU_CONFIGURE= yes
+# it is an upstream bug that --with-krb5 needs a path
+CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
USES= iconv libtool readline
USE_RC_SUBR= zhm
USE_LDCONFIG= yes
@@ -24,7 +26,11 @@ CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= HEIMDAL
HEIMDAL_DESC= Link against libss.so from security/heimdal
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_libiconv_open=no
+.endif
.if ${PORT_OPTIONS:MHEIMDAL}
BROKEN= bad depobj
@@ -39,13 +45,10 @@ LIB_DEPENDS+= libss.so.2:${PORTSDIR}/devel/e2fsprogs-libss
KRB5_DIR?= ${DESTDIR}/usr
.endif
-# it is an upstream bug that --with-krb5 needs a path
-CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
-
# try to fix parallel (-jX) builds: add missing inter-source dependencies
post-patch:
@${REINPLACE_CMD} -e \
'/^eval\.o/,$$s,port\.h,& string_stack.h new_string.h, ; \
s,_aux\.h,.h,' ${WRKSRC}/zwgc/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>