aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-03 18:31:14 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-03 18:31:14 +0000
commit8742a6b54c49d30fa0b979beda4e95e8444a0457 (patch)
treebe31325152c3f8a692c427a1247e98045090dcb3 /net-im
parentb1a20a1bdabaa85f2df06ede9effcf9eade7f275 (diff)
downloadports-8742a6b54c49d30fa0b979beda4e95e8444a0457.tar.gz
ports-8742a6b54c49d30fa0b979beda4e95e8444a0457.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/msn-proxy/Makefile29
-rw-r--r--net-im/msn-proxy/files/pkg-message.in24
-rw-r--r--net-im/msn-proxy/pkg-plist30
3 files changed, 82 insertions, 1 deletions
diff --git a/net-im/msn-proxy/Makefile b/net-im/msn-proxy/Makefile
index 3baedbf9c314..dbc726ed57b7 100644
--- a/net-im/msn-proxy/Makefile
+++ b/net-im/msn-proxy/Makefile
@@ -7,9 +7,9 @@
PORTNAME= msn-proxy
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF
-#DISTNAME= msn-proxy-${PORTVERSION}
MAINTAINER= loos.br@gmail.com
COMMENT= Messenger proxy/control daemon
@@ -18,15 +18,42 @@ LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
USE_MYSQL= yes
+SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
+
DOCS= INSTALL
+MSNPROXYWWW= ajax.inc.php al.inc.php bl.inc.php chat-to.php chat.php \
+ conf.php default.array.cmd.inc.php default.array.option.inc.php \
+ default.array.status.inc.php fl.inc.php group.inc.php \
+ header.inc.php index.php mysql.inc.php save_contact_op.php \
+ save_default_op.php save_msg.php save_user_op.php user.php \
+ view-to.php view.php
+MSNPROXYIMG= ausente.gif notinlist.png ocupado.gif offline.gif online.gif \
+ send_im.gif webcam.png
+
+WANT_PHP_WEB= yes
+USE_PHP= mysql
+MAKE_ARGS= SYSCONFDIR=$(DESTDIR)${PREFIX}/etc/msn-proxy \
+ BINDIR=$(DESTDIR)${PREFIX}/bin
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/config.h
post-install:
+ @${MKDIR} ${WWWDIR}
+.for FILE in ${MSNPROXYWWW}
+ @cd ${WRKSRC}/php && ${INSTALL} -m 644 ${FILE} ${WWWDIR}
+.endfor
+ @${MKDIR} ${WWWDIR}/imagens
+.for FILE in ${MSNPROXYIMG}
+ @cd ${WRKSRC}/php/imagens && ${INSTALL} -m 644 ${FILE} ${WWWDIR}/imagens
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
.endfor
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net-im/msn-proxy/files/pkg-message.in b/net-im/msn-proxy/files/pkg-message.in
new file mode 100644
index 000000000000..8965de2f5536
--- /dev/null
+++ b/net-im/msn-proxy/files/pkg-message.in
@@ -0,0 +1,24 @@
+------------------------------------------------
+msn-proxy post installation (basic) instructions
+------------------------------------------------
+
+On mysql create the database and the user to msn-proxy:
+> create database `msn-proxy`;
+> grant all privileges on `msn-proxy`.* to `msn-proxy`@localhost identified by 'secret';
+> flush privileges;
+
+Pay attention at "`" and "'" differences on mysql commands.
+
+At first run, msn-proxy will check and create the mysql tables, after that
+insert the default configuration (with your real proxy ip):
+
+> insert into defaults (internal_host) values ('192.168.0.1');
+
+Now the proxy should be ready to run, just redirect the msn clients to
+the proxy (all connections to the port 1863 should be redirect at your
+gateway / firewall).
+
+(text from %%DOCSDIR%%/INSTALL)
+
+------------------------------------------------
+
diff --git a/net-im/msn-proxy/pkg-plist b/net-im/msn-proxy/pkg-plist
index 45adf72998b8..c2f034b2989c 100644
--- a/net-im/msn-proxy/pkg-plist
+++ b/net-im/msn-proxy/pkg-plist
@@ -7,8 +7,38 @@ etc/msn-proxy/mysql/tables/defaults
etc/msn-proxy/mysql/tables/contact_groups
etc/msn-proxy/msn-proxy.conf
bin/msn-proxy
+%%WWWDIR%%/ajax.inc.php
+%%WWWDIR%%/al.inc.php
+%%WWWDIR%%/bl.inc.php
+%%WWWDIR%%/chat-to.php
+%%WWWDIR%%/chat.php
+%%WWWDIR%%/conf.php
+%%WWWDIR%%/default.array.cmd.inc.php
+%%WWWDIR%%/default.array.option.inc.php
+%%WWWDIR%%/default.array.status.inc.php
+%%WWWDIR%%/fl.inc.php
+%%WWWDIR%%/group.inc.php
+%%WWWDIR%%/header.inc.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/mysql.inc.php
+%%WWWDIR%%/save_contact_op.php
+%%WWWDIR%%/save_default_op.php
+%%WWWDIR%%/save_msg.php
+%%WWWDIR%%/save_user_op.php
+%%WWWDIR%%/user.php
+%%WWWDIR%%/view-to.php
+%%WWWDIR%%/view.php
+%%WWWDIR%%/imagens/ausente.gif
+%%WWWDIR%%/imagens/notinlist.png
+%%WWWDIR%%/imagens/ocupado.gif
+%%WWWDIR%%/imagens/offline.gif
+%%WWWDIR%%/imagens/online.gif
+%%WWWDIR%%/imagens/send_im.gif
+%%WWWDIR%%/imagens/webcam.png
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry etc/msn-proxy/mysql/tables
@dirrmtry etc/msn-proxy/mysql
@dirrmtry etc/msn-proxy
+@dirrmtry %%WWWDIR%%/imagens
+@dirrmtry %%WWWDIR%%