aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-02-10 16:42:01 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-02-10 16:42:01 +0000
commit9806b8369700e5c19b546359d1e3de97e395d6b3 (patch)
tree55b170744e7685f44a16cfe9b9950bf1703e0b4c /net-im
parentadb1ec21ee2ce6581ff4ed42d6c9ab89f07d405b (diff)
downloadports-9806b8369700e5c19b546359d1e3de97e395d6b3.tar.gz
ports-9806b8369700e5c19b546359d1e3de97e395d6b3.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/telepathy-qt/Makefile39
-rw-r--r--net-im/telepathy-qt/distinfo3
-rw-r--r--net-im/telepathy-qt/pkg-descr8
-rw-r--r--net-im/telepathy-qt/pkg-plist133
5 files changed, 184 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index e6e201f09e3d..e9730ccc00c9 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -125,6 +125,7 @@
SUBDIR += telepathy-glib
SUBDIR += telepathy-idle
SUBDIR += telepathy-python
+ SUBDIR += telepathy-qt
SUBDIR += telepathy-salut
SUBDIR += tkabber
SUBDIR += tkabber-devel
diff --git a/net-im/telepathy-qt/Makefile b/net-im/telepathy-qt/Makefile
new file mode 100644
index 000000000000..27bceec6f691
--- /dev/null
+++ b/net-im/telepathy-qt/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: telepathy-qt
+# Date created: 2008-02-10
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= telepathy-qt
+PORTVERSION= 0.14.1
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tapioca-voip
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Framework for VoIP and IP applications
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
+CMAKE?= ${LOCALBASE}/bin/cmake
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX} \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+USE_QT_VER= 4
+QT_COMPONENTS= corelib qmake uic moc rcc xml dbus
+USE_LDCONFIG= yes
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s,$${LIB_INSTALL_DIR}/pkgconfig,data/pkgconfig,g"\
+ ${WRKSRC}/../CMakeLists.txt
+
+do-configure:
+ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-qt/distinfo b/net-im/telepathy-qt/distinfo
new file mode 100644
index 000000000000..6bb35e8302f0
--- /dev/null
+++ b/net-im/telepathy-qt/distinfo
@@ -0,0 +1,3 @@
+MD5 (telepathy-qt-0.14.1.tar.gz) = 476e3fbd68b3eaf5354559be7de99333
+SHA256 (telepathy-qt-0.14.1.tar.gz) = caa3732609be9e6472e3062e7081ad03d07f78008db0bd235cd29c7330176467
+SIZE (telepathy-qt-0.14.1.tar.gz) = 46344
diff --git a/net-im/telepathy-qt/pkg-descr b/net-im/telepathy-qt/pkg-descr
new file mode 100644
index 000000000000..ef51e60c0766
--- /dev/null
+++ b/net-im/telepathy-qt/pkg-descr
@@ -0,0 +1,8 @@
+The Tapioca project provides a set of convenience libraries to easily
+integrate VoIP and IM in your application, or even write new ones.
+
+Tapioca follows the standard defined by the Telepathy project and therefore,
+operates seamlessly with its connection managers and other software that
+follows it as well.
+
+WWW: http://tapioca-voip.sourceforge.net/
diff --git a/net-im/telepathy-qt/pkg-plist b/net-im/telepathy-qt/pkg-plist
new file mode 100644
index 000000000000..7103f0c179f0
--- /dev/null
+++ b/net-im/telepathy-qt/pkg-plist
@@ -0,0 +1,133 @@
+include/QtTelepathy/Client/Channel
+include/QtTelepathy/Client/ChannelChatStateInterface
+include/QtTelepathy/Client/ChannelContactList
+include/QtTelepathy/Client/ChannelContactSearch
+include/QtTelepathy/Client/ChannelDTMFInterface
+include/QtTelepathy/Client/ChannelGroupInterface
+include/QtTelepathy/Client/ChannelHandler
+include/QtTelepathy/Client/ChannelHoldInterface
+include/QtTelepathy/Client/ChannelPasswordInterface
+include/QtTelepathy/Client/ChannelRoomList
+include/QtTelepathy/Client/ChannelStreamedMedia
+include/QtTelepathy/Client/ChannelText
+include/QtTelepathy/Client/ChannelTransferInterface
+include/QtTelepathy/Client/Connection
+include/QtTelepathy/Client/ConnectionAliasingInterface
+include/QtTelepathy/Client/ConnectionAvatarsInterface
+include/QtTelepathy/Client/ConnectionCapabilitiesInterface
+include/QtTelepathy/Client/ConnectionContactInfoInterface
+include/QtTelepathy/Client/ConnectionForwardingInterface
+include/QtTelepathy/Client/ConnectionManager
+include/QtTelepathy/Client/ConnectionPresenceInterface
+include/QtTelepathy/Client/ConnectionPrivacyInterface
+include/QtTelepathy/Client/ConnectionRenamingInterface
+include/QtTelepathy/Client/Properties
+include/QtTelepathy/Client/StreamEngine
+include/QtTelepathy/Client/channel.h
+include/QtTelepathy/Client/channelchatstateinterface.h
+include/QtTelepathy/Client/channelcontactlist.h
+include/QtTelepathy/Client/channelcontactsearch.h
+include/QtTelepathy/Client/channeldtmfinterface.h
+include/QtTelepathy/Client/channelgroupinterface.h
+include/QtTelepathy/Client/channelhandler.h
+include/QtTelepathy/Client/channelholdinterface.h
+include/QtTelepathy/Client/channelpasswordinterface.h
+include/QtTelepathy/Client/channelroomlist.h
+include/QtTelepathy/Client/channelstreamedmedia.h
+include/QtTelepathy/Client/channeltext.h
+include/QtTelepathy/Client/channeltransferinterface.h
+include/QtTelepathy/Client/connection.h
+include/QtTelepathy/Client/connectionaliasinginterface.h
+include/QtTelepathy/Client/connectionavatarsinterface.h
+include/QtTelepathy/Client/connectioncapabilitiesinterface.h
+include/QtTelepathy/Client/connectioncontactinfointerface.h
+include/QtTelepathy/Client/connectionforwardinginterface.h
+include/QtTelepathy/Client/connectionmanager.h
+include/QtTelepathy/Client/connectionpresenceinterface.h
+include/QtTelepathy/Client/connectionprivacyinterface.h
+include/QtTelepathy/Client/connectionrenaminginterface.h
+include/QtTelepathy/Client/properties.h
+include/QtTelepathy/Client/streamengine.h
+include/QtTelepathy/Common/BaseTypes
+include/QtTelepathy/Common/ChannelContactSearchTypes
+include/QtTelepathy/Common/ChannelGroupInterfaceTypes
+include/QtTelepathy/Common/ChannelRoomListTypes
+include/QtTelepathy/Common/ChannelStreamedMediaTypes
+include/QtTelepathy/Common/ChannelTextTypes
+include/QtTelepathy/Common/ConnectionAliasingInterfaceTypes
+include/QtTelepathy/Common/ConnectionCapabilitiesInterfaceTypes
+include/QtTelepathy/Common/ConnectionManagerTypes
+include/QtTelepathy/Common/ConnectionPresenceInterfaceTypes
+include/QtTelepathy/Common/ConnectionTypes
+include/QtTelepathy/Common/PropertiesTypes
+include/QtTelepathy/Common/basetypes.h
+include/QtTelepathy/Common/channelcontactsearchtypes.h
+include/QtTelepathy/Common/channelgroupinterfacetypes.h
+include/QtTelepathy/Common/channelroomlisttypes.h
+include/QtTelepathy/Common/channelstreamedmediatypes.h
+include/QtTelepathy/Common/channeltexttypes.h
+include/QtTelepathy/Common/connectionaliasinginterfacetypes.h
+include/QtTelepathy/Common/connectioncapabilitiesinterfacetypes.h
+include/QtTelepathy/Common/connectionmanagertypes.h
+include/QtTelepathy/Common/connectionpresenceinterfacetypes.h
+include/QtTelepathy/Common/connectiontypes.h
+include/QtTelepathy/Common/propertiestypes.h
+include/QtTelepathy/Core/CMakeLists.txt
+include/QtTelepathy/Core/ChannelAdaptor
+include/QtTelepathy/Core/ChannelContactSearchAdaptor
+include/QtTelepathy/Core/ChannelInterfaceDTMFAdaptor
+include/QtTelepathy/Core/ChannelInterfaceGroupAdaptor
+include/QtTelepathy/Core/ChannelInterfaceHoldAdaptor
+include/QtTelepathy/Core/ChannelInterfacePasswordAdaptor
+include/QtTelepathy/Core/ChannelInterfaceTransferAdaptor
+include/QtTelepathy/Core/ChannelRoomListAdaptor
+include/QtTelepathy/Core/ChannelStreamedMediaAdaptor
+include/QtTelepathy/Core/ChannelTypeTextAdaptor
+include/QtTelepathy/Core/ConnectionAdaptor
+include/QtTelepathy/Core/ConnectionInterfaceAliasingAdaptor
+include/QtTelepathy/Core/ConnectionInterfaceAvatarsAdaptor
+include/QtTelepathy/Core/ConnectionInterfaceCapabilitiesAdaptor
+include/QtTelepathy/Core/ConnectionInterfaceContactInfoAdaptor
+include/QtTelepathy/Core/ConnectionInterfaceForwardingAdaptor
+include/QtTelepathy/Core/ConnectionInterfacePresenceAdaptor
+include/QtTelepathy/Core/ConnectionInterfacePrivacyAdaptor
+include/QtTelepathy/Core/ConnectionInterfaceRenamingAdaptor
+include/QtTelepathy/Core/ConnectionManagerAdaptor
+include/QtTelepathy/Core/PropertiesAdaptor
+include/QtTelepathy/Core/channeladaptor.h
+include/QtTelepathy/Core/channelcontactsearchadaptor.h
+include/QtTelepathy/Core/channelinterfacedtmfadaptor.h
+include/QtTelepathy/Core/channelinterfacegroupadaptor.h
+include/QtTelepathy/Core/channelinterfaceholdadaptor.h
+include/QtTelepathy/Core/channelinterfacepasswordadaptor.h
+include/QtTelepathy/Core/channelinterfacetransferadaptor.h
+include/QtTelepathy/Core/channelroomlistadaptor.h
+include/QtTelepathy/Core/channelstreamedmediaadaptor.h
+include/QtTelepathy/Core/channeltypetextadaptor.h
+include/QtTelepathy/Core/connectionadaptor.h
+include/QtTelepathy/Core/connectioninterfacealiasingadaptor.h
+include/QtTelepathy/Core/connectioninterfaceavatarsadaptor.h
+include/QtTelepathy/Core/connectioninterfacecapabilitiesadaptor.h
+include/QtTelepathy/Core/connectioninterfacecontactinfoadaptor.h
+include/QtTelepathy/Core/connectioninterfaceforwardingadaptor.h
+include/QtTelepathy/Core/connectioninterfacepresenceadaptor.h
+include/QtTelepathy/Core/connectioninterfaceprivacyadaptor.h
+include/QtTelepathy/Core/connectioninterfacerenamingadaptor.h
+include/QtTelepathy/Core/connectionmanageradaptor.h
+include/QtTelepathy/Core/propertiesadaptor.h
+lib/libQtTelepathyClient.so
+lib/libQtTelepathyClient.so.0
+lib/libQtTelepathyClient.so.0.1.0
+lib/libQtTelepathyCommon.so
+lib/libQtTelepathyCommon.so.0
+lib/libQtTelepathyCommon.so.0.1.0
+lib/libQtTelepathyCore.so
+lib/libQtTelepathyCore.so.0
+lib/libQtTelepathyCore.so.0.1.0
+libdata/pkgconfig/QtTelepathyClient.pc
+libdata/pkgconfig/QtTelepathyCommon.pc
+libdata/pkgconfig/QtTelepathyCore.pc
+@dirrm include/QtTelepathy/Client
+@dirrm include/QtTelepathy/Common
+@dirrm include/QtTelepathy/Core
+@dirrm include/QtTelepathy