aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-09 03:56:51 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-09 03:56:51 +0000
commitda0bb730fb0d5e14e1a1d237455e86e78aa89415 (patch)
tree2ff431d6a6cc6a743043758109b69efff1965927 /net-im
parent2b0238e5e1a0cefe226ed0be831aa055dce19149 (diff)
downloadports-da0bb730fb0d5e14e1a1d237455e86e78aa89415.tar.gz
ports-da0bb730fb0d5e14e1a1d237455e86e78aa89415.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/trix/Makefile6
-rw-r--r--net-im/trix/distinfo6
-rw-r--r--net-im/trix/files/patch-crypto.cpp8
-rw-r--r--net-im/trix/files/patch-settings.cpp40
-rw-r--r--net-im/trix/files/patch-xxxprotocol.cpp31
-rw-r--r--net-im/trix/files/patch-xxxprotocol.h24
-rw-r--r--net-im/trix/pkg-descr1
-rw-r--r--net-im/trix/pkg-plist239
8 files changed, 166 insertions, 189 deletions
diff --git a/net-im/trix/Makefile b/net-im/trix/Makefile
index b2be0c2a3e99..586306dd6fb5 100644
--- a/net-im/trix/Makefile
+++ b/net-im/trix/Makefile
@@ -6,16 +6,14 @@
#
PORTNAME= trix
-PORTVERSION= 0.93
+PORTVERSION= 0.94
PORTREVISION= 1
CATEGORIES= net-im
+MASTER_SITES= SF
MAINTAINER= pascalamsg@gmail.com
COMMENT= TriX is a chat compatible with 2.0 protocol of the Vypress Chat
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
USE_QT_VER= 3
USE_GMAKE= yes
USE_PERL5= yes
diff --git a/net-im/trix/distinfo b/net-im/trix/distinfo
index 430926b3d12b..4dd439e3e334 100644
--- a/net-im/trix/distinfo
+++ b/net-im/trix/distinfo
@@ -1,3 +1,3 @@
-MD5 (trix-0.93.tar.bz2) = ad60f8b608fb08f8738deab69e1880f1
-SHA256 (trix-0.93.tar.bz2) = cf9e2df926277b79227900817e289e8fcf242922b3f233bb7d037e95cb3a3dd4
-SIZE (trix-0.93.tar.bz2) = 1050048
+MD5 (trix-0.94.tar.bz2) = 0d49c6dd0e8d281062dfbbc43f92f91b
+SHA256 (trix-0.94.tar.bz2) = 4ca2c49ebe0a422c0678212b2304b599c82542255fcf6add7efa548c7725ae5a
+SIZE (trix-0.94.tar.bz2) = 1018173
diff --git a/net-im/trix/files/patch-crypto.cpp b/net-im/trix/files/patch-crypto.cpp
deleted file mode 100644
index fd8745b38f2b..000000000000
--- a/net-im/trix/files/patch-crypto.cpp
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/crypto.cpp.orig 2008-01-04 18:25:54.000000000 +0200
-+++ src/crypto.cpp 2008-04-21 01:30:02.000000000 +0300
-@@ -1,4 +1,5 @@
- #include "crypto.h"
-+typedef unsigned int uint;
- //#include <iostream>
-
- PROV_ENUMALGS_EX aProvEnumAlgsEx[4][RSAENH_MAX_ENUMALGS+1] =
diff --git a/net-im/trix/files/patch-settings.cpp b/net-im/trix/files/patch-settings.cpp
index 855a086dc30d..64fcbd1f07e3 100644
--- a/net-im/trix/files/patch-settings.cpp
+++ b/net-im/trix/files/patch-settings.cpp
@@ -1,29 +1,17 @@
---- src/settings.cpp.orig 2008-01-04 18:25:54.000000000 +0200
-+++ src/settings.cpp 2008-04-24 00:55:06.000000000 +0300
-@@ -8,15 +8,12 @@
-
- #include <unistd.h>
- #include <sys/ioctl.h>
--#include <net/if.h>
-+#include <netinet/in.h>
- #include <sys/socket.h>
-+#include <net/if.h>
- #include <sys/types.h>
- #include <arpa/inet.h>
--
--#ifdef FREEBSD
- #include <net/route.h>
--#include <netinet/in.h>
--#endif
-
- #endif
-
-@@ -279,7 +276,7 @@
- #if defined ( WIN32 )
- def_playcmd = "";
- #else
+--- src/settings.cpp.orig 2008-06-29 20:24:50.000000000 +0300
++++ src/settings.cpp 2008-07-02 18:31:27.000000000 +0300
+@@ -143,11 +143,10 @@
+ def_downloadpath=QDir::homeDirPath();
+ def_awaylimit=1800;
+ def_autoupdateinterval = 300;
+-#ifdef BSD
++
+ def_playcmd="/usr/local/bin/play";
+-#else
- def_playcmd = "/usr/bin/aplay";
-+ def_playcmd = "/usr/local/bin/play";
- #endif
+-#endif
++
++
def_snd[Sound::Chatline] = datapath + "snd/chatline.wav";
def_snd[Sound::Beep] = datapath + "snd/beep.wav";
+ def_snd[Sound::JoinChannel] = datapath + "snd/join.wav";
diff --git a/net-im/trix/files/patch-xxxprotocol.cpp b/net-im/trix/files/patch-xxxprotocol.cpp
index 1da7cdd2d6ae..5ae9e5b6e333 100644
--- a/net-im/trix/files/patch-xxxprotocol.cpp
+++ b/net-im/trix/files/patch-xxxprotocol.cpp
@@ -1,37 +1,42 @@
---- src/xxxprotocol.cpp.orig 2008-01-04 18:25:54.000000000 +0200
-+++ src/xxxprotocol.cpp 2008-04-21 01:19:07.000000000 +0300
+--- src/xxxprotocol.cpp.orig 2008-06-29 19:17:33.000000000 +0100
++++ src/xxxprotocol.cpp 2008-07-02 13:20:41.000000000 +0100
@@ -8,6 +8,7 @@
#include <quuid.h>
#include <qsocketnotifier.h>
#include <qmessagebox.h>
+#include <sys/param.h>
- #ifdef WIN32
- #include <winsock.h>
- #else
-@@ -21,7 +22,7 @@
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+@@ -17,12 +18,11 @@
+ #include <unistd.h>
#include <fcntl.h>
- #endif
-#ifdef FREEBSD
+#ifdef BSD
#include <err.h>
#include <errno.h>
#include <net/if.h>
-@@ -223,7 +224,7 @@
+ #include <sys/sysctl.h>
+-#include <sys/param.h>
+ #include <netinet/if_ether.h>
+ #include <net/route.h>
+ #include <net/if_dl.h>
+@@ -207,7 +207,7 @@
QString XXXProtocol::getHWAddr(const QString& addr, const QString& iface)
{
QString macaddr(tr("Unknown"));
--#if defined( FREEBSD )
-+#if defined( BSD )
+-#ifdef BSD
++#if defined ( BSD )
struct sockaddr_inarp addr_inarp;
bzero(&addr_inarp, sizeof(addr_inarp));
-@@ -265,7 +266,7 @@
+@@ -249,7 +249,7 @@
return macaddr;
}
--#if defined( FREEBSD )
-+#if defined( BSD )
+-#ifdef BSD
++#if defined ( BSD )
struct sockaddr_dl * XXXProtocol::search(u_long addr)
{
int mib[6];
diff --git a/net-im/trix/files/patch-xxxprotocol.h b/net-im/trix/files/patch-xxxprotocol.h
index d7017cb289fb..abb171bf0183 100644
--- a/net-im/trix/files/patch-xxxprotocol.h
+++ b/net-im/trix/files/patch-xxxprotocol.h
@@ -1,20 +1,14 @@
---- src/xxxprotocol.h.orig 2008-01-04 18:25:54.000000000 +0200
-+++ src/xxxprotocol.h 2008-04-21 01:20:02.000000000 +0300
-@@ -4,7 +4,7 @@
- #include "global.h"
- #include "tcpsocket.h"
- #include "crypto.h"
--
-+#include <sys/param.h>
- #ifdef WIN32
- #include <winsock.h>
- #endif
-@@ -31,7 +31,7 @@
+--- src/xxxprotocol.h.orig 2008-06-29 18:29:01.000000000 +0100
++++ src/xxxprotocol.h 2008-07-02 13:17:12.000000000 +0100
+@@ -31,9 +31,9 @@
uint port;
int recvsd; //UDP socket
--#if defined( FREEBSD )
-+#if defined( BSD )
+-#ifdef BSD
++
struct sockaddr_dl *search(u_long addr);
- #endif
+-#endif
++
+ struct UserSpec {
+ char codec;
diff --git a/net-im/trix/pkg-descr b/net-im/trix/pkg-descr
index aec334a02afb..8487df383e2d 100644
--- a/net-im/trix/pkg-descr
+++ b/net-im/trix/pkg-descr
@@ -6,4 +6,3 @@ Now TriX is compatible with the version 2.0 of the Vypress Chat
protocol developed by VyPRESS Research.
WWW: http://trix.sourceforge.net/
-
diff --git a/net-im/trix/pkg-plist b/net-im/trix/pkg-plist
index f43efc60fac3..9f58c1ab8d98 100644
--- a/net-im/trix/pkg-plist
+++ b/net-im/trix/pkg-plist
@@ -1,120 +1,121 @@
bin/trix
-share/trix/avatars/bird.gif
-share/trix/avatars/blue_angel.jpg
-share/trix/avatars/blue_sky.jpg
-share/trix/avatars/dark.jpg
-share/trix/avatars/dark_angel.jpg
-share/trix/avatars/edward.gif
-share/trix/avatars/female_face_1.jpg
-share/trix/avatars/hand.jpg
-share/trix/avatars/red.jpg
-share/trix/avatars/tekila.jpg
-share/trix/avatars/white_angel.jpg
-share/trix/gfx/about.png
-share/trix/gfx/angel.png
-share/trix/gfx/angry.png
-share/trix/gfx/automessage.png
-share/trix/gfx/bat.png
-share/trix/gfx/beep.png
-share/trix/gfx/beer.png
-share/trix/gfx/boardnormal.png
-share/trix/gfx/cake.png
-share/trix/gfx/cat.png
-share/trix/gfx/cbblank.png
-share/trix/gfx/cbchecked.png
-share/trix/gfx/chnlalert.png
-share/trix/gfx/chnlnormal.png
-share/trix/gfx/clear.png
-share/trix/gfx/clock.png
-share/trix/gfx/cocktail.png
-share/trix/gfx/colors.png
-share/trix/gfx/confused.png
-share/trix/gfx/copy.png
-share/trix/gfx/cry.png
-share/trix/gfx/cup.png
-share/trix/gfx/decrypted.png
-share/trix/gfx/default.png
-share/trix/gfx/devil.png
-share/trix/gfx/dog.png
-share/trix/gfx/down.png
-share/trix/gfx/downarrows.png
-share/trix/gfx/dude_hug.png
-share/trix/gfx/edit.png
-share/trix/gfx/editclear.png
-share/trix/gfx/editcut.png
-share/trix/gfx/editpaste.png
-share/trix/gfx/embarassed.png
-share/trix/gfx/encrypted.png
-share/trix/gfx/exit.png
-share/trix/gfx/female.png
-share/trix/gfx/film.png
-share/trix/gfx/find.png
-share/trix/gfx/fonts.png
-share/trix/gfx/forward.png
-share/trix/gfx/gear.png
-share/trix/gfx/girl_hug.png
-share/trix/gfx/info.png
-share/trix/gfx/kiss.png
-share/trix/gfx/leave.png
-share/trix/gfx/lightbulb.png
-share/trix/gfx/locale.png
-share/trix/gfx/logo.png
-share/trix/gfx/love.png
-share/trix/gfx/mail.png
-share/trix/gfx/male.png
-share/trix/gfx/massmessage.png
-share/trix/gfx/message.png
-share/trix/gfx/network.png
-share/trix/gfx/new.png
-share/trix/gfx/normal.png
-share/trix/gfx/notify.png
-share/trix/gfx/omg.png
-share/trix/gfx/phone.png
-share/trix/gfx/photo.png
-share/trix/gfx/present.png
-share/trix/gfx/prvalert.png
-share/trix/gfx/prvnormal.png
-share/trix/gfx/refresh.png
-share/trix/gfx/rose.png
-share/trix/gfx/sad.png
-share/trix/gfx/save.png
-share/trix/gfx/saveas.png
-share/trix/gfx/saynick.png
-share/trix/gfx/send.png
-share/trix/gfx/settings.png
-share/trix/gfx/shade.png
-share/trix/gfx/sleep.png
-share/trix/gfx/smile.png
-share/trix/gfx/smiletris.png
-share/trix/gfx/sound.png
-share/trix/gfx/star.png
-share/trix/gfx/switchuser.png
-share/trix/gfx/sysmsg.png
-share/trix/gfx/teeth.png
-share/trix/gfx/thumbs_down.png
-share/trix/gfx/thumbs_up.png
-share/trix/gfx/tongue.png
-share/trix/gfx/trash.png
-share/trix/gfx/trayntfy.png
-share/trix/gfx/unlove.png
-share/trix/gfx/uparrows.png
-share/trix/gfx/useraway.png
-share/trix/gfx/userdnd.png
-share/trix/gfx/useroffline.png
-share/trix/gfx/users.png
-share/trix/gfx/wilted_rose.png
-share/trix/gfx/wink.png
-share/trix/gfx/xedit.png
-share/trix/snd/beep.wav
-share/trix/snd/chatline.wav
-share/trix/snd/join.wav
-share/trix/snd/leave.wav
-share/trix/snd/message.wav
-share/trix/tr/trix_bg.qm
-share/trix/tr/trix_en.qm
-share/trix/tr/trix_ru.qm
-@dirrm share/trix/tr
-@dirrm share/trix/snd
-@dirrm share/trix/gfx
-@dirrm share/trix/avatars
-@dirrm share/trix
+%%DATADIR%%/avatars/bird.gif
+%%DATADIR%%/avatars/blue_angel.jpg
+%%DATADIR%%/avatars/blue_sky.jpg
+%%DATADIR%%/avatars/dark.jpg
+%%DATADIR%%/avatars/dark_angel.jpg
+%%DATADIR%%/avatars/edward.gif
+%%DATADIR%%/avatars/female_face_1.jpg
+%%DATADIR%%/avatars/hand.jpg
+%%DATADIR%%/avatars/red.jpg
+%%DATADIR%%/avatars/tekila.jpg
+%%DATADIR%%/avatars/white_angel.jpg
+%%DATADIR%%/gfx/about.png
+%%DATADIR%%/gfx/angel.png
+%%DATADIR%%/gfx/angry.png
+%%DATADIR%%/gfx/automessage.png
+%%DATADIR%%/gfx/bat.png
+%%DATADIR%%/gfx/beep.png
+%%DATADIR%%/gfx/beer.png
+%%DATADIR%%/gfx/boardnormal.png
+%%DATADIR%%/gfx/cake.png
+%%DATADIR%%/gfx/cat.png
+%%DATADIR%%/gfx/cbblank.png
+%%DATADIR%%/gfx/cbchecked.png
+%%DATADIR%%/gfx/chnlalert.png
+%%DATADIR%%/gfx/chnlnormal.png
+%%DATADIR%%/gfx/clear.png
+%%DATADIR%%/gfx/clock.png
+%%DATADIR%%/gfx/cocktail.png
+%%DATADIR%%/gfx/colors.png
+%%DATADIR%%/gfx/confused.png
+%%DATADIR%%/gfx/copy.png
+%%DATADIR%%/gfx/cry.png
+%%DATADIR%%/gfx/cup.png
+%%DATADIR%%/gfx/decrypted.png
+%%DATADIR%%/gfx/default.png
+%%DATADIR%%/gfx/devil.png
+%%DATADIR%%/gfx/dog.png
+%%DATADIR%%/gfx/down.png
+%%DATADIR%%/gfx/downarrows.png
+%%DATADIR%%/gfx/dude_hug.png
+%%DATADIR%%/gfx/edit.png
+%%DATADIR%%/gfx/editclear.png
+%%DATADIR%%/gfx/editcut.png
+%%DATADIR%%/gfx/editpaste.png
+%%DATADIR%%/gfx/embarassed.png
+%%DATADIR%%/gfx/encrypted.png
+%%DATADIR%%/gfx/exit.png
+%%DATADIR%%/gfx/female.png
+%%DATADIR%%/gfx/film.png
+%%DATADIR%%/gfx/find.png
+%%DATADIR%%/gfx/fonts.png
+%%DATADIR%%/gfx/forward.png
+%%DATADIR%%/gfx/gear.png
+%%DATADIR%%/gfx/girl_hug.png
+%%DATADIR%%/gfx/info.png
+%%DATADIR%%/gfx/kiss.png
+%%DATADIR%%/gfx/leave.png
+%%DATADIR%%/gfx/lightbulb.png
+%%DATADIR%%/gfx/locale.png
+%%DATADIR%%/gfx/logo.png
+%%DATADIR%%/gfx/love.png
+%%DATADIR%%/gfx/mail.png
+%%DATADIR%%/gfx/male.png
+%%DATADIR%%/gfx/massmessage.png
+%%DATADIR%%/gfx/message.png
+%%DATADIR%%/gfx/network.png
+%%DATADIR%%/gfx/new.png
+%%DATADIR%%/gfx/normal.png
+%%DATADIR%%/gfx/notify.png
+%%DATADIR%%/gfx/omg.png
+%%DATADIR%%/gfx/phone.png
+%%DATADIR%%/gfx/photo.png
+%%DATADIR%%/gfx/present.png
+%%DATADIR%%/gfx/prvalert.png
+%%DATADIR%%/gfx/prvnormal.png
+%%DATADIR%%/gfx/refresh.png
+%%DATADIR%%/gfx/rose.png
+%%DATADIR%%/gfx/sad.png
+%%DATADIR%%/gfx/save.png
+%%DATADIR%%/gfx/saveas.png
+%%DATADIR%%/gfx/saynick.png
+%%DATADIR%%/gfx/send.png
+%%DATADIR%%/gfx/settings.png
+%%DATADIR%%/gfx/shade.png
+%%DATADIR%%/gfx/sleep.png
+%%DATADIR%%/gfx/smile.png
+%%DATADIR%%/gfx/smiletris.png
+%%DATADIR%%/gfx/sound.png
+%%DATADIR%%/gfx/star.png
+%%DATADIR%%/gfx/switchuser.png
+%%DATADIR%%/gfx/sysmsg.png
+%%DATADIR%%/gfx/teeth.png
+%%DATADIR%%/gfx/thumbs_down.png
+%%DATADIR%%/gfx/thumbs_up.png
+%%DATADIR%%/gfx/tongue.png
+%%DATADIR%%/gfx/trash.png
+%%DATADIR%%/gfx/trayntfy.png
+%%DATADIR%%/gfx/unlove.png
+%%DATADIR%%/gfx/uparrows.png
+%%DATADIR%%/gfx/useraway.png
+%%DATADIR%%/gfx/userdnd.png
+%%DATADIR%%/gfx/useroffline.png
+%%DATADIR%%/gfx/users.png
+%%DATADIR%%/gfx/wilted_rose.png
+%%DATADIR%%/gfx/wink.png
+%%DATADIR%%/gfx/xedit.png
+%%DATADIR%%/snd/beep.wav
+%%DATADIR%%/snd/chatline.wav
+%%DATADIR%%/snd/join.wav
+%%DATADIR%%/snd/leave.wav
+%%DATADIR%%/snd/message.wav
+%%DATADIR%%/tr/trix_bg.qm
+%%DATADIR%%/tr/trix_en.qm
+%%DATADIR%%/tr/trix_ru.qm
+%%DATADIR%%/tr/trix_sp.qm
+@dirrm %%DATADIR%%/tr
+@dirrm %%DATADIR%%/snd
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/avatars
+@dirrm %%DATADIR%%