aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-10-07 11:33:46 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-10-07 11:33:46 +0000
commitdf0e7ad62d21b08ce856d254bb1fefdffbe67fd4 (patch)
treec2103c8c95a7d7a986668be76635fd161b995d49 /net-im
parentb380b863d3d298ba2d16bfdfea39a0db2100a54f (diff)
downloadports-df0e7ad62d21b08ce856d254bb1fefdffbe67fd4.tar.gz
ports-df0e7ad62d21b08ce856d254bb1fefdffbe67fd4.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber-pyicq/Makefile6
-rw-r--r--net-im/jabber-pyicq/files/patch-src__contact.py11
-rw-r--r--net-im/jabber-pyicq/files/patch-src__imgmanip.py11
-rw-r--r--net-im/jabber-pyicq/files/patch-tools__infodump.py11
4 files changed, 36 insertions, 3 deletions
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index 342881537cc8..aba0444a442b 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pyicq
PORTVERSION= 0.8.1.5
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -17,7 +17,7 @@ COMMENT= Python ICQ-Transport for Jabber
LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl \
- ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
PROJECTHOST= pyicqt
OPTIONS_DEFINE= DOCS EXAMPLES MYSQL TWISTED
@@ -31,7 +31,7 @@ DAEMON_DESC= Use builtin daemon
TWISTED_DESC= Use py-twisted
NO_BUILD= yes
-USE_PYTHON= yes
+USES= python
USE_RC_SUBR= jabber-pyicq-transport
LOCAL_PYTHON= ${PYTHON_CMD}
diff --git a/net-im/jabber-pyicq/files/patch-src__contact.py b/net-im/jabber-pyicq/files/patch-src__contact.py
new file mode 100644
index 000000000000..c9ca2e0964a4
--- /dev/null
+++ b/net-im/jabber-pyicq/files/patch-src__contact.py
@@ -0,0 +1,11 @@
+--- src/contact.py.orig 2014-10-06 16:48:44 UTC
++++ src/contact.py
+@@ -13,7 +13,7 @@
+ import globals
+ import base64
+ if not config.disableAvatars:
+- import Image
++ from PIL import Image
+ import StringIO
+
+
diff --git a/net-im/jabber-pyicq/files/patch-src__imgmanip.py b/net-im/jabber-pyicq/files/patch-src__imgmanip.py
new file mode 100644
index 000000000000..d42cb886d658
--- /dev/null
+++ b/net-im/jabber-pyicq/files/patch-src__imgmanip.py
@@ -0,0 +1,11 @@
+--- src/imgmanip.py.orig 2014-10-06 16:49:20 UTC
++++ src/imgmanip.py
+@@ -5,7 +5,7 @@
+
+ if not config.disableAvatars:
+ try:
+- import Image
++ from PIL import Image
+ import StringIO
+
+ def convertToPNG(imageData):
diff --git a/net-im/jabber-pyicq/files/patch-tools__infodump.py b/net-im/jabber-pyicq/files/patch-tools__infodump.py
new file mode 100644
index 000000000000..0be2ae5ecb93
--- /dev/null
+++ b/net-im/jabber-pyicq/files/patch-tools__infodump.py
@@ -0,0 +1,11 @@
+--- tools/infodump.py.orig 2014-10-06 16:48:04 UTC
++++ tools/infodump.py
+@@ -41,7 +41,7 @@
+ print "Nevow Version: Unknown or Not Installed"
+
+ try:
+- from Image import VERSION
++ from PIL.Image import VERSION
+ print "Python Imaging Library (PIL) Version: " + VERSION
+ except:
+ print "Python Imaging Library (PIL) Version: Unknown or Not Installed"