aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-06 07:19:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-06 07:19:10 +0000
commit64d4501c2ef9ca499e3b665ea3b7c5ae44ca7898 (patch)
tree673ee261a656f61fcf218acc6016f49b7d184f48 /net-im
parent1387c08f50eae1944dd1d9c4b4e492e64bd13745 (diff)
downloadports-64d4501c2ef9ca499e3b665ea3b7c5ae44ca7898.tar.gz
ports-64d4501c2ef9ca499e3b665ea3b7c5ae44ca7898.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/pidgin-msn-pecan/Makefile26
-rw-r--r--net-im/pidgin-msn-pecan/distinfo3
-rw-r--r--net-im/pidgin-msn-pecan/files/patch-Makefile11
-rw-r--r--net-im/pidgin-msn-pecan/pkg-descr12
5 files changed, 53 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 2fd327f1dd13..7a823933ba72 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -110,6 +110,7 @@
SUBDIR += pidgin-latex
SUBDIR += pidgin-libnotify
SUBDIR += pidgin-manualsize
+ SUBDIR += pidgin-msn-pecan
SUBDIR += pidgin-rhythmbox
SUBDIR += pidgin-twitter
SUBDIR += pork
diff --git a/net-im/pidgin-msn-pecan/Makefile b/net-im/pidgin-msn-pecan/Makefile
new file mode 100644
index 000000000000..fdbd9abe6671
--- /dev/null
+++ b/net-im/pidgin-msn-pecan/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pidgin-msn-pecan
+# Date created: 30 July 2008
+# Whom: hrkfrd@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= msn-pecan
+PORTVERSION= 0.0.14
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= hrkfrd@gmail.com
+COMMENT= Alternative MSN protocol plugin for libpurple
+
+LIB_DEPENDS= purple.4:${PORTSDIR}/net-im/libpurple
+
+PROJECTHOST= msn-pecan
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/purple-2/libmsn-pecan.so
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-msn-pecan/distinfo b/net-im/pidgin-msn-pecan/distinfo
new file mode 100644
index 000000000000..d18e94eb7bea
--- /dev/null
+++ b/net-im/pidgin-msn-pecan/distinfo
@@ -0,0 +1,3 @@
+MD5 (msn-pecan-0.0.14.tar.bz2) = e2e31a797e867654df055f3d8abad32a
+SHA256 (msn-pecan-0.0.14.tar.bz2) = a656ec6a160bbc8a3340ad1204b17c64466dcae8c6ce8cde3faa7f6e4c4f39ca
+SIZE (msn-pecan-0.0.14.tar.bz2) = 88122
diff --git a/net-im/pidgin-msn-pecan/files/patch-Makefile b/net-im/pidgin-msn-pecan/files/patch-Makefile
new file mode 100644
index 000000000000..18ff51bc88ce
--- /dev/null
+++ b/net-im/pidgin-msn-pecan/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- _Makefile 2008-08-03 20:08:19.000000000 +0000
++++ Makefile 2008-08-03 20:08:29.000000000 +0000
+@@ -32,7 +32,7 @@
+ # For glib < 2.6 support (libpurple maniacs)
+ FALLBACK_CFLAGS+=-I./fix_purple
+
+-LDFLAGS:=-Wl,--no-undefined
++LDFLAGS:=-Wl,--no-undefined,-lc
+
+ purpledir=$(DESTDIR)/$(PURPLE_PREFIX)/lib/purple-2
+
diff --git a/net-im/pidgin-msn-pecan/pkg-descr b/net-im/pidgin-msn-pecan/pkg-descr
new file mode 100644
index 000000000000..d90f34e76fa9
--- /dev/null
+++ b/net-im/pidgin-msn-pecan/pkg-descr
@@ -0,0 +1,12 @@
+msn-pecan is an alternative MSN protocol plugin for libpurple.
+
+Features include:
+* Support for personal messages
+* Server-side storage for display names (private alias)
+* Partial direct connection support (p2p transfers)
+* Improved network IO (using GIOChannel)
+* Improved error handling
+* Network issues tested with netem
+* GObject usage
+
+WWW: http://code.google.com/p/msn-pecan/