aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 08:12:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 08:12:11 +0000
commitab0b1f8d32a18ba0b819967ef3589695149edf58 (patch)
tree947e428d7a6ddb587ab0d61e3d9fb15fba73c5fd /net-im
parentb62fac1e235aece8f40f52edb9caecf8cd94ec29 (diff)
downloadports-ab0b1f8d32a18ba0b819967ef3589695149edf58.tar.gz
ports-ab0b1f8d32a18ba0b819967ef3589695149edf58.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/gloox/Makefile33
-rw-r--r--net-im/gloox/distinfo3
-rw-r--r--net-im/gloox/files/patch-ltmain.sh15
-rw-r--r--net-im/gloox/pkg-descr8
-rw-r--r--net-im/gloox/pkg-plist5
6 files changed, 65 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 7fd852b857a6..9f6a6356fe43 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -32,6 +32,7 @@
SUBDIR += gale
SUBDIR += gicq
SUBDIR += ginsu
+ SUBDIR += gloox
SUBDIR += gnome-jabber
SUBDIR += gnomeicu2
SUBDIR += gossip
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
new file mode 100644
index 000000000000..ec4b53220cf8
--- /dev/null
+++ b/net-im/gloox/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gloox
+# Date created: 24 April 2006
+# Whom: trasz
+#
+# $FreeBSD$
+#
+
+PORTNAME= gloox
+PORTVERSION= 0.8
+CATEGORIES= net-im
+MASTER_SITES= http://camaya.net/download/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Jabber/XMPP client library
+
+LIB_DEPENDS= iksemel.3:${PORTSDIR}/textproc/iksemel \
+ idn.16:${PORTSDIR}/dns/libidn \
+ gnutls.15:${PORTSDIR}/security/gnutls
+
+USE_BZIP2= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+post-install:
+ @${FIND} ${PREFIX}/include/gloox ! -type d | \
+ ${SED} "s,${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/gloox -type d | ${SORT} -r | \
+ ${SED} "s,${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/net-im/gloox/distinfo b/net-im/gloox/distinfo
new file mode 100644
index 000000000000..a3ed3eb12763
--- /dev/null
+++ b/net-im/gloox/distinfo
@@ -0,0 +1,3 @@
+MD5 (gloox-0.8.tar.bz2) = fc595ff8d468d2f4ebd73139494ea32c
+SHA256 (gloox-0.8.tar.bz2) = ec0598a7e1711b2f63189d2b427c90cb58d02b866e6aaccd73e745edb8349e66
+SIZE (gloox-0.8.tar.bz2) = 317228
diff --git a/net-im/gloox/files/patch-ltmain.sh b/net-im/gloox/files/patch-ltmain.sh
new file mode 100644
index 000000000000..063a387e4514
--- /dev/null
+++ b/net-im/gloox/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Fri Apr 28 15:45:13 2006
++++ ltmain.sh Fri Apr 28 15:45:25 2006
+@@ -5621,10 +5621,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net-im/gloox/pkg-descr b/net-im/gloox/pkg-descr
new file mode 100644
index 000000000000..931579b2ccb5
--- /dev/null
+++ b/net-im/gloox/pkg-descr
@@ -0,0 +1,8 @@
+gloox is a full-featured Jabber/XMPP client without GUI, written
+in C++ and implemented as a shared library. It makes writing
+spec-compliant clients easy and allows for hassle-free integration
+of Jabber/XMPP functionality into extisting applications. gloox
+is released under the GNU GPL. Commercial licensing and support
+are available.
+
+WWW: http://camaya.net/gloox
diff --git a/net-im/gloox/pkg-plist b/net-im/gloox/pkg-plist
new file mode 100644
index 000000000000..d8e121fd2c60
--- /dev/null
+++ b/net-im/gloox/pkg-plist
@@ -0,0 +1,5 @@
+bin/gloox-config
+lib/libgloox.a
+lib/libgloox.so
+lib/libgloox.so.2
+libdata/pkgconfig/gloox.pc