aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-11-21 21:53:03 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-11-21 21:53:03 +0000
commit1d20f4ab4538031e20001f7eacbe94e046014f17 (patch)
treeabf1737e7380f72b482e0c6790e3fd938fe88bd6 /net-im
parentfdc2551a56cc3a9fe59db4ac59065bc2733ce003 (diff)
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qTox/Makefile15
-rw-r--r--net-im/qTox/distinfo4
-rw-r--r--net-im/qTox/files/patch-qtox.pro12
3 files changed, 17 insertions, 14 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index 9ca63ebb5233..636b72101126 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 0.141028
+PORTVERSION= 0.141118
CATEGORIES= net-im
MAINTAINER= yuri@rawbw.com
@@ -11,16 +11,19 @@ COMMENT= Qt 5 based Tox client
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
-LIB_DEPENDS= libopencv_highgui.so:${PORTSDIR}/graphics/opencv
+LIB_DEPENDS= libopencv_highgui.so:${PORTSDIR}/graphics/opencv \
+ libopencv_core.so:${PORTSDIR}/graphics/opencv-core \
+ libvpx.so:${PORTSDIR}/multimedia/libvpx \
+ libsodium.so:${PORTSDIR}/security/libsodium
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tux3
-GH_COMMIT= 8ff3d1d
+GH_COMMIT= 7c499c2
GH_TAGNAME= ${GH_COMMIT}
-
-USE_QT5= core gui network xml opengl sql widgets buildtools_build
-USES= compiler:c++11-lib desktop-file-utils openal:soft qmake
+USE_QT5= core gui network xml opengl sql widgets concurrent \
+ buildtools_build linguisttools
+USES= compiler:c++11-lib desktop-file-utils openal:soft qmake gmake
PLIST_FILES= bin/qtox \
share/applications/qTox.desktop \
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index d5d3a91f4761..2d2a31e11b78 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qTox-0.141028.tar.gz) = 812d7321c8e34edde49043aab029213670e77db801abc69551f977a47bf3169b
-SIZE (qTox-0.141028.tar.gz) = 2668590
+SHA256 (qTox-0.141118.tar.gz) = ec7d4f3dde2d64369a489a0426a0cf21449e79e773426616fff970aa114cb81f
+SIZE (qTox-0.141118.tar.gz) = 2901912
diff --git a/net-im/qTox/files/patch-qtox.pro b/net-im/qTox/files/patch-qtox.pro
index 06f310c8121f..22eb2a2152c9 100644
--- a/net-im/qTox/files/patch-qtox.pro
+++ b/net-im/qTox/files/patch-qtox.pro
@@ -1,9 +1,9 @@
---- qtox.pro.orig 2014-10-28 21:27:51.000000000 +0100
-+++ qtox.pro 2014-10-29 19:21:51.000000000 +0100
-@@ -213,3 +213,15 @@
- src/video/netvideosource.cpp \
- src/widget/form/tabcompleter.cpp \
- src/video/videoframe.cpp
+--- qtox.pro
++++ qtox.pro
+@@ -223,3 +223,15 @@
+ src/misc/serialize.cpp \
+ src/widget/form/settings/advancedform.cpp \
+ src/audio.cpp
+
+unix {
+ target.path = $$PREFIX/bin