aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-06-01 22:13:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-06-01 22:13:54 +0000
commit32817e4f09d108c66ca95b4ff47818c4e9cf0b5a (patch)
treef314fa93592a523c0934e5a04d77d6ed9da5214b /net-im
parentfeea508b4d186e3f1c66ad0b803378c83216cb1e (diff)
downloadports-32817e4f09d108c66ca95b4ff47818c4e9cf0b5a.tar.gz
ports-32817e4f09d108c66ca95b4ff47818c4e9cf0b5a.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/tox/Makefile20
-rw-r--r--net-im/tox/distinfo4
-rw-r--r--net-im/tox/files/patch-toxav_phone.c11
-rw-r--r--net-im/tox/files/patch-toxav_toxav.c18
4 files changed, 28 insertions, 25 deletions
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index e6026e7437c5..5936525a55e8 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ProjectTox-Core
-PORTVERSION= 0.140514
+PORTVERSION= 0.140601
PORTREVISION= 1
CATEGORIES= net-im net-p2p
@@ -13,34 +13,30 @@ LICENSE= GPLv3
BUILD_DEPENDS= checkmk:${PORTSDIR}/devel/libcheck
LIB_DEPENDS= libvpx.so:${PORTSDIR}/multimedia/libvpx \
- libopus.so:${PORTSDIR}/audio/opus
+ libopus.so:${PORTSDIR}/audio/opus \
+ libopenal.so.1:${PORTSDIR}/audio/openal-soft \
+ libv4l2.so:${PORTSDIR}/multimedia/libv4l \
+ libswscale.so:${PORTSDIR}/multimedia/ffmpeg
USE_GITHUB= yes
GH_ACCOUNT= irungentoo
GH_PROJECT= ProjectTox-Core
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 8902232
+GH_COMMIT= 9684339
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
AUTOMAKE_ARGS= -a -c -f
USES= pkgconfig pathfix libtool
+USE_SDL= yes
USE_LDCONFIG= yes
PATHFIX_MAKEFILEIN= Makefile.am
INSTALL_TARGET= install-strip
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SODIUM NACL
-OPTIONS_DEFINE= PHONE
-OPTIONS_DEFAULT= PHONE SODIUM
+OPTIONS_DEFAULT= SODIUM
OPTIONS_SUB= yes
-PHONE_DESC= Enable phone test
-PHONE_CONFIGURE_ENABLE= phone
-PHONE_LIB_DEPENDS= libopenal.so.1:${PORTSDIR}/audio/openal-soft \
- libv4l2.so:${PORTSDIR}/multimedia/libv4l \
- libswscale.so:${PORTSDIR}/multimedia/ffmpeg
-PHONE_USE= SDL=sdl
-
SODIUM_DESC= Prefer libsodium
SODIUM_LIB_DEPENDS= libsodium.so:${PORTSDIR}/security/libsodium
diff --git a/net-im/tox/distinfo b/net-im/tox/distinfo
index 86f2e2858fd0..a14e9b95d274 100644
--- a/net-im/tox/distinfo
+++ b/net-im/tox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ProjectTox-Core-0.140514.tar.gz) = d6389cd49f5411aedae7e8bcaef8dbc3de207afb86d9e6be68adee2ee5cdb38a
-SIZE (ProjectTox-Core-0.140514.tar.gz) = 267723
+SHA256 (ProjectTox-Core-0.140601.tar.gz) = aba9ffbad2d26059905f88101ae73df9eaed6f6edbd121bcea3ca21adc60500b
+SIZE (ProjectTox-Core-0.140601.tar.gz) = 272908
diff --git a/net-im/tox/files/patch-toxav_phone.c b/net-im/tox/files/patch-toxav_phone.c
deleted file mode 100644
index 5f1b8e7a2dbc..000000000000
--- a/net-im/tox/files/patch-toxav_phone.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- toxav/phone.c.orig 2014-02-22 23:52:26.000000000 +0100
-+++ toxav/phone.c 2014-02-23 22:31:19.000000000 +0100
-@@ -67,7 +67,7 @@
- /* the quit event for SDL */
- #define FF_QUIT_EVENT (SDL_USEREVENT + 2)
-
--#ifdef __linux__
-+#if defined( __linux__) || defined(__FreeBSD__)
- #define VIDEO_DRIVER "video4linux2"
- #define DEFAULT_WEBCAM "/dev/video0"
- #endif
diff --git a/net-im/tox/files/patch-toxav_toxav.c b/net-im/tox/files/patch-toxav_toxav.c
new file mode 100644
index 000000000000..3e131f2b1280
--- /dev/null
+++ b/net-im/tox/files/patch-toxav_toxav.c
@@ -0,0 +1,18 @@
+--- toxav/toxav.c.orig 2014-05-31 21:36:37.000000000 +0200
++++ toxav/toxav.c 2014-06-02 00:11:25.000000000 +0200
+@@ -532,7 +532,7 @@
+ if (pkt->kind == VPX_CODEC_CX_FRAME_PKT) {
+ if ( copied + pkt->data.frame.sz > dest_max ) return ErrorPacketTooLarge;
+
+- mempcpy(dest + copied, pkt->data.frame.buf, pkt->data.frame.sz);
++ memcpy(dest + copied, pkt->data.frame.buf, pkt->data.frame.sz);
+ copied += pkt->data.frame.sz;
+ }
+ }
+@@ -713,4 +713,4 @@
+ inline__ Tox *toxav_get_tox(ToxAv *av)
+ {
+ return (Tox *)av->messenger;
+-}
+\ No newline at end of file
++}