aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-08-30 03:51:10 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-08-30 03:51:10 +0000
commita54d79fa38d297eb3983d3ad0cc98f7c113ccb1d (patch)
treeb149a38c265a6a3dc46694e6bfbafe956608be4f /net-im
parent880b740272adcc7a0e1c078c2e2a7255ea79d1dc (diff)
downloadports-a54d79fa38d297eb3983d3ad0cc98f7c113ccb1d.tar.gz
ports-a54d79fa38d297eb3983d3ad0cc98f7c113ccb1d.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/Makefile32
-rw-r--r--net-im/gajim/files/patch-po-Makefile.in.in11
2 files changed, 23 insertions, 20 deletions
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index b61ed60bddf9..b37028a7f34c 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -1,9 +1,10 @@
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
PORTNAME= gajim
PORTVERSION= 0.15.4
CATEGORIES= net-im
-MASTER_SITES= http://www.gajim.org/downloads/0.15/
+MASTER_SITES= http://gajim.org/downloads/0.15/
MAINTAINER= rm@FreeBSD.org
COMMENT= Jabber client based on a plugin system
@@ -14,12 +15,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0:${PORTSDIR}/security/py-openssl \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1
-FETCH_ARGS= -Fpr
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+USES= gmake pathfix
USE_BZIP2= yes
USE_DOS2UNIX= src/plugins/plugins_i18n.py
-USE_GMAKE= yes
USE_GNOME= pygtk2
USE_PYTHON= -2.7
USE_XORG= x11 xext xscrnsaver
@@ -29,26 +29,34 @@ CONFIGURE_ENV+= PYTHON=${PYTHON_CMD}
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS_DEFINE= CRYPTO DBUS KEYRING NLS SPELL
+OPTIONS_DEFINE= AVAHI CRYPTO DBUS DOCS GUPNP KEYRING NLS SPELL
OPTIONS_DEFAULT=DBUS NLS SPELL
CRYPTO_DESC= End to end encryption support
KEYRING_DESC= Gnome Keyring support
SPELL_DESC= Spell checking support
+PORTDOCS= AUTHORS ChangeLog README.html
+OPTIONS_SUB= yes
+NLS_USES= gettext
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
+.if ! ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MAVAHI}
+RUN_DEPENDS+= avahi-discover:${PORTSDIR}/net/py-avahi
.endif
.if ${PORT_OPTIONS:MDBUS}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0.82.2:${PORTSDIR}/devel/py-dbus
.endif
+.if ${PORT_OPTIONS:MGUPNP}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gupnp/__init__.py:${PORTSDIR}/net/gupnp-igd
+.endif
+
.if ${PORT_OPTIONS:MCRYPTO}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto
.endif
@@ -61,6 +69,12 @@ USE_GNOME+= pygnomedesktop
LIB_DEPENDS= gtkspell:${PORTSDIR}/textproc/gtkspell
.endif
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
pre-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/src
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/src
diff --git a/net-im/gajim/files/patch-po-Makefile.in.in b/net-im/gajim/files/patch-po-Makefile.in.in
deleted file mode 100644
index 4e33b57c4508..000000000000
--- a/net-im/gajim/files/patch-po-Makefile.in.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig 2011-10-15 04:47:18.000000000 +0400
-+++ po/Makefile.in.in 2012-03-20 19:15:22.000000000 +0400
-@@ -34,7 +34,7 @@
- datarootdir = @datarootdir@
- libdir = @libdir@
- DATADIRNAME = @DATADIRNAME@
--itlocaledir = $(prefix)/$(DATADIRNAME)/locale
-+itlocaledir = @localedir@
- subdir = po
- install_sh = @install_sh@
- # Automake >= 1.8 provides @mkdir_p@.