aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-08-06 14:31:06 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-08-06 14:31:06 +0000
commitf8fa4faf0750a9676b7bb4cdba1ffbf77956cbb3 (patch)
treed9880f640613d1d914f21c17d71ebcb85c546414 /net-im
parentcd3338a5c5fc2d46fe01adcd86b9fe7376c3e7f2 (diff)
downloadports-f8fa4faf0750a9676b7bb4cdba1ffbf77956cbb3.tar.gz
ports-f8fa4faf0750a9676b7bb4cdba1ffbf77956cbb3.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mastodon/Makefile6
-rw-r--r--net-im/mastodon/files/patch-package.json15
-rw-r--r--net-im/mastodon/files/patch-yarn.lock11
3 files changed, 28 insertions, 4 deletions
diff --git a/net-im/mastodon/Makefile b/net-im/mastodon/Makefile
index e87291b75ef5..db6c85de9a0a 100644
--- a/net-im/mastodon/Makefile
+++ b/net-im/mastodon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mastodon
DISTVERSIONPREFIX= v
DISTVERSION= 1.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im www
MAINTAINER= jrm@FreeBSD.org
@@ -14,9 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libidn2.so:dns/libidn2
RUN_DEPENDS= ffmpeg>0:multimedia/ffmpeg \
- gmake>0:devel/gmake \
- libpqtypes>1.5.0:databases/libpqtypes \
- npm>=0:www/npm
+ libpqtypes>1.5.0:databases/libpqtypes
# Dependencies below match Gemfile layout
RUN_DEPENDS+= rubygem-pkg-config>=1.2.0:devel/rubygem-pkg-config
diff --git a/net-im/mastodon/files/patch-package.json b/net-im/mastodon/files/patch-package.json
new file mode 100644
index 000000000000..f18af4f9ee02
--- /dev/null
+++ b/net-im/mastodon/files/patch-package.json
@@ -0,0 +1,15 @@
+--- package.json.orig 2017-08-05 12:54:54 UTC
++++ package.json
+@@ -7,10 +7,9 @@
+ "build:production": "cross-env RAILS_ENV=production ./bin/webpack",
+ "manage:translations": "node ./config/webpack/translationRunner.js",
+ "start": "node ./streaming/index.js",
+- "test": "npm run test:lint && npm run test:mocha",
++ "test": "yarn run test:lint && yarn run test:mocha",
+ "test:lint": "eslint -c .eslintrc.yml --ext=js app/javascript/ config/webpack/ spec/javascript/ streaming/",
+- "test:mocha": "cross-env NODE_ENV=test mocha --require ./spec/javascript/setup.js --compilers js:babel-register ./spec/javascript/components/**/*.test.js",
+- "postinstall": "npm rebuild node-sass"
++ "test:mocha": "cross-env NODE_ENV=test mocha --require ./spec/javascript/setup.js --compilers js:babel-register ./spec/javascript/components/**/*.test.js"
+ },
+ "repository": {
+ "type": "git",
diff --git a/net-im/mastodon/files/patch-yarn.lock b/net-im/mastodon/files/patch-yarn.lock
new file mode 100644
index 000000000000..ad23f142d120
--- /dev/null
+++ b/net-im/mastodon/files/patch-yarn.lock
@@ -0,0 +1,11 @@
+--- yarn.lock.orig 2017-08-05 12:54:17 UTC
++++ yarn.lock
+@@ -6587,6 +6587,8 @@ uuid@^3.0.0, uuid@^3.0.1, uuid@^3.1.0:
+ uws@^8.14.0:
+ version "8.14.0"
+ resolved "https://registry.yarnpkg.com/uws/-/uws-8.14.0.tgz#acc1488d13ecb23fe2f942a7eafb06681fa91431"
++ dependencies:
++ node-gyp "^3.3.1"
+
+ validate-npm-package-license@^3.0.1:
+ version "3.0.1"