aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2007-12-27 16:01:34 +0000
committerJohan van Selst <johans@FreeBSD.org>2007-12-27 16:01:34 +0000
commita5d51d2358f81a11fd347160fc5c5b272a5e42fc (patch)
tree32ddc03520e8bf760eaa3ecab408af5603032710 /net-im
parent5a3fa9d9f3359368ecb4baa3d773c7a09497d87d (diff)
downloadports-a5d51d2358f81a11fd347160fc5c5b272a5e42fc.tar.gz
ports-a5d51d2358f81a11fd347160fc5c5b272a5e42fc.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/climm/Makefile56
1 files changed, 42 insertions, 14 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index aaccb7716a30..6576613a4e0c 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= climm
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.climm.org/source/ \
http://http.bg.climm.org/source/
@@ -20,41 +21,68 @@ USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= climm.1
MAN5= climmrc.5
MAN7= climmcmds.7
-.if defined(WITHOUT_LIBICONV)
-CONFIGURE_ARGS+= --disable-iconv
-.else
-USE_ICONV= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -liconv
-.endif
+OPTIONS= LIBICONV "Iconv character set conversion" on \
+ P2P "Peer2peer connection support" on \
+ TCL "TCL scripting support" on \
+ SSL "SSL/OTR encryption support" on \
+ REMOTE "Remote control fifo support" on
+# XMPP "XMPP Jabber support" on
-.if defined(WITHOUT_UTF8)
-CONFIGURE_ARGS+= --disable-utf8
+.include <bsd.port.options.mk>
+
+# XMPP support is currently broken - forcefully turn this off
+WITHOUT_XMPP= true
+
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --disable-ssl --disable-otr
+.else
+. if defined(WITHOUT_XMPP)
+CONFIGURE_ARGS+= --enable-ssl=openssl
+. else
+CONFIGURE_ARGS+= --enable-ssl=gnutls
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+. endif
+LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt \
+ otr:${PORTSDIR}/security/libotr \
+ gpg-error:${PORTSDIR}/security/libgpg-error
.endif
-.if defined(WITHOUT_P2P)
-CONFIGURE_ARGS+= --disable-peer2peer
+.if defined(WITHOUT_LIBICONV)
+CONFIGURE_ARGS+= --disable-iconv
+.else
+USE_ICONV= yes
.endif
.if defined(WITHOUT_P2P) || defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= --disable-ssl
+CONFIGURE_ARGS+= --disable-peer2peer --disable-ssl
.endif
.if defined(WITHOUT_TCL)
CONFIGURE_ARGS+= --disable-tcl
+.else
+USE_TCL= yes
.endif
.if defined(WITHOUT_REMOTE)
CONFIGURE_ARGS+= --disable-remote
.endif
+.if defined(WITHOUT_XMPP)
+CONFIGURE_ARGS+= --disable-xmpp
+.else
+LIB_DEPENDS+= gloox:${PORTSDIR}/net-im/gloox
+CONFIGURE_ARGS+= --enable-xmpp
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/ doc//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/ac_lib/s/tcl8\.4/tcl84/' ${WRKSRC}/configure
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/climm.1 ${MANPREFIX}/man/man1
@@ -62,9 +90,9 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/climmcmds.7 ${MANPREFIX}/man/man7
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for ext in i18n logformat png txt xpm
+. for ext in i18n logformat png txt xpm
${INSTALL_DATA} ${WRKSRC}/doc/*.${ext} ${DOCSDIR}
-.endfor
+. endfor
.endif
.include <bsd.port.mk>