aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2016-07-25 18:04:07 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2016-07-25 18:04:07 +0000
commit053a9a7cca07ba695b7a13cd0be097f7834ec59d (patch)
treea4cb831b00856721bfe518d9e1876873392405f9 /net-im
parentaa86468e19b5278f44b2b365988a13a2320d25a3 (diff)
downloadports-053a9a7cca07ba695b7a13cd0be097f7834ec59d.tar.gz
ports-053a9a7cca07ba695b7a13cd0be097f7834ec59d.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-python-telegram-bot/Makefile30
-rw-r--r--net-im/py-python-telegram-bot/distinfo3
-rw-r--r--net-im/py-python-telegram-bot/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 4ffde3dab576..13c4001fa9bc 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -131,6 +131,7 @@
SUBDIR += py-libturpial
SUBDIR += py-nbxmpp
SUBDIR += py-punjab
+ SUBDIR += py-python-telegram-bot
SUBDIR += py-pyxmpp
SUBDIR += py-skype4py
SUBDIR += py-slackclient
diff --git a/net-im/py-python-telegram-bot/Makefile b/net-im/py-python-telegram-bot/Makefile
new file mode 100644
index 000000000000..c1154e68ca9e
--- /dev/null
+++ b/net-im/py-python-telegram-bot/Makefile
@@ -0,0 +1,30 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-telegram-bot
+PORTVERSION= 5.0.0
+CATEGORIES= net-im devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Not just a Python wrapper around the Telegram Bot API
+
+LICENSE= LGPL3
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3400
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/py-python-telegram-bot/distinfo b/net-im/py-python-telegram-bot/distinfo
new file mode 100644
index 000000000000..5361320ba898
--- /dev/null
+++ b/net-im/py-python-telegram-bot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469462136
+SHA256 (python-telegram-bot-5.0.0.tar.gz) = 68f86beb03bbf8fd88f6c395a1a32e7bd199e0e07d6c67cd8f4fb6ee1b1cb6ab
+SIZE (python-telegram-bot-5.0.0.tar.gz) = 73003
diff --git a/net-im/py-python-telegram-bot/pkg-descr b/net-im/py-python-telegram-bot/pkg-descr
new file mode 100644
index 000000000000..5bfaef4e1bbe
--- /dev/null
+++ b/net-im/py-python-telegram-bot/pkg-descr
@@ -0,0 +1,6 @@
+This library provides a pure Python interface for the Telegram Bot API.
+In addition to the pure API implementation, this library features a number of
+high-level classes to make the development of bots easy and straightforward.
+These classes are contained in the telegram.ext submodule.
+
+WWW: https://python-telegram-bot.org/