aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-03-19 20:22:26 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-03-19 20:22:26 +0000
commit03ebbc6ca586ba8399364fcac7d0a5f3afcb6f87 (patch)
treed7c9e3b572278a13f0a1ab49cb977055e8abfb02 /net-im
parentaa959c5677de2dbb3d3134b9d1379208770d4fb9 (diff)
downloadports-03ebbc6ca586ba8399364fcac7d0a5f3afcb6f87.tar.gz
ports-03ebbc6ca586ba8399364fcac7d0a5f3afcb6f87.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qTox/Makefile27
-rw-r--r--net-im/qTox/distinfo4
-rw-r--r--net-im/qTox/files/patch-qtox.pro8
-rw-r--r--net-im/tox/Makefile4
-rw-r--r--net-im/tox/distinfo4
5 files changed, 25 insertions, 22 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index ed6b9fa3df8c..60bc97b8d9c0 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 0.150113
-PORTREVISION= 1
-CATEGORIES= net-im
+PORTVERSION= 0.150317
+CATEGORIES= net-im net-p2p
MAINTAINER= yuri@rawbw.com
COMMENT= Qt 5 based Tox client
@@ -16,22 +15,23 @@ LIB_DEPENDS= libopencv_highgui.so:${PORTSDIR}/graphics/opencv \
libopencv_core.so:${PORTSDIR}/graphics/opencv-core \
libvpx.so:${PORTSDIR}/multimedia/libvpx \
libfilteraudio.so:${PORTSDIR}/audio/filter_audio \
- libsodium.so:${PORTSDIR}/security/libsodium
+ libsodium.so:${PORTSDIR}/security/libsodium \
+ libqrencode.so:${PORTSDIR}/graphics/libqrencode
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tux3
-GH_COMMIT= d74b95a
+GH_COMMIT= de42357
GH_TAGNAME= ${GH_COMMIT}
USES= compiler:c++11-lib desktop-file-utils openal:soft qmake gmake
-USE_XORG+= x11 xscrnsaver
-USE_QT5= core gui network xml opengl sql sql-sqlite3_run widgets \
+USE_GNOME= glib20 gtk20 cairo gdkpixbuf2
+USE_XORG= x11 xscrnsaver
+USE_QT5= core gui network xml opengl sql sql-sqlite3_run widgets svg \
concurrent buildtools_build linguisttools_build
PLIST_FILES= bin/qtox \
- share/applications/qTox.desktop \
- share/pixmaps/qtox.png
+ share/applications/qTox.desktop
pre-everything::
@${ECHO_MSG}
@@ -39,12 +39,15 @@ pre-everything::
@${ECHO_MSG}
post-patch:
- ${REINPLACE_CMD} -e 's|$$$$system(git rev-parse HEAD)|"${GH_COMMIT}"|' \
+ @${REINPLACE_CMD} -e 's|$$$$system(git rev-parse HEAD)|"${GH_COMMIT}"|' \
+ ${WRKSRC}/qtox.pro
+ @${REINPLACE_CMD} -e 's|INCLUDEPATH += "/usr/include|INCLUDEPATH += "/usr/local/include|' \
+ ${WRKSRC}/qtox.pro
+ @${REINPLACE_CMD} -e 's|INCLUDEPATH += "/usr/lib|INCLUDEPATH += "/usr/local/lib|' \
${WRKSRC}/qtox.pro
pre-configure:
- ${CP} ${WRKSRC}/img/icon.png ${WRKSRC}/img/qtox.png
- ${REINPLACE_CMD} '/Comment/s,=.*,=${COMMENT},' \
+ @${REINPLACE_CMD} '/Comment/s,=.*,=${COMMENT},' \
${WRKSRC}/qTox.desktop
.include <bsd.port.mk>
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index e922219554fd..68ecf9cb9a31 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qTox-0.150113.tar.gz) = 6d982f93bfbe82ef8594188a7bf2874ff3170acf909ff7e5ae48903151036182
-SIZE (qTox-0.150113.tar.gz) = 2966865
+SHA256 (qTox-0.150317.tar.gz) = f89c7c149cd9dc1b934f545e6bfff0b40f3af0205a213dcba2ad7d466a127468
+SIZE (qTox-0.150317.tar.gz) = 4633713
diff --git a/net-im/qTox/files/patch-qtox.pro b/net-im/qTox/files/patch-qtox.pro
index 22eb2a2152c9..d4c050dc0bac 100644
--- a/net-im/qTox/files/patch-qtox.pro
+++ b/net-im/qTox/files/patch-qtox.pro
@@ -1,9 +1,9 @@
--- qtox.pro
+++ qtox.pro
-@@ -223,3 +223,15 @@
- src/misc/serialize.cpp \
- src/widget/form/settings/advancedform.cpp \
- src/audio.cpp
+@@ -451,3 +451,15 @@
+ src/widget/gui.h \
+ src/toxme.h \
+ src/misc/qrwidget.h
+
+unix {
+ target.path = $$PREFIX/bin
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index 14a115efc640..5ce815586196 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= toxcore
-PORTVERSION= 0.150228
+PORTVERSION= 0.150317
CATEGORIES= net-im net-p2p
MAINTAINER= thierry@FreeBSD.org
@@ -20,7 +20,7 @@ USE_GITHUB= yes
GH_ACCOUNT= irungentoo
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 972e6a9
+GH_COMMIT= 4ad7649
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
AUTOMAKE_ARGS= -a -c -f
diff --git a/net-im/tox/distinfo b/net-im/tox/distinfo
index d77fe72f3456..b644651dccd8 100644
--- a/net-im/tox/distinfo
+++ b/net-im/tox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (toxcore-0.150228.tar.gz) = 4bb481a90151437fca3bff33ebb471c6336de7bf1b6edd7ee8a8d9e636dfd781
-SIZE (toxcore-0.150228.tar.gz) = 351987
+SHA256 (toxcore-0.150317.tar.gz) = bfff413a0d254eb42bb86cc1b4d3bfd21e6969b5ab091f9420ec8838abee7d3b
+SIZE (toxcore-0.150317.tar.gz) = 352871