aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-09-28 19:35:17 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-09-28 19:35:17 +0000
commit2abeba29a05386ab333058c6e75848b2b12abf93 (patch)
treeaa01ea4e71094f1b311a78f52ee74b3994556979 /net-im
parentf952e2758d05f41145138a75c63cd62adfb0a0fa (diff)
downloadports-2abeba29a05386ab333058c6e75848b2b12abf93.tar.gz
ports-2abeba29a05386ab333058c6e75848b2b12abf93.zip
Fix net-im/spectral build
Recent update to qtkeychain removed the need for the workaround for lousy qtkeychain CMake configuration files -- and made the workaround itself bad. Reported by: fallout
Notes
Notes: svn path=/head/; revision=550440
Diffstat (limited to 'net-im')
-rw-r--r--net-im/spectral/Makefile2
-rw-r--r--net-im/spectral/files/patch-CMakeLists.txt38
2 files changed, 1 insertions, 39 deletions
diff --git a/net-im/spectral/Makefile b/net-im/spectral/Makefile
index b48641e2f42f..5c788f00263e 100644
--- a/net-im/spectral/Makefile
+++ b/net-im/spectral/Makefile
@@ -2,7 +2,7 @@
PORTNAME= spectral
PORTVERSION= 817
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
diff --git a/net-im/spectral/files/patch-CMakeLists.txt b/net-im/spectral/files/patch-CMakeLists.txt
deleted file mode 100644
index f9b1337c9f8e..000000000000
--- a/net-im/spectral/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-Replace the linked libraries for QtKeychain by expanded ones.
-
-This is a workaround for QtKeychain installing a Config.cmake file
-that refers to libraries that are **not** expanded or in the
-default search path (e.g. glib). Without this expansion,
-we end up with -lglib in the final link line -- and no
-corresponding -L/usr/local/lib to make sure it is actually found.
-
-
---- CMakeLists.txt.orig 2020-01-11 18:26:51 UTC
-+++ CMakeLists.txt
-@@ -206,6 +210,26 @@ endif(APPLE)
- add_executable(${PROJECT_NAME} WIN32 MACOSX_BUNDLE
- ${spectral_SRCS} ${spectral_QRC_SRC} $<TARGET_OBJECTS:SortFilterProxyModel>
- ${spectral_WINRC} ${${PROJECT_NAME}_MAC_ICON})
-+
-+get_target_property(_libs
-+ ${QTKEYCHAIN_LIBRARIES}
-+ IMPORTED_LINK_INTERFACE_LIBRARIES_RELEASE)
-+set(_expanded_libs "")
-+foreach(d ${_libs})
-+ if(TARGET ${d})
-+ list(APPEND _expanded_libs ${d})
-+ else()
-+ find_library(_expanded_d ${d})
-+ if(_expanded_d)
-+ list(APPEND _expanded_libs ${_expanded_d})
-+ else()
-+ list(APPEND _expanded_libs ${d})
-+ endif()
-+ unset(_expanded_d)
-+ endif()
-+endforeach()
-+set_target_properties(${QTKEYCHAIN_LIBRARIES} PROPERTIES
-+ IMPORTED_LINK_INTERFACE_LIBRARIES_RELEASE ${_expanded_libs})
-
- target_link_libraries(${PROJECT_NAME}
- Qt5::Widgets Qt5::Quick Qt5::Qml Qt5::Gui Qt5::Network Qt5::Svg Qt5::QuickControls2