aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-07-24 18:36:19 +0000
committerRene Ladan <rene@FreeBSD.org>2014-07-24 18:36:19 +0000
commit36e34f48e2e5ab984eb31b7cff1ee163494523f0 (patch)
tree78419497b9b7f06ed2367445df2b7045727c6e0a /net-im
parent37f54e0f66813dcddb3659fd7810198377792a1e (diff)
downloadports-36e34f48e2e5ab984eb31b7cff1ee163494523f0.tar.gz
ports-36e34f48e2e5ab984eb31b7cff1ee163494523f0.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/centericq/Makefile137
-rw-r--r--net-im/centericq/distinfo2
-rw-r--r--net-im/centericq/files/patch-configure18
-rw-r--r--net-im/centericq/files/patch-kkconsui-0.1_src_texteditor.cc79
-rw-r--r--net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.cc61
-rw-r--r--net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.h11
-rw-r--r--net-im/centericq/files/patch-libicq2000-0.1_libicq2000_sigslot.h10
-rw-r--r--net-im/centericq/files/patch-libicq2000-0.1_src_DirectClient.cpp11
-rw-r--r--net-im/centericq/files/patch-msn-connection.cpp12
-rw-r--r--net-im/centericq/files/patch-msn-filetransfer.cpp10
-rw-r--r--net-im/centericq/files/patch-msnhook.cc26
-rw-r--r--net-im/centericq/files/patch-src_icqdialogs.cc71
-rw-r--r--net-im/centericq/files/patch-src_icqface.cc68
-rw-r--r--net-im/centericq/files/patch-src_impgp.cc10
-rw-r--r--net-im/centericq/pkg-descr14
-rw-r--r--net-im/centericq/pkg-plist26
17 files changed, 0 insertions, 567 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 173e4422034b..90721d6cad82 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -5,7 +5,6 @@
SUBDIR += ayttm
SUBDIR += bsflite
- SUBDIR += centericq
SUBDIR += centerim
SUBDIR += centerim-devel
SUBDIR += chattahoochie
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
deleted file mode 100644
index c12069e781e8..000000000000
--- a/net-im/centericq/Makefile
+++ /dev/null
@@ -1,137 +0,0 @@
-# Created by: Chris Piazza <cpiazza@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= centericq
-PORTVERSION= 4.21.0
-PORTREVISION= 16
-CATEGORIES= net-im
-MASTER_SITES= http://thekonst.net/download/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Text mode menu- and window-driven IM interface
-
-DEPRECATED= Fails to build with new utmpx
-EXPIRATION_DATE= 2014-07-23
-
-USES= iconv gmake tar:bzip2
-USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lstdc++
-CONFIGURE_ARGS= --with-openssl --disable-konst
-
-OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO AIM IRC JABBER GPGME RSS LJ GG
-FRIBIDI_DESC= Fribidi Support
-MSN_DESC= MSN Protocol
-YAHOO_DESC= Yahoo! Messenger Protocol
-AIM_DESC= AOL's Instant Messenger Protocol
-IRC_DESC= IRC Protocol
-GPGME_DESC= PGP encrypted Jabber messages
-RSS_DESC= RSS Support
-LJ_DESC= LiveJournal Support
-GG_DESC= Gadu-Gadu Protocol Support
-
-OPTIONS_DEFAULT= GPGME
-
-MAN1= cicqconv.1 cicqsync.1
-
-PORTDOCS= FAQ README
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == "amd64"
-# Don't use optimization since it sefgaults in some cases otherwise.
-CFLAGS:= ${CFLAGS:C/-O[0123456789]*/-O0/}
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMULTIBYTE}
-CONFIGURE_ARGS+= --enable-locales-fix
-.endif
-
-.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
-CONFIGURE_ARGS+= --with-fribidi
-.endif
-
-.if ${PORT_OPTIONS:MMSN}
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-.else
-CONFIGURE_ARGS+= --disable-msn
-.endif
-
-.if ! ${PORT_OPTIONS:MYAHOO}
-CONFIGURE_ARGS+= --disable-yahoo
-.endif
-
-.if ! ${PORT_OPTIONS:MAIM}
-CONFIGURE_ARGS+= --disable-aim
-.endif
-
-.if ! ${PORT_OPTIONS:MIRC}
-CONFIGURE_ARGS+= --disable-irc
-.endif
-
-.if ! ${PORT_OPTIONS:MJABBER}
-CONFIGURE_ARGS+= --disable-jabber
-.endif
-
-.if ${PORT_OPTIONS:MGPGME}
-LIB_DEPENDS+= libgpgme.so:${PORTSDIR}/security/gpgme
-CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-gpgme
-.endif
-
-.if ! ${PORT_OPTIONS:MRSS}
-CONFIGURE_ARGS+= --disable-rss
-.endif
-
-.if ! ${PORT_OPTIONS:MLJ}
-CONFIGURE_ARGS+= --disable-lj
-.endif
-
-.if ${PORT_OPTIONS:MGG}
-LIB_DEPENDS+= libgadu.so:${PORTSDIR}/polish/ekg
-LIBGADU= -lgadu
-.else
-CONFIGURE_ARGS+= --disable-gg
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
-.endif
-
-post-patch:
-.for file in kkconsui-0.1/include/conf.h kkstrtext-0.1/conf.h kksystr-0.1/include/conf.h
- @(cd ${WRKSRC} ; \
- ${MV} -f ${file} ${file}.orig ; \
- ${GREP} -v "_G_config.h" ${file}.orig > ${file})
-.endfor
- @${FIND} ${WRKSRC} -name "Makefile*" -type f -print0 | \
- ${XARGS} -0 \
- ${REINPLACE_CMD} -E \
- -e "s|-I\$$\(top_srcdir\)/libgadu-0.1|-I${LOCALBASE}/include|" \
- -e "s|-L\$$\(top_srcdir\)/libgadu-0.1|-L${LOCALBASE}/lib|" \
- -e 's|libgadu-0.1/*||' \
- -e 's|libgadu-0.1||' \
- -e 's|-llibgadu|${LIBGADU}|'
-
-.if ${PORT_OPTIONS:MDOCS}
-post-install:
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC} ; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net-im/centericq/distinfo b/net-im/centericq/distinfo
deleted file mode 100644
index 26aab8b97f90..000000000000
--- a/net-im/centericq/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (centericq-4.21.0.tar.bz2) = fc8d7e95f54c153b7004448b33118477e52831d071e930e21b473ad6b724fd76
-SIZE (centericq-4.21.0.tar.bz2) = 1422126
diff --git a/net-im/centericq/files/patch-configure b/net-im/centericq/files/patch-configure
deleted file mode 100644
index e0f5294e7efd..000000000000
--- a/net-im/centericq/files/patch-configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig Fri Sep 2 22:46:37 2005
-+++ configure Sat Sep 3 13:43:48 2005
-@@ -14315,12 +14315,15 @@
- ac_prev=prefix ;;
- -prefix=* | --prefix=* | --prefi=* | --pref=* | --pre=* | --pr=* | --p=*)
- ;;
-+ *alias=* )
-+ ;;
- *) ac_sub_configure_args="$ac_sub_configure_args $ac_arg" ;;
- esac
- done
-
- # Always prepend --prefix to ensure using the same prefix
- # in subdir configurations.
-+ ac_sub_configure_args=`echo $ac_sub_configure_args | sed "s,'[A-Z][^']*',,g"`
- ac_sub_configure_args="--prefix=$prefix $ac_sub_configure_args"
-
- ac_popdir=`pwd`
diff --git a/net-im/centericq/files/patch-kkconsui-0.1_src_texteditor.cc b/net-im/centericq/files/patch-kkconsui-0.1_src_texteditor.cc
deleted file mode 100644
index 73373cc7a75f..000000000000
--- a/net-im/centericq/files/patch-kkconsui-0.1_src_texteditor.cc
+++ /dev/null
@@ -1,79 +0,0 @@
-
-$FreeBSD$
-
---- kkconsui-0.1/src/texteditor.cc.orig
-+++ kkconsui-0.1/src/texteditor.cc
-@@ -106,7 +106,7 @@
- fread(p, st.st_size, 1, f);
- p[st.st_size] = 0;
- i = load(p, strdup(id.c_str()));
-- delete p;
-+ delete[] p;
- }
-
- return i;
-@@ -124,7 +124,7 @@
- f.read(buf, size);
- buf[size] = 0;
- ret = load(buf, strdup(id.c_str()));
-- delete buf;
-+ delete[] buf;
-
- return ret;
- }
-@@ -172,7 +172,7 @@
- int texteditor::save(FILE *f, const char *linebreak) {
- char *buf = save(linebreak);
- fwrite(buf, strlen(buf), 1, f);
-- delete buf;
-+ free(buf);
- modified = false;
- return 0;
- }
-@@ -180,7 +180,7 @@
- int texteditor::save(ofstream &f, const string linebreak) {
- char *buf = save(linebreak.c_str());
- f.write(buf, strlen(buf));
-- delete buf;
-+ free(buf);
- f.close();
- modified = false;
- return 0;
-@@ -526,7 +526,7 @@
- fread(buf, fsize, 1, f);
- buf[fsize] = 0;
- insert(buf);
-- delete buf;
-+ delete[] buf;
- }
- }
-
-@@ -576,8 +576,8 @@
- firstpass = false;
- }
-
-- delete el;
-- delete sl;
-+ free(el);
-+ free(sl);
-
- modification(uinsblock, sbuf);
- }
-@@ -1081,7 +1081,7 @@
- curfile->lines->replace(CURLINE, newline);
- }
-
-- delete anext;
-+ free(anext);
- } else {
- if(next) nextlen = strlen(next); else nextlen = 0;
- char *newline = new char[nextlen+strlen(p)+1];
-@@ -1940,7 +1940,7 @@
- }
-
- int texteditor::findint(void *p1, void *p2) {
-- return *(int *) p1 != (int) p2;
-+ return *(int *) p1 != (intptr_t) p2;
- }
-
- int texteditor::findhighline(void *p1, void *p2) {
diff --git a/net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.cc b/net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.cc
deleted file mode 100644
index 6cf4c4d43ac0..000000000000
--- a/net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.cc
+++ /dev/null
@@ -1,61 +0,0 @@
-
-$FreeBSD$
-
---- kkstrtext-0.1/kkstrtext.cc.orig
-+++ kkstrtext-0.1/kkstrtext.cc
-@@ -154,7 +154,7 @@
- string r;
- char *buf = (char *) utf8_to_str(text.c_str());
- r = buf;
-- delete buf;
-+ delete[] buf;
- return r;
- }
-
-@@ -162,7 +162,7 @@
- string r;
- char *buf = str_to_utf8(text.c_str());
- r = buf;
-- delete buf;
-+ delete[] buf;
- return r;
- }
-
-@@ -416,7 +416,7 @@
-
- void charpointerfree(void *p) {
- char *cp = (char *) p;
-- if(cp) delete cp;
-+ if(cp) free(cp);
- }
-
- void nothingfree(void *p) {
-@@ -431,7 +431,7 @@
- }
-
- int intcompare(void *s1, void *s2) {
-- return (int) s1 != (int) s2;
-+ return (intptr_t) s1 != (intptr_t) s2;
- }
-
- string i2str(int i) {
-@@ -885,7 +885,7 @@
- #ifdef HAVE_ICONV
- iconv_t cd = iconv_open(tocs.c_str(), fromcs.c_str());
-
-- if(((int) cd) != -1) {
-+ if(((intptr_t) cd) != -1) {
- string r, text(atext);
- size_t inleft, outleft, soutleft;
- char *inbuf, *outbuf, *sinbuf, *soutbuf;
-@@ -907,8 +907,8 @@
- r += soutbuf;
- text.erase(0, text.size()-inleft);
-
-- delete soutbuf;
-- delete sinbuf;
-+ delete[] soutbuf;
-+ free(sinbuf);
-
- if(res == -1 && errno != EILSEQ)
- break;
diff --git a/net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.h b/net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.h
deleted file mode 100644
index b443df08353b..000000000000
--- a/net-im/centericq/files/patch-kkstrtext-0.1_kkstrtext.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- kkstrtext-0.1/kkstrtext.h.orig Wed Aug 9 10:50:49 2006
-+++ kkstrtext-0.1/kkstrtext.h Wed Aug 9 10:51:12 2006
-@@ -87,7 +87,7 @@
- { \
- va_list vgs__ap; char vgs__buf[1024]; \
- va_start(vgs__ap, fmt); \
-- vsprintf(vgs__buf, fmt, vgs__ap); c = vgs__buf; \
-+ vsnprintf(vgs__buf, sizeof(vgs__buf), fmt, vgs__ap); c = vgs__buf; \
- va_end(vgs__ap); \
- }
-
diff --git a/net-im/centericq/files/patch-libicq2000-0.1_libicq2000_sigslot.h b/net-im/centericq/files/patch-libicq2000-0.1_libicq2000_sigslot.h
deleted file mode 100644
index 81f384b377aa..000000000000
--- a/net-im/centericq/files/patch-libicq2000-0.1_libicq2000_sigslot.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./libicq2000-0.1/libicq2000/sigslot.h.orig Wed Aug 23 01:30:57 2006
-+++ ./libicq2000-0.1/libicq2000/sigslot.h Wed Aug 23 01:34:04 2006
-@@ -616,7 +616,6 @@
- if((*it)->getdest() == pslot)
- {
- m_connected_slots.erase(it);
-- delete *it;
- }
-
- it = itNext;
diff --git a/net-im/centericq/files/patch-libicq2000-0.1_src_DirectClient.cpp b/net-im/centericq/files/patch-libicq2000-0.1_src_DirectClient.cpp
deleted file mode 100644
index 95e5d6677931..000000000000
--- a/net-im/centericq/files/patch-libicq2000-0.1_src_DirectClient.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libicq2000-0.1/src/DirectClient.cpp.orig Wed Aug 9 10:52:04 2006
-+++ libicq2000-0.1/src/DirectClient.cpp Wed Aug 9 10:53:26 2006
-@@ -162,6 +162,8 @@
-
- m_recv.setLittleEndian();
- m_recv >> length;
-+ if (length == 0)
-+ return;
- if (length > Incoming_Packet_Limit) throw ParseException("Received too long incoming packet");
- if (m_recv.remains() < length) return; // waiting for more of the packet
-
diff --git a/net-im/centericq/files/patch-msn-connection.cpp b/net-im/centericq/files/patch-msn-connection.cpp
deleted file mode 100644
index 47dff454cd72..000000000000
--- a/net-im/centericq/files/patch-msn-connection.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- libmsn-0.1/msn/connection.cpp.orig Tue Jun 29 07:17:07 2004
-+++ libmsn-0.1/msn/connection.cpp Thu Jul 1 17:04:36 2004
-@@ -27,8 +27,8 @@
- #include <msn/externals.h>
-
- #ifndef WIN32
--#include <sys/socket.h>
- #include <unistd.h>
-+#include <sys/socket.h>
- #else
- #include <winsock.h>
- #include <io.h>
diff --git a/net-im/centericq/files/patch-msn-filetransfer.cpp b/net-im/centericq/files/patch-msn-filetransfer.cpp
deleted file mode 100644
index 29cd6a6b8a80..000000000000
--- a/net-im/centericq/files/patch-msn-filetransfer.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libmsn-0.1/msn/filetransfer.cpp.orig Tue Jun 29 18:59:04 2004
-+++ libmsn-0.1/msn/filetransfer.cpp Thu Jul 1 17:03:28 2004
-@@ -27,6 +27,7 @@
-
- #ifndef WIN32
- #include <unistd.h>
-+#include <sys/time.h>
- #include <sys/socket.h>
- #else
- #include <winsock.h>
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
deleted file mode 100644
index 6f1486372147..000000000000
--- a/net-im/centericq/files/patch-msnhook.cc
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/hooks/msnhook.cc.orig Thu Jul 1 03:42:16 2004
-+++ src/hooks/msnhook.cc Thu Jul 29 10:02:57 2004
-@@ -155,6 +155,9 @@
- int hsock = 0;
- MSN::Connection *c;
-
-+ FD_ZERO(&rs);
-+ FD_ZERO(&ws);
-+ FD_ZERO(&es);
- getsockets(rs, ws, es, hsock);
- tv.tv_sec = tv.tv_usec = 0;
-
-@@ -451,11 +454,11 @@
-
- void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
- string oldnick = c->getnick();
-- string newnick = unmime(friendlynick);
-+ string newnick = rusconv("uk",unmime(friendlynick));
-
- c->setnick(newnick);
-
-- if(forcefetch || (oldnick != newnick && c->getdispnick() == oldnick) || oldnick.empty()) {
-+ if(forcefetch || (oldnick != newnick && c->getdispnick() != newnick) || oldnick.empty()) {
- c->setdispnick(newnick);
- face.relaxedupdate();
- }
diff --git a/net-im/centericq/files/patch-src_icqdialogs.cc b/net-im/centericq/files/patch-src_icqdialogs.cc
deleted file mode 100644
index 34fc6d081b8c..000000000000
--- a/net-im/centericq/files/patch-src_icqdialogs.cc
+++ /dev/null
@@ -1,71 +0,0 @@
-
-$FreeBSD$
-
---- src/icqdialogs.cc.orig
-+++ src/icqdialogs.cc
-@@ -210,17 +210,17 @@
- switch(subj) {
- case fsuser:
- db.setbar(new horizontalbar(conf.getcolor(cp_dialog_text), conf.getcolor(cp_dialog_selected),
-- _("lOad"), _("sAve"), _("cLear"), _("Change"), _("Search/Add"), 0));
-+ _("lOad"), _("sAve"), _("cLear"), _("Change"), _("Search/Add"), 0L));
- break;
-
- case fschannel:
- db.setbar(new horizontalbar(conf.getcolor(cp_dialog_text), conf.getcolor(cp_dialog_selected),
-- _("cLear"), _("Change"), _("Join/Create"), 0));
-+ _("cLear"), _("Change"), _("Join/Create"), 0L));
- break;
-
- case fsrss:
- db.setbar(new horizontalbar(conf.getcolor(cp_dialog_text), conf.getcolor(cp_dialog_selected),
-- _("cLear"), _("Change"), _("lInk"), 0));
-+ _("cLear"), _("Change"), _("lInk"), 0L));
- break;
- }
-
-@@ -894,7 +894,7 @@
- i = m.open();
- m.close();
-
-- if(i) f = (unsigned short) ((int) m.getref(i-1));
-+ if(i) f = (unsigned short) ((intptr_t) m.getref(i-1));
- }
-
- void icqface::selectlanguage(unsigned short &f) {
-@@ -946,7 +946,7 @@
- int i = m.open();
- m.close();
-
-- if(i) f = (imgender) ((int) m.getref(i-1));
-+ if(i) f = (imgender) ((intptr_t) m.getref(i-1));
- }
-
- void icqface::selectagerange(ICQ2000::AgeRange &r) {
-@@ -967,7 +967,7 @@
- int i = m.open();
- m.close();
-
-- if(i) r = (ICQ2000::AgeRange) ((int) m.getref(i-1));
-+ if(i) r = (ICQ2000::AgeRange) ((intptr_t) m.getref(i-1));
- }
-
- bool icqface::edit(string &txt, const string &header) {
-@@ -1256,7 +1256,7 @@
-
- void *p;
- finished = !db.open(n, b, &p);
-- i = (int) p;
-+ i = (intptr_t) p;
-
- if(!finished)
- switch(b) {
-@@ -1750,7 +1750,7 @@
- it = transfers.end();
-
- if(!db.gettree()->isnode(db.gettree()->getid(np-1)))
-- it = transfers.begin() + (int) db.getmenu()->getref(n-1);
-+ it = transfers.begin() + (intptr_t) db.getmenu()->getref(n-1);
-
- switch(b) {
- case 0:
diff --git a/net-im/centericq/files/patch-src_icqface.cc b/net-im/centericq/files/patch-src_icqface.cc
deleted file mode 100644
index b21b48418e3a..000000000000
--- a/net-im/centericq/files/patch-src_icqface.cc
+++ /dev/null
@@ -1,68 +0,0 @@
-
-$FreeBSD$
-
---- src/icqface.cc.orig
-+++ src/icqface.cc
-@@ -401,7 +401,7 @@
-
- m.scale();
- m.idle = &menuidle;
-- i = (int) m.getref(m.open()-1);
-+ i = (intptr_t) m.getref(m.open()-1);
- m.close();
-
- if(i) lastr = i;
-@@ -450,7 +450,7 @@
-
- if(i) {
- lastitem = i-1;
-- r = (int) m.getref(lastitem);
-+ r = (intptr_t) m.getref(lastitem);
- }
-
- return r;
-@@ -513,7 +513,7 @@
- g = 0;
- }
-
-- if((unsigned int) c < 100) c = 0;
-+ if((intptr_t) c < 100) c = 0;
-
- if(i) {
- switch(action = extk) {
-@@ -1484,7 +1484,7 @@
- m.scale();
-
- i = m.open();
-- choice = (int) m.getref(i-1);
-+ choice = (intptr_t) m.getref(i-1);
-
- m.close();
- }
-@@ -1539,7 +1539,7 @@
- m.close();
-
- if(r = i) {
-- st = (imstatus) ((int) m.getref(i-1));
-+ st = (imstatus) ((intptr_t) m.getref(i-1));
- }
- }
-
-@@ -2003,7 +2003,7 @@
- mvaddchnstr(i-1, sizeWArea.x1+1, logline, sizeWArea.x2-sizeWArea.x1);
- }
-
-- delete logline;
-+ delete[] logline;
-
- if(text.size() > sizeWArea.x2-sizeWArea.x1-2) text.resize(sizeWArea.x2-sizeWArea.x1-2);
- mvhline(LINES-3, sizeWArea.x1+2, ' ', sizeWArea.x2-sizeWArea.x1-2);
-@@ -2132,7 +2132,7 @@
- c = (icqcontact *) cm->getref(i);
- }
-
-- if((unsigned int) c > 100) {
-+ if((intptr_t) c > 100) {
- string current = c->getdispnick();
- len = current.size();
- if(len > nick.size()) len = nick.size();
diff --git a/net-im/centericq/files/patch-src_impgp.cc b/net-im/centericq/files/patch-src_impgp.cc
deleted file mode 100644
index cfa38bebf5f7..000000000000
--- a/net-im/centericq/files/patch-src_impgp.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/impgp.cc.orig 2009-07-01 23:19:00.000000000 -0400
-+++ ./src/impgp.cc 2009-07-01 23:19:29.000000000 -0400
-@@ -12,6 +12,7 @@
- string impgp::passphrase[];
-
- impgp::impgp() {
-+ gpgme_check_version(NULL);
- if(gpgme_new(&ctx))
- ctx = 0;
- }
diff --git a/net-im/centericq/pkg-descr b/net-im/centericq/pkg-descr
deleted file mode 100644
index b52c41583c74..000000000000
--- a/net-im/centericq/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-Centericq is a text mode menu- and window-driven IM interface that
-supports the ICQ2000, Yahoo!, MSN, AIM, and IRC protocols. It allows you
-to send, receive, and forward messages, URLs, SMSes, contacts, and email
-express messages. It also lets you set your own and fetch others' away
-messages, and define external handlers for incoming events. You can
-mass message-send, search for users, view users' details, maintain
-your contact list directly from the program, view the message history,
-register a new UIN and update your details, be informed upon receipt
-of email messages, automatically set away after the defined period of
-inactivity, and have your own ignore, visible, and invisible lists.
-It can also associate events with sounds, make log of events, and
-allows arrangement of contacts into groups.
-
-WWW: http://konst.org.ua/centericq/
diff --git a/net-im/centericq/pkg-plist b/net-im/centericq/pkg-plist
deleted file mode 100644
index 0131b9001715..000000000000
--- a/net-im/centericq/pkg-plist
+++ /dev/null
@@ -1,26 +0,0 @@
-bin/centericq
-bin/cicqconv
-bin/cicqsync
-%%DATADIR%%/email.wav
-%%DATADIR%%/msg.wav
-%%DATADIR%%/offline.wav
-%%DATADIR%%/online.wav
-%%DATADIR%%/sms.wav
-%%DATADIR%%/url.wav
-%%NLS%%share/locale/bg/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/de/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/es/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/it/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/centericq.mo
-%%NLS%%share/locale/zh_TW.Big5/LC_MESSAGES/centericq.mo
-@dirrm %%DATADIR%%