aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:58:04 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:58:04 +0000
commit897ad0b36e733c0ecd382d79bc924e8826b141c2 (patch)
tree51651e644edd2c685808f4c990c2f85e7b689f49 /net-im
parentbbd9c2e7e1340971b4a4a2c5675a3a06c28998ed (diff)
downloadports-897ad0b36e733c0ecd382d79bc924e8826b141c2.tar.gz
ports-897ad0b36e733c0ecd382d79bc924e8826b141c2.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/diligent/Makefile2
-rw-r--r--net-im/ekiga/Makefile4
-rw-r--r--net-im/empathy/Makefile4
-rw-r--r--net-im/gajim/Makefile2
-rw-r--r--net-im/gitterdone/Makefile2
-rw-r--r--net-im/licq-qt-gui/Makefile2
-rw-r--r--net-im/pidgin/Makefile2
-rw-r--r--net-im/psi/Makefile2
-rw-r--r--net-im/ricochet/Makefile2
-rw-r--r--net-im/spectral/Makefile2
-rw-r--r--net-im/vqcc-gtk/Makefile2
11 files changed, 13 insertions, 13 deletions
diff --git a/net-im/diligent/Makefile b/net-im/diligent/Makefile
index 637a98b46e09..23091d012762 100644
--- a/net-im/diligent/Makefile
+++ b/net-im/diligent/Makefile
@@ -16,7 +16,7 @@ USE_LDCONFIG= yes
USE_QT= core gui linguist network svg \
webkit widgets x11extras buildtools_build
USE_GL= gl
-USES= compiler:c++11-lang qmake qt:5
+USES= compiler:c++11-lang gl qmake qt:5
QMAKE_ARGS= CONFIG+="configure"
diff --git a/net-im/ekiga/Makefile b/net-im/ekiga/Makefile
index c2e38652206a..d1363db5a8a0 100644
--- a/net-im/ekiga/Makefile
+++ b/net-im/ekiga/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= libopal.so:net/opal \
RUN_DEPENDS= gnome-icon-theme>=3.0.0:misc/gnome-icon-theme
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang cpe gettext gmake libtool localbase \
- pathfix pkgconfig tar:xz
+USES= compiler:c++11-lang cpe gettext gmake gnome libtool localbase \
+ pathfix pkgconfig tar:xz xorg
USE_XORG= xv
USE_GNOME= gtk20 intlhack libxml2
INSTALLS_ICONS= yes
diff --git a/net-im/empathy/Makefile b/net-im/empathy/Makefile
index 3fda27a1ea29..34ff3d785c60 100644
--- a/net-im/empathy/Makefile
+++ b/net-im/empathy/Makefile
@@ -48,8 +48,8 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
geoclue>=0:net/geoclue \
mc-tool:net-im/telepathy-mission-control
-USES= compiler:c11 gettext gmake gnome libtool localbase pathfix \
- pkgconfig python:2.7 tar:xz
+USES= compiler:c11 gettext gl gmake gnome libtool localbase pathfix \
+ pkgconfig python:2.7 tar:xz xorg
USE_GNOME= cairo evolutiondataserver3 intlhack
USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
USE_GL= egl
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index abfcb1cad8dd..4254f23de0e0 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssutils>=1.0.2:www/py-cssutils@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR}
-USES= cpe dos2unix gnome python:3.5+ tar:bzip2
+USES= cpe dos2unix gnome python:3.5+ tar:bzip2 xorg
USE_PYTHON= autoplist distutils noflavors
USE_GNOME= intltool pygobject3
USE_XORG= x11 xext xscrnsaver
diff --git a/net-im/gitterdone/Makefile b/net-im/gitterdone/Makefile
index e1467e2a8176..2816aa3bb5d4 100644
--- a/net-im/gitterdone/Makefile
+++ b/net-im/gitterdone/Makefile
@@ -10,7 +10,7 @@ COMMENT= Gitter Client based on Qt5
LICENSE= BSD2CLAUSE
-USES= compiler:c++11-lang qmake qt:5 shebangfix tar:xz
+USES= compiler:c++11-lang gl qmake qt:5 shebangfix tar:xz
USE_QT= core gui network linguist_build \
buildtools_build widgets webkit svg
USE_GL+= gl
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index 6d94f4287927..dafa9d7e1218 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= licq:${LICQ_PORT} \
${LOCALBASE}/lib/licq/protocol_icq.so:${LICQ_PORT}-icq
+USES= cmake qt:5 xorg
USE_XORG= x11 xext ice xscrnsaver sm
-USES= cmake qt:5
USE_QT= buildtools_build qmake_build linguisttools_build core \
xml gui network dbus svg widgets
USE_GITHUB= yes
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index db9368ea420f..4adfe5582dec 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -20,7 +20,7 @@ PLIST= ${.CURDIR}/pkg-plist
PIDGIN_SLAVE= yes
WITH_GTKUI= yes
-USES= python:build
+USES= gnome python:build xorg
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gtk20 intltool
USE_XORG= xscrnsaver sm
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index 1aad19d91d1a..e8bfeb24f81c 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libqca-qt5.so:devel/qca
USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
- qt:5 tar:xz
+ qt:5 tar:xz xorg
USE_QT= concurrent core dbus gui multimedia network svg widgets \
x11extras xml buildtools_build qmake_build imageformats_run
USE_XORG= ice sm x11 xcb xext xscrnsaver
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index d731c72ce9b6..d72da7b92f59 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= compiler:c++11-lib gmake pkgconfig qmake qt:5 ssl
+USES= compiler:c++11-lib gl gmake pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= ricochet-im
USE_QT= core declarative gui multimedia network quickcontrols widgets \
diff --git a/net-im/spectral/Makefile b/net-im/spectral/Makefile
index fb9929181b10..20097eb56a5c 100644
--- a/net-im/spectral/Makefile
+++ b/net-im/spectral/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= libqmatrixclient>=0.5:net-im/libqmatrixclient
-USES= compiler:c++17-lang pkgconfig qmake qt:5 tar:bz2
+USES= compiler:c++17-lang gl pkgconfig qmake qt:5 tar:bz2
USE_GL= gl
USE_QT= core dbus declarative graphicaleffects gui imageformats \
multimedia network quickcontrols2 svg widgets \
diff --git a/net-im/vqcc-gtk/Makefile b/net-im/vqcc-gtk/Makefile
index 72a804e8b435..25b5e027d025 100644
--- a/net-im/vqcc-gtk/Makefile
+++ b/net-im/vqcc-gtk/Makefile
@@ -12,7 +12,7 @@ COMMENT= LAN chat client compatible with quickChat and Vypress Chat (TM)
LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
-USES= pathfix gmake gettext pkgconfig
+USES= pathfix gmake gnome gettext pkgconfig xorg
USE_GNOME= gnomeprefix gtk20
USE_XORG= x11 xext xscrnsaver
GNU_CONFIGURE= yes