aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-27 13:14:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-27 13:14:07 +0000
commit80b83b4e258947b133315f5f507412ff49130c02 (patch)
treee2f74466bec6aa0c36ced94bf01001c10df15582 /net-im
parent6dd93bac13b6dc5fc95ab26a9c205f9065c89ed6 (diff)
downloadports-80b83b4e258947b133315f5f507412ff49130c02.tar.gz
ports-80b83b4e258947b133315f5f507412ff49130c02.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber-jud/Makefile37
-rw-r--r--net-im/jabber-jud/files/README.jabberd14.in38
-rw-r--r--net-im/jabber-jud/files/patch-Makefile10
-rw-r--r--net-im/jabber-jud/files/patch-aa12
-rw-r--r--net-im/jabber-jud/files/pkg-message.in2
-rw-r--r--net-im/jabber-jud/pkg-message32
-rw-r--r--net-im/jabber-jud/pkg-plist3
7 files changed, 81 insertions, 53 deletions
diff --git a/net-im/jabber-jud/Makefile b/net-im/jabber-jud/Makefile
index 478b79039656..d66b3d5cbd48 100644
--- a/net-im/jabber-jud/Makefile
+++ b/net-im/jabber-jud/Makefile
@@ -6,29 +6,48 @@
PORTNAME= jud
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://jud.jabberstudio.org/ \
http://freebsd.unixfreunde.de/sources/
PKGNAMEPREFIX= jabber-
DIST_SUBDIR= jabber
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= martin@matuska.org
COMMENT= Jabber User Directory module
-BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net-im/jabber
+LIB_DEPENDS= jabberd.1:${PORTSDIR}/net-im/jabber
WRKSRC= ${WRKDIR}/${PORTNAME}-ansi-c
-PLIST_FILES= lib/jabber/jud.so
USE_GMAKE= yes
-post-patch:
- @echo "${PREFIX}" > ${WRKSRC}/.prefix-freebsd
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/jabber \
+ -I${LOCALBASE}/include/pth
+
+MAKE_ARGS+= MCFLAGS="-shared" \
+ LDFLAGS="-L${LOCALBASE}/lib/pth -L${LOCALBASE}/lib/jabber"
+
+SUB_FILES+= pkg-message README.jabberd14
+DOCSDIR= ${TARGETDIR}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PKGMESSAGE= ${WRKDIR}/pkg-message
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
do-install:
- ${INSTALL_DATA} ${WRKSRC}/jud.so ${PREFIX}/lib/jabber/
+ ${INSTALL_PROGRAM} ${WRKSRC}/jud.so ${TARGETDIR}/lib/jabber/
post-install:
- @cat pkg-message
-
-.include <bsd.port.mk>
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKDIR}/README.jabberd14 ${DOCSDIR}
+ @${CAT} ${PKGMESSAGE}
+.endif
+.include <bsd.port.post.mk>
diff --git a/net-im/jabber-jud/files/README.jabberd14.in b/net-im/jabber-jud/files/README.jabberd14.in
new file mode 100644
index 000000000000..a9131a4d0eb9
--- /dev/null
+++ b/net-im/jabber-jud/files/README.jabberd14.in
@@ -0,0 +1,38 @@
+The sample configuration file for jabberd14 may be located in:
+%%TARGETDIR%%/etc/jabber.xml.sample
+
+Please make all necessary changes to your configuration file which may be:
+%%TARGETDIR%%/etc/jabber.xml
+
+To activate JUD for your Jabber server, add the following to your configuration file
+(around line 921 in the sample configuration file):
+-------------------------------------------------------------------------------
+
+ <!--
+ If you want this service to be accessible from other servers,
+ change 'jud.localhost' to the server's fully qualified domain name!
+ -->
+ <service id="jud">
+ <host>jud.localhost</host>
+ <load><jud>%%TARGETDIR%%/lib/jabber/jud.so</jud></load>
+ <jud xmlns="jabber:config:jud">
+ <vCard>
+ <FN>Local Organization's User Directory</FN>
+ <DESC>This service provides a simple user directory service.</DESC>
+ <URL>http://foo.bar/</URL>
+ </vCard>
+ </jud>
+ </service>
+
+-------------------------------------------------------------------------------
+Add this section to the browse area of the jsm service to advertise it to
+your users (around line 382 of the sample config):
+-------------------------------------------------------------------------------
+
+ <item category="directory" type="user" jid="jud.localhost" name="My Organization's User Directory">
+ <ns>jabber:iq:search</ns>
+ <ns>jabber:iq:register</ns>
+ </item>
+
+-------------------------------------------------------------------------------
+Be sure to restart your server after reconfiguring.
diff --git a/net-im/jabber-jud/files/patch-Makefile b/net-im/jabber-jud/files/patch-Makefile
new file mode 100644
index 000000000000..d9dc34f265d3
--- /dev/null
+++ b/net-im/jabber-jud/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Wed Feb 21 15:47:45 2007
++++ Makefile Wed Feb 21 15:47:50 2007
+@@ -1,7 +1,3 @@
+-include ../platform-settings
+-
+-CFLAGS=$(CCFLAGS) -I../jabberd
+-
+ jud_OBJECTS=jud.o jud_reg.o jud_search.o
+
+ all: jud
diff --git a/net-im/jabber-jud/files/patch-aa b/net-im/jabber-jud/files/patch-aa
deleted file mode 100644
index de94520d8810..000000000000
--- a/net-im/jabber-jud/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig Wed Nov 12 10:12:20 2003
-+++ Makefile Thu Jun 15 21:12:23 2006
-@@ -1,6 +1,7 @@
--include ../platform-settings
-+INCDIR= ${PREFIX}/include/jabber
-+include ${INCDIR}/platform-settings
-
--CFLAGS=$(CCFLAGS) -I../jabberd
-+CFLAGS:=$(CFLAGS) -I${INCDIR}
-
- jud_OBJECTS=jud.o jud_reg.o jud_search.o
-
diff --git a/net-im/jabber-jud/files/pkg-message.in b/net-im/jabber-jud/files/pkg-message.in
new file mode 100644
index 000000000000..c51d212244f8
--- /dev/null
+++ b/net-im/jabber-jud/files/pkg-message.in
@@ -0,0 +1,2 @@
+You can find a configuration example in:
+%%DOCSDIR%%/README.jabberd14
diff --git a/net-im/jabber-jud/pkg-message b/net-im/jabber-jud/pkg-message
deleted file mode 100644
index 4380f3efcdd1..000000000000
--- a/net-im/jabber-jud/pkg-message
+++ /dev/null
@@ -1,32 +0,0 @@
-To activate JUD for your Jabber server, add the following (around line 36 in
-the sample configuration file) to your configuration file
-(${LOCALBASE}/etc/jabber.xml):
-
-
- <!--
- If you want this service to be accessible from other servers,
- change 'jud.localhost' to the server's fully qualified domain name!
- Also note that ${LOCALBASE} should be changed to your local base
- (ex: /usr/local).
- -->
- <service id="jud">
- <host>jud.localhost</host>
- <load><jud>${LOCALBASE}/lib/jabber/jud.so</jud></load>
- <jud xmlns="jabber:config:jud">
- <vCard>
- <FN>Local Organization's User Directory</FN>
- <DESC>This service provides a simple user directory service.</DESC>
- <URL>http://foo.bar/</URL>
- </vCard>
- </jud>
- </service>
-
-Add this section to the browse area of the jsm service to advertise it to
-your users (around line 245 of the sample config):
-
- <service type="jud" jid="jud.localhost" name="My Organization's User Directory">
- <ns>jabber:iq:search</ns>
- <ns>jabber:iq:register</ns>
- </service>
-
-Be sure to restart your server after reconfiguring.
diff --git a/net-im/jabber-jud/pkg-plist b/net-im/jabber-jud/pkg-plist
new file mode 100644
index 000000000000..511d7221c470
--- /dev/null
+++ b/net-im/jabber-jud/pkg-plist
@@ -0,0 +1,3 @@
+lib/jabber/jud.so
+%%PORTDOCS%%%%DOCSDIR%%/README.jabberd14
+%%PORTDOCS%%@dirrm %%DOCSDIR%%