aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-06 19:48:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-06 19:48:31 +0000
commitebf457224c29f4f4613a3be076f9dbf713b7fbdd (patch)
tree6c5c37e0835cf54764553001db169ec1d699710d /net-im
parentd58734c674a7a29bb31d9251511220475dd39344 (diff)
downloadports-ebf457224c29f4f4613a3be076f9dbf713b7fbdd.tar.gz
ports-ebf457224c29f4f4613a3be076f9dbf713b7fbdd.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/loudmouth/Makefile7
-rw-r--r--net-im/loudmouth/distinfo6
-rw-r--r--net-im/loudmouth/files/patch-loudmouth_Makefile.in12
-rw-r--r--net-im/loudmouth/files/patch-loudmouth_lm-sock.c27
-rw-r--r--net-im/loudmouth/pkg-descr2
-rw-r--r--net-im/loudmouth/pkg-plist1
6 files changed, 32 insertions, 23 deletions
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index 73c260d2370b..2c0d9a6d7324 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= loudmouth
-PORTVERSION= 1.2.3
-PORTREVISION= 4
+PORTVERSION= 1.4.0
CATEGORIES= net-im gnome
MASTER_SITES= http://ftp.imendio.com/pub/imendio/loudmouth/src/ \
${MASTER_SITE_GNOME}
@@ -20,9 +19,9 @@ LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn
USE_BZIP2= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-USE_GNOME= gnomehack glib20
+USE_GNOME= gnomehack glib20 ltverhack
CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net-im/loudmouth/distinfo b/net-im/loudmouth/distinfo
index ca97edc061ec..7cb5d600a772 100644
--- a/net-im/loudmouth/distinfo
+++ b/net-im/loudmouth/distinfo
@@ -1,3 +1,3 @@
-MD5 (loudmouth-1.2.3.tar.bz2) = 7e25b0e13498dcb671d60d0cd62091b8
-SHA256 (loudmouth-1.2.3.tar.bz2) = 41f775303e76436add3c0141e485246223a60bbbcf90a7e90ed2b5baf6e2602b
-SIZE (loudmouth-1.2.3.tar.bz2) = 325864
+MD5 (loudmouth-1.4.0.tar.bz2) = d9504bb4251d4e5b32cb379debda634d
+SHA256 (loudmouth-1.4.0.tar.bz2) = 67cad76c18a138b9b55bf6ff88a5796128371cf9339b3761b36f79fb4e7459d7
+SIZE (loudmouth-1.4.0.tar.bz2) = 381235
diff --git a/net-im/loudmouth/files/patch-loudmouth_Makefile.in b/net-im/loudmouth/files/patch-loudmouth_Makefile.in
new file mode 100644
index 000000000000..99c8782e6ced
--- /dev/null
+++ b/net-im/loudmouth/files/patch-loudmouth_Makefile.in
@@ -0,0 +1,12 @@
+--- loudmouth/Makefile.in.orig 2008-07-06 15:44:25.000000000 -0400
++++ loudmouth/Makefile.in 2008-07-06 15:43:53.000000000 -0400
+@@ -306,8 +306,7 @@ libloudmouthinclude_HEADERS = \
+
+ libloudmouth_1_la_LIBADD = \
+ $(LOUDMOUTH_LIBS) \
+- $(LIBIDN_LIBS) \
+- -lresolv
++ $(LIBIDN_LIBS)
+
+ libloudmouth_1_la_LDFLAGS = \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
diff --git a/net-im/loudmouth/files/patch-loudmouth_lm-sock.c b/net-im/loudmouth/files/patch-loudmouth_lm-sock.c
index 61a8727646b1..594cc49705c2 100644
--- a/net-im/loudmouth/files/patch-loudmouth_lm-sock.c
+++ b/net-im/loudmouth/files/patch-loudmouth_lm-sock.c
@@ -1,14 +1,13 @@
---- loudmouth/lm-sock.c.orig Mon Apr 16 23:37:43 2007
-+++ loudmouth/lm-sock.c Mon Apr 16 23:38:08 2007
-@@ -273,9 +273,11 @@
- case EAI_FAIL:
- return _("The nameserver encountered errors "
- "looking up this address");
-+#ifdef EAI_NODATA
- case EAI_NODATA:
- return _("The remote host exists but no address "
- "is available");
-+#endif
- case EAI_NONAME:
- return _("The remote address is unknown");
- case EAI_FAMILY:
+--- loudmouth/lm-sock.c.orig 2008-07-06 15:41:02.000000000 -0400
++++ loudmouth/lm-sock.c 2008-07-06 15:43:01.000000000 -0400
+@@ -27,8 +27,10 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <fcntl.h>
++#include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/tcp.h>
diff --git a/net-im/loudmouth/pkg-descr b/net-im/loudmouth/pkg-descr
index 27f9f970cd1f..546a7c87ed8e 100644
--- a/net-im/loudmouth/pkg-descr
+++ b/net-im/loudmouth/pkg-descr
@@ -2,4 +2,4 @@ Loudmouth is a lightweight and easy-to-use C library for programming with the
Jabber protocol. It's designed to be easy to get started with and yet
extensible to let you do anything the Jabber protocol allows.
-WWW: http://developer.imendio.com/projects/loudmouth/
+WWW: http://www.loudmouth-project.org/
diff --git a/net-im/loudmouth/pkg-plist b/net-im/loudmouth/pkg-plist
index 540f79e0582f..52b8060c21e1 100644
--- a/net-im/loudmouth/pkg-plist
+++ b/net-im/loudmouth/pkg-plist
@@ -24,7 +24,6 @@ share/gtk-doc/html/loudmouth/loudmouth-lm-message.html
share/gtk-doc/html/loudmouth/loudmouth-lm-message-node.html
share/gtk-doc/html/loudmouth/loudmouth-lm-proxy.html
share/gtk-doc/html/loudmouth/loudmouth-lm-ssl.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-utils.html
share/gtk-doc/html/loudmouth/loudmouth.devhelp
share/gtk-doc/html/loudmouth/loudmouth.devhelp2
share/gtk-doc/html/loudmouth/right.png