aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2017-11-19 09:05:18 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2017-11-19 09:05:18 +0000
commit2984ed3847671d92e6e8490e5d9d64bd956b58df (patch)
tree954d22830e35a668f3a4ba289a5641fc0cf61f63 /net-im
parentda4128eac0f2a07702731bdb415277f1bf018477 (diff)
downloadports-2984ed3847671d92e6e8490e5d9d64bd956b58df.tar.gz
ports-2984ed3847671d92e6e8490e5d9d64bd956b58df.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ejabberd/Makefile8
-rw-r--r--net-im/ejabberd/files/pkg-message.in1
-rw-r--r--net-im/ejabberd/pkg-plist1
3 files changed, 10 insertions, 0 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 58071d9e46fa..4c9cc44c40da 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ejabberd
PORTVERSION= 17.09
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.process-one.net/downloads/${PORTNAME}/${PORTVERSION}/:p1 \
http://distfiles.pirateparty.in/ashish/:deps \
@@ -86,6 +87,9 @@ DOCS_MAKE_ARGS_OFF= NOPORTDOCS=yes
post-extract:
@${LN} -s ${WRKDIR}/deps ${WRKSRC}/
+post-patch:
+ @${REINPLACE_CMD} -e 's,^convert,${LOCALBASE}/bin/convert,' ${WRKSRC}/tools/captcha.sh
+
pre-configure:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
@@ -106,5 +110,9 @@ post-install-PAM-on:
post-install:
@${FIND} ${STAGEDIR}${PREFIX}/${EJABBERD_LIBDIR} -type f \
-name '*.so' -exec ${STRIP_CMD} {} \;
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${INSTALL} -m 0755 ${STAGEDIR}${PREFIX}/${EJABBERD_LIBDIR}/${PORTNAME}-${PORTVERSION}/priv/bin/captcha.sh \
+ ${STAGEDIR}${DATADIR}
+ @${REINPLACE_CMD} -r -e '/captcha_cmd:/s,"[^"]+","${DATADIR}/captcha.sh",' ${STAGEDIR}${ETCDIR}/${PORTNAME}.yml.example
.include <bsd.port.post.mk>
diff --git a/net-im/ejabberd/files/pkg-message.in b/net-im/ejabberd/files/pkg-message.in
index c91c3f7babd1..6b000d3ebc91 100644
--- a/net-im/ejabberd/files/pkg-message.in
+++ b/net-im/ejabberd/files/pkg-message.in
@@ -12,5 +12,6 @@ Congratulations, you have installed %%PORTNAME%%!
o PLEASE NOTE! "ejabberd" user UID and GID have changed from version 2.0.3
of this port! Users are advised to check all configuration files and data
in /var/spool/ejabberd to ensure everything has the correct owner/group.
+ o To start using CAPTCHA functionality, please install ImageMagick port.
------------------------------------------------------------------------
diff --git a/net-im/ejabberd/pkg-plist b/net-im/ejabberd/pkg-plist
index 1f56decbb19f..f7e731a9c519 100644
--- a/net-im/ejabberd/pkg-plist
+++ b/net-im/ejabberd/pkg-plist
@@ -730,6 +730,7 @@
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/zh.msg
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/priv/sql/lite.sql
sbin/%%PORTNAME%%ctl
+%%DATADIR%%/captcha.sh
%%PORTDOCS%%%%DOCSDIR%%/COPYING
@dir /var/log/%%PORTNAME%%
@dir /var/run/%%PORTNAME%%ctl