aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 04:15:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 04:15:07 +0000
commit2cbefe575abe259b1749f4247c215ea6f163d11f (patch)
treec2268fee8ba07ec73a65f879afd6d35e19df2af6 /net-im
parent362d7f6fd1cf491d22d7ef2d99b4ff60fb173521 (diff)
downloadports-2cbefe575abe259b1749f4247c215ea6f163d11f.tar.gz
ports-2cbefe575abe259b1749f4247c215ea6f163d11f.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/telepathy-haze/Makefile28
-rw-r--r--net-im/telepathy-haze/distinfo3
-rw-r--r--net-im/telepathy-haze/pkg-descr4
-rw-r--r--net-im/telepathy-haze/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index ba1a22632e5e..37f2bb3ffa0f 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -129,6 +129,7 @@
SUBDIR += telepathy-butterfly
SUBDIR += telepathy-gabble
SUBDIR += telepathy-glib
+ SUBDIR += telepathy-haze
SUBDIR += telepathy-idle
SUBDIR += telepathy-python
SUBDIR += telepathy-qt
diff --git a/net-im/telepathy-haze/Makefile b/net-im/telepathy-haze/Makefile
new file mode 100644
index 000000000000..00806ce87722
--- /dev/null
+++ b/net-im/telepathy-haze/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: telepathy-haze
+# Date created: 2007-10-29
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net-im/telepathy-haze/Makefile,v 1.3 2008/03/02 19:50:45 marcus Exp $
+
+PORTNAME= haze
+PORTVERSION= 0.2.0
+PORTREVISION= 1
+CATEGORIES= net-im
+MASTER_SITES= http://telepathy.freedesktop.org/releases/telepathy-haze/
+PKGNAMEPREFIX= telepathy-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Libpurple connection manager for telepathy
+
+LIB_DEPENDS= purple.4:${PORTSDIR}/net-im/libpurple \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
+
+USE_GNOME= pkgconfig
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+WRKSRC= ${WRKDIR}/telepathy-${PORTNAME}-${DISTVERSION}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-haze/distinfo b/net-im/telepathy-haze/distinfo
new file mode 100644
index 000000000000..28ebc9412273
--- /dev/null
+++ b/net-im/telepathy-haze/distinfo
@@ -0,0 +1,3 @@
+MD5 (telepathy-haze-0.2.0.tar.gz) = 63bb7d0f9c45be27d5cec478f9f61846
+SHA256 (telepathy-haze-0.2.0.tar.gz) = 63cd1d612eff7a3b206384d4a8dbce74a6481cce498b9be706e0f2a4d75f963b
+SIZE (telepathy-haze-0.2.0.tar.gz) = 362270
diff --git a/net-im/telepathy-haze/pkg-descr b/net-im/telepathy-haze/pkg-descr
new file mode 100644
index 000000000000..4ade5205b5f9
--- /dev/null
+++ b/net-im/telepathy-haze/pkg-descr
@@ -0,0 +1,4 @@
+Libpurple-based Telepathy connection manager, to provide Telepathy clients
+with access to the full range of protocols supported by libpurple.
+
+WWW: http://developer.pidgin.im/wiki/Telepathy
diff --git a/net-im/telepathy-haze/pkg-plist b/net-im/telepathy-haze/pkg-plist
new file mode 100644
index 000000000000..37a9a039f8a0
--- /dev/null
+++ b/net-im/telepathy-haze/pkg-plist
@@ -0,0 +1,5 @@
+libexec/telepathy-haze
+share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.haze.service
+share/telepathy/managers/haze.manager
+@dirrmtry share/telepathy/managers
+@dirrmtry share/telepathy