aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-09 10:08:19 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-09 10:08:19 +0000
commit42ec77e2f1f8576f45dbd47b1c988bf5106cb0e5 (patch)
tree8e0d5b26e7d65868e20d7e28211d09eea7e0d5a9 /net-im
parenta821cad16d83cd8b2939cfb7924f3f24e55b6b63 (diff)
downloadports-42ec77e2f1f8576f45dbd47b1c988bf5106cb0e5.tar.gz
ports-42ec77e2f1f8576f45dbd47b1c988bf5106cb0e5.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index c0153decd93d..6323e80af711 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/Psi/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt 4 based Jabber client
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl \
qca-gnupg>=2.0.0.b3:${PORTSDIR}/security/qca-gnupg
@@ -24,6 +24,7 @@ USE_XORG= xscrnsaver
CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${LOCALBASE} \
--disable-growl --verbose
CONFIGURE_ENV= QMAKEFLAGS='${QMAKEFLAGS}'
+DESTDIRNAME= INSTALL_ROOT
OPTIONS_DEFINE= ASPELL ENCHANT DBUS DEBUG
OPTIONS_DEFAULT= ASPELL DBUS
@@ -31,7 +32,6 @@ OPTIONS_DEFAULT= ASPELL DBUS
ASPELL_DESC= Use aspell for spell checking
ENCHANT_DESC= Use Enchant for spell checking
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
@@ -49,7 +49,7 @@ CONFIGURE_ARGS+= --disable-qdbus
.endif
.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-aspell-inc=${LOCALBASE}/include \
--with-aspell-lib=${LOCALBASE}/lib
.else
@@ -57,12 +57,12 @@ CONFIGURE_ARGS+= --disable-aspell
.endif
.if ${PORT_OPTIONS:MENCHANT}
-LIB_DEPENDS+= enchant.1:${PORTSDIR}/textproc/enchant
+LIB_DEPENDS+= libenchant.so:${PORTSDIR}/textproc/enchant
.else
CONFIGURE_ARGS+= --disable-enchant
.endif
post-install:
- ${STRIP_CMD} ${PREFIX}/bin/psi
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/psi
.include <bsd.port.mk>