aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /net-im
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ekiga/Makefile14
-rw-r--r--net-im/hotot/Makefile4
-rw-r--r--net-im/kde-telepathy/Makefile25
-rw-r--r--net-im/kmess-kde4/Makefile4
-rw-r--r--net-im/kopete-kde4/Makefile4
-rw-r--r--net-im/ktp-accounts-kcm/Makefile6
-rw-r--r--net-im/ktp-approver/Makefile6
-rw-r--r--net-im/ktp-auth-handler/Makefile4
-rw-r--r--net-im/ktp-common-internals/Makefile4
-rw-r--r--net-im/ktp-contact-list/Makefile4
-rw-r--r--net-im/ktp-contact-runner/Makefile4
-rw-r--r--net-im/ktp-desktop-applets/Makefile4
-rw-r--r--net-im/ktp-filetransfer-handler/Makefile4
-rw-r--r--net-im/ktp-kded-integration-module/Makefile4
-rw-r--r--net-im/ktp-send-file/Makefile8
-rw-r--r--net-im/ktp-text-ui/Makefile6
-rw-r--r--net-im/licq-qt-gui/Makefile3
-rw-r--r--net-im/plasma-applet-ktp/Makefile4
-rw-r--r--net-im/telepathy-logger-qt4/Makefile4
19 files changed, 58 insertions, 58 deletions
diff --git a/net-im/ekiga/Makefile b/net-im/ekiga/Makefile
index 2db49db86a4c..c02be2671577 100644
--- a/net-im/ekiga/Makefile
+++ b/net-im/ekiga/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libboost_signals.so:devel/boost-libs \
RUN_DEPENDS= gnome-icon-theme>=3.0.0:misc/gnome-icon-theme
GNU_CONFIGURE= yes
-USES= cpe gettext gmake libtool pathfix perl5 pkgconfig \
+USES= cpe gettext gmake kde:4 libtool pathfix perl5 pkgconfig \
tar:xz
USE_XORG= xv
USE_GNOME= gtk20 intlhack libxml2
@@ -51,20 +51,20 @@ LOUDMOUTH_DESC= XMPP (jabber) support
PLIST_SUB+= VERSION=${PORTVERSION}
.if ${PORT_OPTIONS:MKDE} || ${PORT_OPTIONS:MKAB}
-USE_KDE4= kdelibs
+USE_KDE= kdelibs
USE_QT4= corelib
CONFIGURE_ARGS+=--enable-kde
-#CONFIGURE_ENV+=KDE_CFLAGS="-I${KDE4_PREFIX}/include -I${QT_INCDIR} \
-# -I${LOCALBASE}/include" KDE_LIBS="-L${KDE4_PREFIX}/lib"
-CPPFLAGS+= -I${KDE4_PREFIX}/include
-LDFLAGS+= -L${KDE4_PREFIX}/lib
+#CONFIGURE_ENV+=KDE_CFLAGS="-I${KDE_PREFIX}/include -I${QT_INCDIR} \
+# -I${LOCALBASE}/include" KDE_LIBS="-L${KDE_PREFIX}/lib"
+CPPFLAGS+= -I${KDE_PREFIX}/include
+LDFLAGS+= -L${KDE_PREFIX}/lib
.else
CONFIGURE_ARGS+=--disable-kde
.endif
.if ${PORT_OPTIONS:MKAB}
CONFIGURE_ARGS+=--enable-kab
-USE_KDE4+= pimlibs
+USE_KDE+= pimlibs
.else
CONFIGURE_ARGS+=--disable-kab
.endif
diff --git a/net-im/hotot/Makefile b/net-im/hotot/Makefile
index b1ba6fbadc83..da7426ef26a9 100644
--- a/net-im/hotot/Makefile
+++ b/net-im/hotot/Makefile
@@ -15,7 +15,7 @@ USE_GITHUB= yes
GH_ACCOUNT= lyricat
GH_PROJECT= Hotot
-USES= cmake gettext python
+USES= cmake gettext kde:4 python
USE_GNOME= intltool
INSTALLS_ICONS= yes
@@ -48,7 +48,7 @@ PLIST_SUB+= QT4="@comment "
.endif
.if ${PORT_OPTIONS:MKDE4}
-USE_KDE4= automoc4 kdelibs
+USE_KDE= automoc4 kdelibs
.else
CMAKE_ARGS+= -DWITH_KDE=off
.endif
diff --git a/net-im/kde-telepathy/Makefile b/net-im/kde-telepathy/Makefile
index 65a4c0dcfeec..7b9d86415f09 100644
--- a/net-im/kde-telepathy/Makefile
+++ b/net-im/kde-telepathy/Makefile
@@ -7,17 +7,16 @@ CATEGORIES= net-im kde
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE integrated instant messaging framework
-RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kcm_ktp_accounts.so:net-im/ktp-accounts-kcm \
- ${KDE4_PREFIX}/lib/kde4/kded_ktp_approver.so:net-im/ktp-approver \
- ${KDE4_PREFIX}/lib/kde4/libexec/ktp-auth-handler:net-im/ktp-auth-handler \
- ${KDE4_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list \
- ${KDE4_PREFIX}/lib/kde4/krunner_ktp_contacts.so:net-im/ktp-contact-runner \
- ${KDE4_PREFIX}/lib/kde4/libexec/ktp-filetransfer-handler:net-im/ktp-filetransfer-handler \
- ${KDE4_PREFIX}/lib/kde4/kded_ktp_integration_module.so:net-im/ktp-kded-integration-module \
- ${KDE4_PREFIX}/lib/kde4/libexec/ktp-text-ui:net-im/ktp-text-ui
-
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/kcm_ktp_accounts.so:net-im/ktp-accounts-kcm \
+ ${KDE_PREFIX}/lib/kde4/kded_ktp_approver.so:net-im/ktp-approver \
+ ${KDE_PREFIX}/lib/kde4/libexec/ktp-auth-handler:net-im/ktp-auth-handler \
+ ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list \
+ ${KDE_PREFIX}/lib/kde4/krunner_ktp_contacts.so:net-im/ktp-contact-runner \
+ ${KDE_PREFIX}/lib/kde4/libexec/ktp-filetransfer-handler:net-im/ktp-filetransfer-handler \
+ ${KDE_PREFIX}/lib/kde4/kded_ktp_integration_module.so:net-im/ktp-kded-integration-module \
+ ${KDE_PREFIX}/lib/kde4/libexec/ktp-text-ui:net-im/ktp-text-ui
+
+USES= kde:4 metaport
OPTIONS_DEFINE= PLASMA SEND_FILE
OPTIONS_DEFAULT=PLASMA SEND_FILE
@@ -28,11 +27,11 @@ SEND_FILE_DESC= Context menu plugin for sending files
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPLASMA}
-RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/plasma_applet_ktp_presence.so:net-im/plasma-applet-ktp
+RUN_DEPENDS+= ${KDE_PREFIX}/lib/kde4/plasma_applet_ktp_presence.so:net-im/plasma-applet-ktp
.endif
.if ${PORT_OPTIONS:MSEND_FILE}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/ktp-send-file:net-im/ktp-send-file
+RUN_DEPENDS+= ${KDE_PREFIX}/bin/ktp-send-file:net-im/ktp-send-file
.endif
.include <bsd.port.mk>
diff --git a/net-im/kmess-kde4/Makefile b/net-im/kmess-kde4/Makefile
index 08cea47af3a7..c23ed5b3cdc2 100644
--- a/net-im/kmess-kde4/Makefile
+++ b/net-im/kmess-kde4/Makefile
@@ -13,9 +13,9 @@ COMMENT= MSN Messenger client for KDE
LIB_DEPENDS= libqca.so:devel/qca \
libgif.so:graphics/giflib
+USES= cmake gettext kde:4 tar:bzip2
USE_GNOME= libxml2 libxslt
-USE_KDE4= kdelibs libkonq automoc4
+USE_KDE= kdelibs libkonq automoc4
USE_QT4= qmake_build moc_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/kopete-kde4/Makefile b/net-im/kopete-kde4/Makefile
index 07c6a19fea46..5f0e5faeaad1 100644
--- a/net-im/kopete-kde4/Makefile
+++ b/net-im/kopete-kde4/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libjasper.so:graphics/jasper
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
-USES= cmake:outsource jpeg pkgconfig shebangfix sqlite tar:xz \
+USES= cmake:outsource jpeg kde:4 pkgconfig shebangfix sqlite tar:xz \
webplugin:native
USE_GNOME= libxml2 libxslt
-USE_KDE4= kdelibs pimlibs \
+USE_KDE= kdelibs pimlibs \
automoc4 qimageblitz
USE_QT4= corelib gui network qt3support sql xml \
moc_build qmake_build rcc_build uic_build uic3_build
diff --git a/net-im/ktp-accounts-kcm/Makefile b/net-im/ktp-accounts-kcm/Makefile
index 2a607f13eccb..009253d141f7 100644
--- a/net-im/ktp-accounts-kcm/Makefile
+++ b/net-im/ktp-accounts-kcm/Makefile
@@ -11,11 +11,11 @@ COMMENT= KDE instant messaging account management module
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libtelepathy-logger-qt4.so:net-im/telepathy-logger-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-RUN_DEPENDS= ${KDE4_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
+RUN_DEPENDS= ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
USE_LDCONFIG= yes
OPTIONS_DEFINE= HAZE IRC JABBER SALUT
diff --git a/net-im/ktp-approver/Makefile b/net-im/ktp-approver/Makefile
index 507622d747ef..bd8c1c8b64ac 100644
--- a/net-im/ktp-approver/Makefile
+++ b/net-im/ktp-approver/Makefile
@@ -10,10 +10,10 @@ COMMENT= KDE instant messaging notifier
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-RUN_DEPENDS= ${KDE4_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
+RUN_DEPENDS= ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-auth-handler/Makefile b/net-im/ktp-auth-handler/Makefile
index 511e1ff2a038..14877fe944d7 100644
--- a/net-im/ktp-auth-handler/Makefile
+++ b/net-im/ktp-auth-handler/Makefile
@@ -13,9 +13,9 @@ LIB_DEPENDS= libqjson.so:devel/qjson \
libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib dbus gui xml webkit \
moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-common-internals/Makefile b/net-im/ktp-common-internals/Makefile
index b49019f61d55..1b1a9e899af2 100644
--- a/net-im/ktp-common-internals/Makefile
+++ b/net-im/ktp-common-internals/Makefile
@@ -12,10 +12,10 @@ LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libtelepathy-logger-qt4.so:net-im/telepathy-logger-qt4
RUN_DEPENDS= ${LOCALBASE}/libexec/mission-control-5:net-im/telepathy-mission-control
-USE_KDE4= kdelibs pimlibs automoc4
+USES= cmake compiler:c++11-lang gettext kde:4 tar:bzip2
+USE_KDE= kdelibs pimlibs automoc4
USE_QT4= declarative script \
moc_build qmake_build rcc_build uic_build
-USES= cmake compiler:c++11-lang gettext tar:bzip2
USE_LDCONFIG= yes
PLIST_SUB= KTP_VERSION=${KTP_VERSION}
diff --git a/net-im/ktp-contact-list/Makefile b/net-im/ktp-contact-list/Makefile
index c1053ada1fd9..3e3bff1f3f3a 100644
--- a/net-im/ktp-contact-list/Makefile
+++ b/net-im/ktp-contact-list/Makefile
@@ -12,8 +12,8 @@ LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libtelepathy-logger-qt4.so:net-im/telepathy-logger-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-contact-runner/Makefile b/net-im/ktp-contact-runner/Makefile
index 724bb1d11718..b2efa6012b25 100644
--- a/net-im/ktp-contact-runner/Makefile
+++ b/net-im/ktp-contact-runner/Makefile
@@ -11,8 +11,8 @@ COMMENT= KRunner integration module for KDE Telepathy
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-desktop-applets/Makefile b/net-im/ktp-desktop-applets/Makefile
index f90a5a026826..2e698e57743f 100644
--- a/net-im/ktp-desktop-applets/Makefile
+++ b/net-im/ktp-desktop-applets/Makefile
@@ -10,8 +10,8 @@ COMMENT= KDE instant messaging plasma widgets
LIB_DEPENDS= libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-filetransfer-handler/Makefile b/net-im/ktp-filetransfer-handler/Makefile
index 0cbf05daaf56..2f8f7ef30387 100644
--- a/net-im/ktp-filetransfer-handler/Makefile
+++ b/net-im/ktp-filetransfer-handler/Makefile
@@ -11,8 +11,8 @@ COMMENT= KDE instant messaging file transfer handler
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-kded-integration-module/Makefile b/net-im/ktp-kded-integration-module/Makefile
index af282c378431..441424463d43 100644
--- a/net-im/ktp-kded-integration-module/Makefile
+++ b/net-im/ktp-kded-integration-module/Makefile
@@ -11,8 +11,8 @@ COMMENT= Module for integration of instant messaging into KDE Workspaces
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-send-file/Makefile b/net-im/ktp-send-file/Makefile
index 421a1d772420..65254ab5b8d0 100644
--- a/net-im/ktp-send-file/Makefile
+++ b/net-im/ktp-send-file/Makefile
@@ -10,11 +10,11 @@ COMMENT= KDE instant messaging file transfer application
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/libexec/ktp-filetransfer-handler:net-im/ktp-filetransfer-handler \
- ${KDE4_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
+RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/libexec/ktp-filetransfer-handler:net-im/ktp-filetransfer-handler \
+ ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/ktp-text-ui/Makefile b/net-im/ktp-text-ui/Makefile
index b277065e00f0..45c24146b72e 100644
--- a/net-im/ktp-text-ui/Makefile
+++ b/net-im/ktp-text-ui/Makefile
@@ -11,12 +11,12 @@ COMMENT= KDE chat window application
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libtelepathy-logger-qt4.so:net-im/telepathy-logger-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-RUN_DEPENDS= ${KDE4_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
+RUN_DEPENDS= ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
-USE_KDE4= automoc4
+USES= cmake compiler:c++11-lang gettext kde:4 tar:bzip2
+USE_KDE= automoc4
USE_QT4= corelib webkit xml \
moc_build qmake_build rcc_build uic_build
-USES= cmake compiler:c++11-lang gettext tar:bzip2
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index ad43eefc2e92..f0064f1404f7 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -31,7 +31,8 @@ HUNSPELL_CMAKE_ON= -DHUNSPELL_INCLUDE_DIRS=${LOCALBASE}/include/hunspell \
-DHUNSPELL_FOUND:BOOL=ON
HUNSPELL_CMAKE_OFF= -DHUNSPELL_FOUND:BOOL=OFF
-KDE4_USE= KDE4=kdelibs,automoc4
+KDE4_USES= kde:4
+KDE4_USE= KDE=kdelibs,automoc4
KDE4_PREVENTS= HUNSPELL
KDE4_CMAKE_ON= -DWITH_KDE:BOOL=ON
KDE4_CMAKE_OFF= -DWITH_KDE:BOOL=OFF
diff --git a/net-im/plasma-applet-ktp/Makefile b/net-im/plasma-applet-ktp/Makefile
index a9fe6b6c81a2..a9ad32d3f73b 100644
--- a/net-im/plasma-applet-ktp/Makefile
+++ b/net-im/plasma-applet-ktp/Makefile
@@ -13,9 +13,9 @@ COMMENT= KDE instant messaging Plasma applets
LIB_DEPENDS= libtelepathy-qt4.so:net-im/telepathy-qt4 \
libktpcommoninternalsprivate.so:net-im/ktp-common-internals
-USE_KDE4= kdelibs automoc4
+USES= cmake gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= corelib declarative \
moc_build qmake_build rcc_build uic_build
-USES= cmake gettext tar:bzip2
.include <bsd.port.mk>
diff --git a/net-im/telepathy-logger-qt4/Makefile b/net-im/telepathy-logger-qt4/Makefile
index eff68e898aa7..49d83df93e0b 100644
--- a/net-im/telepathy-logger-qt4/Makefile
+++ b/net-im/telepathy-logger-qt4/Makefile
@@ -17,11 +17,11 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libtelepathy-logger.so:net-im/telepathy-logger \
libtelepathy-qt4.so:net-im/telepathy-qt4
+USES= bison:build cmake kde:4 pkgconfig python:build tar:bzip2
USE_GNOME= glib20 libxml2
USE_GSTREAMER= qt4
-USE_KDE4= # empty
+USE_KDE= # empty
USE_QT4= corelib dbus moc_build qmake_build rcc_build uic_build
-USES= bison:build cmake pkgconfig python:build tar:bzip2
CMAKE_ARGS= -DUSE_COMMON_CMAKE_PACKAGE_CONFIG_DIR:BOOL=True
USE_LDCONFIG= yes