aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-07 09:42:42 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-07 09:42:42 +0000
commit11518e301cf225a874d4588d4cf2095874dec054 (patch)
tree2e7e626f87943b63c88e1424f5eed57b29788af2 /net-im
parent89b7a3f045abb10de309985ae326e450fbb43b44 (diff)
downloadports-11518e301cf225a874d4588d4cf2095874dec054.tar.gz
ports-11518e301cf225a874d4588d4cf2095874dec054.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile2
-rw-r--r--net-im/centericq/files/patch-msnhook.cc16
2 files changed, 16 insertions, 2 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 170a0f75b905..1279da3af02e 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,7 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.9.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://konst.org.ua/download/
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
index 9d8a7559f832..653618e18ef5 100644
--- a/net-im/centericq/files/patch-msnhook.cc
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -1,5 +1,5 @@
--- src/hooks/msnhook.cc Fri Dec 13 00:17:12 2002
-+++ src/hooks/msnhook.cc Wed Dec 18 14:57:02 2002
++++ src/hooks/msnhook.cc Sun Jan 5 02:02:44 2003
@@ -29,6 +29,7 @@
#include "accountmanager.h"
#include "eventmanager.h"
@@ -18,6 +18,20 @@
if(c)
if(c->getstatus() != offline || !c->inlist()) {
+@@ -352,11 +354,11 @@
+
+ void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
+ string oldnick = c->getnick();
+- string newnick = unmime(friendlynick);
++ string newnick = Utf8ToStr(unmime(friendlynick));
+
+ c->setnick(newnick);
+
+- if(forcefetch || (oldnick != newnick && c->getdispnick() == oldnick) || oldnick.empty()) {
++ if(forcefetch || (oldnick != newnick && c->getdispnick() != newnick) || oldnick.empty()) {
+ c->setdispnick(newnick);
+ face.relaxedupdate();
+ }
@@ -556,7 +558,8 @@
mhook.checkinlist(ic);