aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-10-30 18:08:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 13:50:53 +0000
commit45526ecbeec33dbb87f0b678d4c04988aab9b657 (patch)
treeb77614b463af0ed929512fcc838ff5cb20c96275 /net-im
parenta148ebec4e0afe980f949de0dea5ef4931cb7e86 (diff)
downloadports-45526ecbeec33dbb87f0b678d4c04988aab9b657.tar.gz
ports-45526ecbeec33dbb87f0b678d4c04988aab9b657.zip
framework: Add new USES 'magick' for graphics/ImageMagick*
A new USES has been added to depend on ImageMagick. USES=magick adds a LIB_DEPENDS on graphics/ImageMagick${IMAGEMAGICK_DEFAULT}. If a specific version is required, use for example USES=magick:6 resp. USES=magick:7 If only a build, run or test is required, use for example USES=magick:build resp. USES=magick:6,build,test If a dependency on the nox11 flavor is required, use for example USES=magick:nox11 resp. USES=magick:7,nox11,run,test See magick.mk for more details on the available flags. The tree has been completely converted to make use of this. Approved by: bapt Differential Revision: https://reviews.freebsd.org/D32754
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin-latex/Makefile5
-rw-r--r--net-im/purple-discord/Makefile3
2 files changed, 3 insertions, 5 deletions
diff --git a/net-im/pidgin-latex/Makefile b/net-im/pidgin-latex/Makefile
index 161fe0f0bef3..ec1438e3e132 100644
--- a/net-im/pidgin-latex/Makefile
+++ b/net-im/pidgin-latex/Makefile
@@ -12,12 +12,11 @@ MAINTAINER= mainland@apeiron.net
COMMENT= Display LaTeX output in your IMs
BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:net-im/pidgin
-RUN_DEPENDS= pidgin:net-im/pidgin \
- convert:graphics/ImageMagick6
+RUN_DEPENDS= pidgin:net-im/pidgin
WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
-USES= gmake gnome pkgconfig tar:bzip2
+USES= gmake gnome magick:6,run pkgconfig tar:bzip2
USE_TEX= latex
USE_GNOME= gtk20
MAKE_ARGS= CC="${CC}"
diff --git a/net-im/purple-discord/Makefile b/net-im/purple-discord/Makefile
index f0b66eb23f8e..6268f9b968d4 100644
--- a/net-im/purple-discord/Makefile
+++ b/net-im/purple-discord/Makefile
@@ -8,11 +8,10 @@ COMMENT= Discord plugin for libpurple
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= convert:graphics/ImageMagick6
LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
libpurple.so:net-im/libpurple
-USES= dos2unix gettext gmake gnome pkgconfig
+USES= dos2unix gettext gmake gnome magick:6,build pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_GITHUB= yes