aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-10-15 09:37:55 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-10-15 09:37:55 +0000
commit556cfc538335973fb70ed7c214c0578dc90ec085 (patch)
tree8f57c8a70c303c3696ad3974a5eba4ac948060f8 /net-im
parent1b874c11647543d120280928b04132e9d312d32d (diff)
downloadports-556cfc538335973fb70ed7c214c0578dc90ec085.tar.gz
ports-556cfc538335973fb70ed7c214c0578dc90ec085.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/sim-im/Makefile5
-rw-r--r--net-im/sim-im/files/patch-sim-api-fetch.cpp11
-rw-r--r--net-im/sim-im/pkg-plist2
-rw-r--r--net-im/simicq/Makefile5
-rw-r--r--net-im/simicq/files/patch-sim-api-fetch.cpp11
-rw-r--r--net-im/simicq/pkg-plist2
6 files changed, 34 insertions, 2 deletions
diff --git a/net-im/sim-im/Makefile b/net-im/sim-im/Makefile
index 7c037f8d10ee..2c98fd705147 100644
--- a/net-im/sim-im/Makefile
+++ b/net-im/sim-im/Makefile
@@ -58,4 +58,9 @@ post-patch:
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
${CONFIGURE_WRKSRC}/configure
+post-configure:
+.if defined(WITHOUT_SSL)
+ @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
+.endif
+
.include <bsd.port.mk>
diff --git a/net-im/sim-im/files/patch-sim-api-fetch.cpp b/net-im/sim-im/files/patch-sim-api-fetch.cpp
new file mode 100644
index 000000000000..982bc837c1dd
--- /dev/null
+++ b/net-im/sim-im/files/patch-sim-api-fetch.cpp
@@ -0,0 +1,11 @@
+--- sim/api/fetch.cpp.orig Fri Oct 15 01:17:45 2004
++++ sim/api/fetch.cpp Fri Oct 15 01:21:31 2004
+@@ -24,6 +24,8 @@
+ #include <qthread.h>
+ #include <qtimer.h>
+
++#include <time.h>
++
+ typedef map<my_string, string> HEADERS_MAP;
+
+ class FetchThread;
diff --git a/net-im/sim-im/pkg-plist b/net-im/sim-im/pkg-plist
index b10461b9c1e7..122fbcdd7d7e 100644
--- a/net-im/sim-im/pkg-plist
+++ b/net-im/sim-im/pkg-plist
@@ -40,7 +40,7 @@ lib/sim/styles.so
%%KDE%%lib/sim/transparent.so
lib/sim/update.so
lib/sim/weather.so
-lib/sim/yahoo.so
+%%SSL%%lib/sim/yahoo.so
lib/sim/zodiak.so
share/applnk/Internet/sim.desktop
share/apps/sim/COPYING
diff --git a/net-im/simicq/Makefile b/net-im/simicq/Makefile
index 7c037f8d10ee..2c98fd705147 100644
--- a/net-im/simicq/Makefile
+++ b/net-im/simicq/Makefile
@@ -58,4 +58,9 @@ post-patch:
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
${CONFIGURE_WRKSRC}/configure
+post-configure:
+.if defined(WITHOUT_SSL)
+ @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
+.endif
+
.include <bsd.port.mk>
diff --git a/net-im/simicq/files/patch-sim-api-fetch.cpp b/net-im/simicq/files/patch-sim-api-fetch.cpp
new file mode 100644
index 000000000000..982bc837c1dd
--- /dev/null
+++ b/net-im/simicq/files/patch-sim-api-fetch.cpp
@@ -0,0 +1,11 @@
+--- sim/api/fetch.cpp.orig Fri Oct 15 01:17:45 2004
++++ sim/api/fetch.cpp Fri Oct 15 01:21:31 2004
+@@ -24,6 +24,8 @@
+ #include <qthread.h>
+ #include <qtimer.h>
+
++#include <time.h>
++
+ typedef map<my_string, string> HEADERS_MAP;
+
+ class FetchThread;
diff --git a/net-im/simicq/pkg-plist b/net-im/simicq/pkg-plist
index b10461b9c1e7..122fbcdd7d7e 100644
--- a/net-im/simicq/pkg-plist
+++ b/net-im/simicq/pkg-plist
@@ -40,7 +40,7 @@ lib/sim/styles.so
%%KDE%%lib/sim/transparent.so
lib/sim/update.so
lib/sim/weather.so
-lib/sim/yahoo.so
+%%SSL%%lib/sim/yahoo.so
lib/sim/zodiak.so
share/applnk/Internet/sim.desktop
share/apps/sim/COPYING