aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-02 03:41:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-02 03:41:14 +0000
commit5684599bf617d22ac9e17688aab91cb671aeb397 (patch)
treeb4dfebb32b1c0ea41ed5bcae7890d745f38a84e3 /net-im
parentf0588e01feb1ae29fde932efe6a627a42be50770 (diff)
downloadports-5684599bf617d22ac9e17688aab91cb671aeb397.tar.gz
ports-5684599bf617d22ac9e17688aab91cb671aeb397.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile1
-rw-r--r--net-im/centericq/files/patch-msnhook.cc16
2 files changed, 17 insertions, 0 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 02d908adb5fb..56e65c7bb716 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,6 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.9.11
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://centericq.de/archive/source/releases/
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
new file mode 100644
index 000000000000..0bbda9b195eb
--- /dev/null
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -0,0 +1,16 @@
+--- src/hooks/msnhook.cc.orig Sun Mar 7 21:44:41 2004
++++ src/hooks/msnhook.cc Fri Apr 2 10:23:03 2004
+@@ -408,11 +408,11 @@
+
+ void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
+ string oldnick = c->getnick();
+- string newnick = unmime(friendlynick);
++ string newnick = rusconv("uk",unmime(friendlynick));
+
+ c->setnick(newnick);
+
+- if(forcefetch || (oldnick != newnick && c->getdispnick() == oldnick) || oldnick.empty()) {
++ if(forcefetch || (oldnick != newnick && c->getdispnick() != newnick) || oldnick.empty()) {
+ c->setdispnick(newnick);
+ face.relaxedupdate();
+ }