aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2013-03-14 12:21:16 +0000
committerAlberto Villa <avilla@FreeBSD.org>2013-03-14 12:21:16 +0000
commitdba8414819caba0260f77d66d6b337e1399c7057 (patch)
treed8724addd0746179aaec872c6268a45283991939 /net-im
parentfd3ce1e81987ea2abcb89e7a97946bb737c0fd4f (diff)
downloadports-dba8414819caba0260f77d66d6b337e1399c7057.tar.gz
ports-dba8414819caba0260f77d66d6b337e1399c7057.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-qt4/Makefile55
-rw-r--r--net-im/telepathy-qt4/distinfo4
-rw-r--r--net-im/telepathy-qt4/pkg-descr2
-rw-r--r--net-im/telepathy-qt4/pkg-plist21
4 files changed, 48 insertions, 34 deletions
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
index 978181cf50d7..c8d5992f2a7b 100644
--- a/net-im/telepathy-qt4/Makefile
+++ b/net-im/telepathy-qt4/Makefile
@@ -1,12 +1,7 @@
-# New ports collection Makefile for: telepathy-qt4
-# Date created: 14 January 2010
-# Whom: Alberto Villa <villa.alberto@gmail.com>
-#
# $FreeBSD$
PORTNAME= telepathy-qt4
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME:C/4//}/
DISTNAME= ${PORTNAME:C/4//}-${PORTVERSION}
@@ -15,60 +10,62 @@ MAINTAINER= avilla@FreeBSD.org
COMMENT= High-level Qt binding for Telepathy
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= telepathy-farsight.0:${PORTSDIR}/net-im/telepathy-farsight \
- telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= telepathy-farsight:${PORTSDIR}/net-im/telepathy-farsight \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib
-USE_GNOME= pkgconfig
+USE_GNOME= libxslt:build
+USE_GSTREAMER= yes
+USE_PKGCONFIG= yes
USE_PYTHON_BUILD= 2.5+
USE_QT4= dbus gui network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
USE_CMAKE= yes
+CMAKE_ARGS= -DENABLE_FARSIGHT:BOOL=True \
+ -DENABLE_TESTS:BOOL=False
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+
PORTDOCS= AUTHORS ChangeLog HACKING NEWS README html
-PORTEXAMPLES= Makefile accounts contact-messenger extensions \
+PORTEXAMPLES= Makefile accounts cm contact-messenger extensions \
file-transfer protocols roster stream-tubes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+CMAKE_ARGS+= -DENABLE_EXAMPLES:BOOL=True
+.else
+CMAKE_ARGS+= -DENABLE_EXAMPLES:BOOL=False
+.endif
+
pre-configure:
${REINPLACE_CMD} -e '/FIND_PROGRAM/ s/qmake //' \
${WRKSRC}/cmake/modules/FindQt.cmake
- ${REINPLACE_CMD} -e '/add_subdirectory(tests)/ d' \
- ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e '/^add_dependencies(doxygen-doc / d' \
${WRKSRC}/TelepathyQt/CMakeLists.txt
-.ifdef(NOPORTEXAMPLES)
- ${REINPLACE_CMD} -e '/add_subdirectory(examples)/ d' \
- ${WRKSRC}/CMakeLists.txt
-.endif
${REINPLACE_CMD} -e '/TelepathyQt.*\.pc/ s|pkgconfig|../libdata/pkgconfig|' \
${WRKSRC}/TelepathyQt/CMakeLists.txt \
${WRKSRC}/TelepathyQt/Farsight/CMakeLists.txt
${REINPLACE_CMD} -e '/$${LIBXML2_INCLUDE_DIR}/ s|$$| ${LOCALBASE}/include|' \
${WRKSRC}/TelepathyQt/Farsight/CMakeLists.txt
-pre-install:
-.ifndef(NOPORTDOCS)
- cd ${WRKSRC} && ${CP} -R doc/html .
-.endif
-
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
+ cd ${WRKSRC} && ${CP} -R doc/html .
+. for f in ${PORTDOCS}
cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${DOCSDIR}
-.endfor
+. endfor
.endif
-.ifndef(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
cd ${WRKSRC}/examples && ${RM} -rf */CMakeFiles */*.cmake */Makefile
${MKDIR} ${EXAMPLESDIR}
-.for f in ${PORTEXAMPLES}
+. for f in ${PORTEXAMPLES}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${f} ${EXAMPLESDIR}
-.endfor
+. endfor
.endif
.include <bsd.port.mk>
diff --git a/net-im/telepathy-qt4/distinfo b/net-im/telepathy-qt4/distinfo
index cd16718d3f87..320ef4d0d908 100644
--- a/net-im/telepathy-qt4/distinfo
+++ b/net-im/telepathy-qt4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (telepathy-qt-0.9.1.tar.gz) = d097b49a3912fed0e9ef0f295740b4002aedf2c1013cbdeb20d91063a6ec9e67
-SIZE (telepathy-qt-0.9.1.tar.gz) = 4624632
+SHA256 (telepathy-qt-0.9.3.tar.gz) = c0ff57bea79b86ad343e184c16941d05f6d6d7dfd03876b44502f11935f44bf9
+SIZE (telepathy-qt-0.9.3.tar.gz) = 4414599
diff --git a/net-im/telepathy-qt4/pkg-descr b/net-im/telepathy-qt4/pkg-descr
index 1d42b623730b..bfeedb6a5f5f 100644
--- a/net-im/telepathy-qt4/pkg-descr
+++ b/net-im/telepathy-qt4/pkg-descr
@@ -5,4 +5,4 @@ including instant messaging, voice calls and video calls. It abstracts
differences between protocols to provide a unified interface for
applications.
-WWW: http://telepathy.freedesktop.org/wiki/Telepathy%20Qt
+WWW: http://telepathy.freedesktop.org/doc/telepathy-qt
diff --git a/net-im/telepathy-qt4/pkg-plist b/net-im/telepathy-qt4/pkg-plist
index 3d1bcc0ba2a5..104ea486e103 100644
--- a/net-im/telepathy-qt4/pkg-plist
+++ b/net-im/telepathy-qt4/pkg-plist
@@ -36,6 +36,7 @@ include/telepathy-qt4/TelepathyQt/CallStreamEndpoint
include/telepathy-qt4/TelepathyQt/CallStreamEndpointInterface
include/telepathy-qt4/TelepathyQt/CallStreamInterface
include/telepathy-qt4/TelepathyQt/CallStreamInterfaceMediaInterface
+include/telepathy-qt4/TelepathyQt/Callbacks
include/telepathy-qt4/TelepathyQt/CapabilitiesBase
include/telepathy-qt4/TelepathyQt/Captcha
include/telepathy-qt4/TelepathyQt/CaptchaAuthentication
@@ -130,7 +131,9 @@ include/telepathy-qt4/TelepathyQt/DBus
include/telepathy-qt4/TelepathyQt/DBusDaemonInterface
include/telepathy-qt4/TelepathyQt/DBusProxy
include/telepathy-qt4/TelepathyQt/DBusProxyFactory
+include/telepathy-qt4/TelepathyQt/DBusTubeChannel
include/telepathy-qt4/TelepathyQt/Debug
+include/telepathy-qt4/TelepathyQt/DebugReceiver
include/telepathy-qt4/TelepathyQt/Farsight/Channel
include/telepathy-qt4/TelepathyQt/Farsight/channel.h
include/telepathy-qt4/TelepathyQt/Farsight/global.h
@@ -140,10 +143,12 @@ include/telepathy-qt4/TelepathyQt/FileTransferChannel
include/telepathy-qt4/TelepathyQt/FileTransferChannelCreationProperties
include/telepathy-qt4/TelepathyQt/Filter
include/telepathy-qt4/TelepathyQt/FixedFeatureFactory
+include/telepathy-qt4/TelepathyQt/Functors
include/telepathy-qt4/TelepathyQt/GenericCapabilityFilter
include/telepathy-qt4/TelepathyQt/GenericPropertyFilter
include/telepathy-qt4/TelepathyQt/Global
include/telepathy-qt4/TelepathyQt/HandledChannelNotifier
+include/telepathy-qt4/TelepathyQt/IncomingDBusTubeChannel
include/telepathy-qt4/TelepathyQt/IncomingFileTransferChannel
include/telepathy-qt4/TelepathyQt/IncomingStreamTubeChannel
include/telepathy-qt4/TelepathyQt/IntrospectableInterface
@@ -160,6 +165,7 @@ include/telepathy-qt4/TelepathyQt/NotFilter
include/telepathy-qt4/TelepathyQt/Object
include/telepathy-qt4/TelepathyQt/OptionalInterfaceFactory
include/telepathy-qt4/TelepathyQt/OrFilter
+include/telepathy-qt4/TelepathyQt/OutgoingDBusTubeChannel
include/telepathy-qt4/TelepathyQt/OutgoingFileTransferChannel
include/telepathy-qt4/TelepathyQt/OutgoingStreamTubeChannel
include/telepathy-qt4/TelepathyQt/PeerInterface
@@ -173,6 +179,8 @@ include/telepathy-qt4/TelepathyQt/PendingConnection
include/telepathy-qt4/TelepathyQt/PendingContactAttributes
include/telepathy-qt4/TelepathyQt/PendingContactInfo
include/telepathy-qt4/TelepathyQt/PendingContacts
+include/telepathy-qt4/TelepathyQt/PendingDBusTubeConnection
+include/telepathy-qt4/TelepathyQt/PendingDebugMessageList
include/telepathy-qt4/TelepathyQt/PendingFailure
include/telepathy-qt4/TelepathyQt/PendingHandles
include/telepathy-qt4/TelepathyQt/PendingOperation
@@ -241,6 +249,7 @@ include/telepathy-qt4/TelepathyQt/_gen/cli-client.h
include/telepathy-qt4/TelepathyQt/_gen/cli-connection-manager.h
include/telepathy-qt4/TelepathyQt/_gen/cli-connection.h
include/telepathy-qt4/TelepathyQt/_gen/cli-dbus.h
+include/telepathy-qt4/TelepathyQt/_gen/cli-debug-receiver.h
include/telepathy-qt4/TelepathyQt/_gen/cli-media-session-handler.h
include/telepathy-qt4/TelepathyQt/_gen/cli-media-stream-handler.h
include/telepathy-qt4/TelepathyQt/_gen/cli-properties.h
@@ -263,6 +272,7 @@ include/telepathy-qt4/TelepathyQt/call-content-media-description.h
include/telepathy-qt4/TelepathyQt/call-content.h
include/telepathy-qt4/TelepathyQt/call-stream-endpoint.h
include/telepathy-qt4/TelepathyQt/call-stream.h
+include/telepathy-qt4/TelepathyQt/callbacks.h
include/telepathy-qt4/TelepathyQt/capabilities-base.h
include/telepathy-qt4/TelepathyQt/captcha-authentication.h
include/telepathy-qt4/TelepathyQt/captcha.h
@@ -290,17 +300,21 @@ include/telepathy-qt4/TelepathyQt/contact-search-channel.h
include/telepathy-qt4/TelepathyQt/contact.h
include/telepathy-qt4/TelepathyQt/dbus-proxy-factory.h
include/telepathy-qt4/TelepathyQt/dbus-proxy.h
+include/telepathy-qt4/TelepathyQt/dbus-tube-channel.h
include/telepathy-qt4/TelepathyQt/dbus.h
+include/telepathy-qt4/TelepathyQt/debug-receiver.h
include/telepathy-qt4/TelepathyQt/debug.h
include/telepathy-qt4/TelepathyQt/feature.h
include/telepathy-qt4/TelepathyQt/file-transfer-channel-creation-properties.h
include/telepathy-qt4/TelepathyQt/file-transfer-channel.h
include/telepathy-qt4/TelepathyQt/filter.h
include/telepathy-qt4/TelepathyQt/fixed-feature-factory.h
+include/telepathy-qt4/TelepathyQt/functors.h
include/telepathy-qt4/TelepathyQt/generic-capability-filter.h
include/telepathy-qt4/TelepathyQt/generic-property-filter.h
include/telepathy-qt4/TelepathyQt/global.h
include/telepathy-qt4/TelepathyQt/handled-channel-notifier.h
+include/telepathy-qt4/TelepathyQt/incoming-dbus-tube-channel.h
include/telepathy-qt4/TelepathyQt/incoming-file-transfer-channel.h
include/telepathy-qt4/TelepathyQt/incoming-stream-tube-channel.h
include/telepathy-qt4/TelepathyQt/location-info.h
@@ -313,6 +327,7 @@ include/telepathy-qt4/TelepathyQt/not-filter.h
include/telepathy-qt4/TelepathyQt/object.h
include/telepathy-qt4/TelepathyQt/optional-interface-factory.h
include/telepathy-qt4/TelepathyQt/or-filter.h
+include/telepathy-qt4/TelepathyQt/outgoing-dbus-tube-channel.h
include/telepathy-qt4/TelepathyQt/outgoing-file-transfer-channel.h
include/telepathy-qt4/TelepathyQt/outgoing-stream-tube-channel.h
include/telepathy-qt4/TelepathyQt/pending-account.h
@@ -323,6 +338,8 @@ include/telepathy-qt4/TelepathyQt/pending-connection.h
include/telepathy-qt4/TelepathyQt/pending-contact-attributes.h
include/telepathy-qt4/TelepathyQt/pending-contact-info.h
include/telepathy-qt4/TelepathyQt/pending-contacts.h
+include/telepathy-qt4/TelepathyQt/pending-dbus-tube-connection.h
+include/telepathy-qt4/TelepathyQt/pending-debug-message-list.h
include/telepathy-qt4/TelepathyQt/pending-handles.h
include/telepathy-qt4/TelepathyQt/pending-operation.h
include/telepathy-qt4/TelepathyQt/pending-ready.h
@@ -366,10 +383,10 @@ lib/cmake/TelepathyQt4Farsight/TelepathyQt4FarsightConfig.cmake
lib/cmake/TelepathyQt4Farsight/TelepathyQt4FarsightConfigVersion.cmake
lib/libtelepathy-qt4-farsight.so
lib/libtelepathy-qt4-farsight.so.2
-lib/libtelepathy-qt4-farsight.so.2.0.9.1
+lib/libtelepathy-qt4-farsight.so.2.%%PORTVERSION%%
lib/libtelepathy-qt4.so
lib/libtelepathy-qt4.so.2
-lib/libtelepathy-qt4.so.2.0.9.1
+lib/libtelepathy-qt4.so.2.%%PORTVERSION%%
libdata/pkgconfig/TelepathyQt4.pc
libdata/pkgconfig/TelepathyQt4Farsight.pc
@dirrm lib/cmake/TelepathyQt4Farsight