aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-10-21 08:14:14 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-10-21 08:14:14 +0000
commit49298a66f56056c2485bdd8fbb5f851781d852fb (patch)
tree20a1f89276d5f668341fd8edd988607e91143aba /net-im
parente5cc6ee0d813272d15aafc3f4771cb0081f1f2c6 (diff)
downloadports-49298a66f56056c2485bdd8fbb5f851781d852fb.tar.gz
ports-49298a66f56056c2485bdd8fbb5f851781d852fb.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/Makefile5
-rw-r--r--net-im/mcabber/files/patch-src_hbuf.c19
2 files changed, 22 insertions, 2 deletions
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 83b2108384b0..41a025a421cc 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mcabber
PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.lilotux.net/~mikael/mcabber/files/
@@ -22,7 +22,8 @@ USE_GETTEXT= yes
USE_GNOME= glib20
USE_GETOPT_LONG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -lcrypto
+
MAN1= mcabber.1
PLIST_FILES= bin/mcabber %%EXAMPLESDIR%%/mcabberrc
PLIST_DIRS= %%EXAMPLESDIR%%
diff --git a/net-im/mcabber/files/patch-src_hbuf.c b/net-im/mcabber/files/patch-src_hbuf.c
new file mode 100644
index 000000000000..4184cd99acfc
--- /dev/null
+++ b/net-im/mcabber/files/patch-src_hbuf.c
@@ -0,0 +1,19 @@
+$FreeBSD$
+
+--- src/hbuf.c.orig
++++ src/hbuf.c
+@@ -70,12 +70,12 @@
+ // Set p_hbuf to the end of the list, to speed up history loading
+ // (or CPU time will be used by g_list_last() for each line)
+ hbuf = *p_hbuf = g_list_last(*p_hbuf);
+- hbuf_block *hbuf_b_prev = hbuf->data;
++ { hbuf_block *hbuf_b_prev = hbuf->data;
+ hbuf_block_elt->ptr = hbuf_b_prev->ptr_end;
+ hbuf_block_elt->flags = HBB_FLAG_PERSISTENT;
+ hbuf_block_elt->ptr_end_alloc = hbuf_b_prev->ptr_end_alloc;
+ g_list_append(*p_hbuf, hbuf_block_elt);
+- }
++ }}
+
+ if (strlen(text) >= HBB_BLOCKSIZE) {
+ // Too long