aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-03 14:56:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-03 14:56:47 +0000
commit632bc2318b5aee8516130edc10d78945d9aeed02 (patch)
treebfe3203c936b119dba2b217896925a19b4342967 /net-im
parent77174668b31f52d9db4c1c4a713b4b69a283bff5 (diff)
downloadports-632bc2318b5aee8516130edc10d78945d9aeed02.tar.gz
ports-632bc2318b5aee8516130edc10d78945d9aeed02.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/gaim-slashexec/Makefile27
-rw-r--r--net-im/gaim-slashexec/distinfo3
-rw-r--r--net-im/gaim-slashexec/files/patch-slashexec.c22
-rw-r--r--net-im/gaim-slashexec/pkg-descr6
5 files changed, 59 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 3426bc1e77a1..a4e4b39cda99 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -27,6 +27,7 @@
SUBDIR += gaim-latex
SUBDIR += gaim-openq
SUBDIR += gaim-rss-reader
+ SUBDIR += gaim-slashexec
SUBDIR += gajim
SUBDIR += gale
SUBDIR += gicq
diff --git a/net-im/gaim-slashexec/Makefile b/net-im/gaim-slashexec/Makefile
new file mode 100644
index 000000000000..c58b4a8bb145
--- /dev/null
+++ b/net-im/gaim-slashexec/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gaim-slashexec
+# Date created: 30 December 2005
+# Whom: kevinb
+#
+# $FreeBSD$
+#
+
+PORTNAME= slashexec
+PORTVERSION= 1.0
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= guifications
+PKGNAMEPREFIX= gaim-
+
+MAINTAINER= kruptos@mlinux.org
+COMMENT= Execute commands inside gaim
+
+BUILD_DEPENDS= gaim:${PORTSDIR}/net-im/gaim
+RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim
+
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= libtool:15
+USE_REINPLACE= yes
+
+PLIST_FILES= lib/gaim/se.so
+
+.include <bsd.port.mk>
diff --git a/net-im/gaim-slashexec/distinfo b/net-im/gaim-slashexec/distinfo
new file mode 100644
index 000000000000..5057ea0bbdd3
--- /dev/null
+++ b/net-im/gaim-slashexec/distinfo
@@ -0,0 +1,3 @@
+MD5 (slashexec-1.0.tar.gz) = ac3c02ffbe14917a79ac6c450a1efb31
+SHA256 (slashexec-1.0.tar.gz) = dde8eac693f0d8b289b5beca5c318743e6af53a6dc9b2fd359a1b0cd348a446d
+SIZE (slashexec-1.0.tar.gz) = 314673
diff --git a/net-im/gaim-slashexec/files/patch-slashexec.c b/net-im/gaim-slashexec/files/patch-slashexec.c
new file mode 100644
index 000000000000..82a9ac2db336
--- /dev/null
+++ b/net-im/gaim-slashexec/files/patch-slashexec.c
@@ -0,0 +1,22 @@
+--- src/slashexec.c.orig Tue Aug 2 08:52:03 2005
++++ src/slashexec.c Tue Jan 3 15:52:55 2006
+@@ -55,6 +55,9 @@
+ gchar buffer[MAX_COMMAND_LEN], **argv;
+ GError *error;
+ gint argc;
++ gchar *standard_output = NULL, *standard_error = NULL;
++ GSpawnFlags Gflags;
++ Gflags = G_SPAWN_SEARCH_PATH;
+ error = NULL;
+ /* TODO: need to properly escape cmd at some stage*/
+ gaim_debug_info("slashexec", "Executing: %s\n", cmd);
+@@ -70,9 +73,6 @@
+ g_strfreev(argv);
+ return NULL;
+ }
+- gchar *standard_output = NULL, *standard_error = NULL;
+- GSpawnFlags Gflags;
+- Gflags = G_SPAWN_SEARCH_PATH;
+ if (!g_spawn_sync (NULL, argv, NULL, Gflags,
+ NULL, NULL, &standard_output, &standard_error, NULL, &error)) {
+ if (buffer)
diff --git a/net-im/gaim-slashexec/pkg-descr b/net-im/gaim-slashexec/pkg-descr
new file mode 100644
index 000000000000..cb15a782d576
--- /dev/null
+++ b/net-im/gaim-slashexec/pkg-descr
@@ -0,0 +1,6 @@
+SlashExec is a Gaim Plugin that lets you execute commands from within a
+Gaim conversation. SlashExec provides a limited command-line interpreter
+for this purpose. SlashExec can also either display the command's output
+locally or send the output as a message in the current conversation.
+
+WWW: http://guifications.sourceforge.net/SlashExec/