aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-30 18:43:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-30 18:43:42 +0000
commit8a4e0b56f92982cd26bd6bf3ab7b42c397185adf (patch)
treedfb7f358850213cb44f804f13ef1789e2b9819a6 /net-im
parent6d17be123725faf32838dd2a890a8be4041ef3d6 (diff)
downloadports-8a4e0b56f92982cd26bd6bf3ab7b42c397185adf.tar.gz
ports-8a4e0b56f92982cd26bd6bf3ab7b42c397185adf.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/pidgin-rhythmbox/Makefile34
-rw-r--r--net-im/pidgin-rhythmbox/distinfo3
-rw-r--r--net-im/pidgin-rhythmbox/files/patch-src__pidgin-rhythmbox.c11
-rw-r--r--net-im/pidgin-rhythmbox/pkg-descr7
5 files changed, 56 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 6ddd8e9ff10c..a565169fffd5 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -99,6 +99,7 @@
SUBDIR += pidgin
SUBDIR += pidgin-guifications
SUBDIR += pidgin-hotkeys
+ SUBDIR += pidgin-rhythmbox
SUBDIR += pork
SUBDIR += py-msnp
SUBDIR += py-pyxmpp
diff --git a/net-im/pidgin-rhythmbox/Makefile b/net-im/pidgin-rhythmbox/Makefile
new file mode 100644
index 000000000000..0114e3aabc51
--- /dev/null
+++ b/net-im/pidgin-rhythmbox/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pidgin-rhythmbox
+# Date created: 2007-06-28
+# Whom: Yuri Pankov <yuri@darklight.org.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pidgin-rhythmbox
+PORTVERSION= 2.0
+CATEGORIES= net-im audio
+MASTER_SITES= http://jon.oberheide.org/projects/pidgin-rhythmbox/downloads/
+
+MAINTAINER= yuri@darklight.org.ru
+COMMENT= Plugin to update your status with info from Rhythmbox
+
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
+ rhythmbox:${PORTSDIR}/audio/rhythmbox
+
+USE_XLIB= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/pidgin/pidgin-rhythmbox.la \
+ lib/pidgin/pidgin-rhythmbox.so
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's#\([@(]\)PIDGIN_INSTALL\([@)]\)#\1libdir\2/pidgin#' \
+ -e 's#-g -g3 -O2##'
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-rhythmbox/distinfo b/net-im/pidgin-rhythmbox/distinfo
new file mode 100644
index 000000000000..b95f5d47d4c7
--- /dev/null
+++ b/net-im/pidgin-rhythmbox/distinfo
@@ -0,0 +1,3 @@
+MD5 (pidgin-rhythmbox-2.0.tar.gz) = d4c7329b6dc8311dfd7d75299537c68e
+SHA256 (pidgin-rhythmbox-2.0.tar.gz) = 9fc4b43d8a353e2c4e7e219b34ae5fb23a3a0dd10b10446c4e75acab9bc5d460
+SIZE (pidgin-rhythmbox-2.0.tar.gz) = 320758
diff --git a/net-im/pidgin-rhythmbox/files/patch-src__pidgin-rhythmbox.c b/net-im/pidgin-rhythmbox/files/patch-src__pidgin-rhythmbox.c
new file mode 100644
index 000000000000..4a059deca49a
--- /dev/null
+++ b/net-im/pidgin-rhythmbox/files/patch-src__pidgin-rhythmbox.c
@@ -0,0 +1,11 @@
+--- ./src/pidgin-rhythmbox.c.orig 2007-06-28 14:14:13.000000000 +0400
++++ ./src/pidgin-rhythmbox.c 2007-06-28 14:14:22.000000000 +0400
+@@ -26,7 +26,7 @@
+ #include <string.h>
+ #include <glib.h>
+ #include <dbus/dbus.h>
+-#include <dbus/dbus-glib.h>
++#include <dbus/dbus-glib-lowlevel.h>
+
+ #include "gtkplugin.h"
+ #include "util.h"
diff --git a/net-im/pidgin-rhythmbox/pkg-descr b/net-im/pidgin-rhythmbox/pkg-descr
new file mode 100644
index 000000000000..5cfe744fe340
--- /dev/null
+++ b/net-im/pidgin-rhythmbox/pkg-descr
@@ -0,0 +1,7 @@
+The Pidgin-Rhythmbox plugin will automatically update your Pidgin user info and
+status message with the currently playing music in Rhythmbox. If the artist and
+title are known, it will also attempt to create a link to the song's lyrics by
+using Google's "I'm Feeling Lucky" feature.
+
+Author: Jon Oberheide
+WWW: http://jon.oberheide.org/projects/pidgin-rhythmbox/