aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /net-im
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/Makefile2
-rw-r--r--net-im/ring-gnome/Makefile2
-rw-r--r--net-im/ring-libclient/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index f7d626d0e406..bb5c814bd7a2 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
BROKEN_sparc64= Does not build: fails to link
-USES= cmake iconv ssl
+USES= cmake:noninja iconv ssl
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
diff --git a/net-im/ring-gnome/Makefile b/net-im/ring-gnome/Makefile
index b7d310cb60ed..e8fbc8cf6151 100644
--- a/net-im/ring-gnome/Makefile
+++ b/net-im/ring-gnome/Makefile
@@ -30,7 +30,7 @@ GH_TUPLE+= savoirfairelinux:ring-client-gnome:07107e9
SUB_FILES= pkg-message
-USES= cmake compiler:c++14-lang gettext gmake pkgconfig shebangfix sqlite
+USES= cmake compiler:c++14-lang gettext pkgconfig shebangfix sqlite
USE_GNOME= evolutiondataserver3 glib20 gtk20 cairo gdkpixbuf2 libxml2 gtk30
USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr xscrnsaver
USE_GL= gl egl
diff --git a/net-im/ring-libclient/Makefile b/net-im/ring-libclient/Makefile
index 8f804e0a25aa..f22b2cf0de7f 100644
--- a/net-im/ring-libclient/Makefile
+++ b/net-im/ring-libclient/Makefile
@@ -18,7 +18,7 @@ USE_GITHUB= yes
#GH_TUPLE+= savoirfairelinux:ring-lrc:9eaac77
GH_TUPLE+= savoirfairelinux:ring-lrc:cb5ee04
-USES= cmake compiler:c++14-lang gmake
+USES= cmake compiler:c++14-lang
USE_GNOME= glib20 gtk20 cairo gdkpixbuf2
USE_XORG= x11 xscrnsaver
USE_GL= gl