aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-06-13 19:15:43 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-06-13 19:15:43 +0000
commite8dc91f679da842ff09eea7c11d2fb58d2ef2262 (patch)
treeaed17db67411c44a341ad3bfcca99783e1db1708 /net-im
parentac8dc2c5987683096e4f858b5c985fd63e11d053 (diff)
downloadports-e8dc91f679da842ff09eea7c11d2fb58d2ef2262.tar.gz
ports-e8dc91f679da842ff09eea7c11d2fb58d2ef2262.zip
Linux version of the official desktop client for Telegram, a cloud-based
messenger with a focus on security and speed. WWW: https://desktop.telegram.org/ PR: 217019 (modified) Submitted by: Henry Hu
Notes
Notes: svn path=/head/; revision=443529
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/linux-telegram-desktop/Makefile41
-rw-r--r--net-im/linux-telegram-desktop/distinfo3
-rw-r--r--net-im/linux-telegram-desktop/files/telegram-desktop.sh.in4
-rw-r--r--net-im/linux-telegram-desktop/pkg-descr12
5 files changed, 61 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 4ffc7d48eb59..25a608eb652c 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -72,6 +72,7 @@
SUBDIR += licq-msn
SUBDIR += licq-osd
SUBDIR += licq-qt-gui
+ SUBDIR += linux-telegram-desktop
SUBDIR += loudmouth
SUBDIR += mastodon
SUBDIR += mbpurple
diff --git a/net-im/linux-telegram-desktop/Makefile b/net-im/linux-telegram-desktop/Makefile
new file mode 100644
index 000000000000..ae00110850ad
--- /dev/null
+++ b/net-im/linux-telegram-desktop/Makefile
@@ -0,0 +1,41 @@
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
+# $FreeBSD$
+
+PORTNAME= telegram-desktop
+PORTVERSION= 1.1.7
+CATEGORIES= net-im linux
+MASTER_SITES= https://updates.tdesktop.com/tlinux32/ \
+ http://freebsd.nsu.ru/distfiles/
+PKGNAMEPREFIX= linux-
+DISTNAME= tsetup32.${PORTVERSION}
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Official desktop client for Telegram messenger (Linux version)
+
+LICENSE= GPLv3
+
+USES= linux:c7 tar:xz
+USE_LINUX= alsalib alsa-plugins-oss dbuslibs dri expat gtk2 xorglibs
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/Telegram
+TDESKTOPDIR= lib/telegram-desktop
+SUB_FILES= telegram-desktop.sh
+SUB_LIST= TDESKTOPDIR=${TDESKTOPDIR}
+
+DESKTOP_ENTRIES= "Telegram Desktop" "${COMMENT}" "" \
+ "${PREFIX}/bin/telegram-desktop -- %u" \
+ "Network;InstantMessaging;" false
+
+PLIST_FILES= bin/telegram-desktop ${TDESKTOPDIR}/Telegram
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${TDESKTOPDIR}
+# The main program binary
+ ${INSTALL_PROGRAM} ${WRKSRC}/Telegram \
+ ${STAGEDIR}${PREFIX}/${TDESKTOPDIR}
+# Wrapper for the main program
+ ${INSTALL_SCRIPT} ${WRKDIR}/telegram-desktop.sh \
+ ${STAGEDIR}${PREFIX}/bin/telegram-desktop
+
+.include <bsd.port.mk>
diff --git a/net-im/linux-telegram-desktop/distinfo b/net-im/linux-telegram-desktop/distinfo
new file mode 100644
index 000000000000..2184fb0ccb68
--- /dev/null
+++ b/net-im/linux-telegram-desktop/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496182037
+SHA256 (tsetup32.1.1.7.tar.xz) = 49db49c089efa680e8ce68ee7153e7a3f601e485a1305857f5cf1b13a5e7e5b0
+SIZE (tsetup32.1.1.7.tar.xz) = 30618984
diff --git a/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in b/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in
new file mode 100644
index 000000000000..1bbc4d442490
--- /dev/null
+++ b/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+export QT_XKB_CONFIG_ROOT=%%PREFIX%%/share/X11/xkb
+exec %%PREFIX%%/%%TDESKTOPDIR%%/Telegram "$@"
diff --git a/net-im/linux-telegram-desktop/pkg-descr b/net-im/linux-telegram-desktop/pkg-descr
new file mode 100644
index 000000000000..bddb17261aa3
--- /dev/null
+++ b/net-im/linux-telegram-desktop/pkg-descr
@@ -0,0 +1,12 @@
+This port provides Linux version of the official Telegram desktop client.
+
+Telegram is a messaging application with a focus on speed and security;
+it is super-fast, simple, and free. You can use Telegram on all your
+devices at the same time -- your messages synchronize seamlessly across
+any number of your phones, tablets, or computers.
+
+With Telegram, you can send messages, photos, videos, and files of any
+type, as well as create groups for up to 1000 people or channels for
+broadcasting to unlimited audiences.
+
+WWW: https://desktop.telegram.org/