aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-11-21 10:57:18 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-11-21 10:57:18 +0000
commit8306540db82f92b18171758da40373c8ad052850 (patch)
tree5ad723636ad2cc9347502e96df07a470e40cf450 /net-im
parent5a3690e6b2f2d4865fd81ed1b02f009a98dda06a (diff)
downloadports-8306540db82f92b18171758da40373c8ad052850.tar.gz
ports-8306540db82f92b18171758da40373c8ad052850.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qTox/Makefile5
-rw-r--r--net-im/qTox/distinfo4
-rw-r--r--net-im/qTox/files/patch-src_main.cpp4
-rw-r--r--net-im/qTox/files/patch-src_platform_camera_v4l2.cpp10
-rw-r--r--net-im/qTox/files/patch-src_platform_camera_v4l2.h2
-rw-r--r--net-im/qTox/files/patch-src_video_cameradevice.cpp65
6 files changed, 72 insertions, 18 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index a3f4bfde59a1..8b588f630f22 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 0.150614
-PORTREVISION= 2
+PORTVERSION= 0.151116
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@rawbw.com
@@ -23,7 +22,7 @@ LIB_DEPENDS= libtoxcore.so:${PORTSDIR}/net-im/tox \
USE_GITHUB= yes
GH_ACCOUNT= tux3
-GH_TAGNAME= ce2c830
+GH_TAGNAME= db52ef6
USES= compiler:c++11-lib desktop-file-utils openal:soft qmake gmake
USE_GNOME= glib20 gtk20 cairo gdkpixbuf2
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index 982e5487b94e..871da3d0d740 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tux3-qTox-0.150614-ce2c830_GH0.tar.gz) = c59580b98886acf9ec5acb1a85b7f6544d53bc2d72491dddeb8865b4d64dd3f6
-SIZE (tux3-qTox-0.150614-ce2c830_GH0.tar.gz) = 4556369
+SHA256 (tux3-qTox-0.151116-db52ef6_GH0.tar.gz) = 3920a71131666bef8044c7428e56e75ac9136b22b9e7d51d2c506da24e34ff91
+SIZE (tux3-qTox-0.151116-db52ef6_GH0.tar.gz) = 4627473
diff --git a/net-im/qTox/files/patch-src_main.cpp b/net-im/qTox/files/patch-src_main.cpp
index fce8ccc494eb..83ba303deb38 100644
--- a/net-im/qTox/files/patch-src_main.cpp
+++ b/net-im/qTox/files/patch-src_main.cpp
@@ -1,6 +1,6 @@
---- src/main.cpp.orig 2015-06-12 10:53:59 UTC
+--- src/main.cpp.orig 2015-11-14 22:51:30 UTC
+++ src/main.cpp
-@@ -280,3 +280,10 @@ int main(int argc, char *argv[])
+@@ -269,3 +269,10 @@ int main(int argc, char *argv[])
qDebug() << "Clean exit with status"<<errorcode;
return errorcode;
}
diff --git a/net-im/qTox/files/patch-src_platform_camera_v4l2.cpp b/net-im/qTox/files/patch-src_platform_camera_v4l2.cpp
deleted file mode 100644
index 8d94e9c04ff4..000000000000
--- a/net-im/qTox/files/patch-src_platform_camera_v4l2.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/platform/camera/v4l2.cpp.orig 2015-06-15 03:25:21 UTC
-+++ src/platform/camera/v4l2.cpp
-@@ -26,6 +26,7 @@
- #include <fcntl.h>
- #include <sys/ioctl.h>
- #include <linux/videodev2.h>
-+#include <errno.h>
-
- /**
- * Most of this file is adapted from libavdevice's v4l2.c,
diff --git a/net-im/qTox/files/patch-src_platform_camera_v4l2.h b/net-im/qTox/files/patch-src_platform_camera_v4l2.h
index f8ba4ab59af3..94c7968c76dd 100644
--- a/net-im/qTox/files/patch-src_platform_camera_v4l2.h
+++ b/net-im/qTox/files/patch-src_platform_camera_v4l2.h
@@ -1,4 +1,4 @@
---- src/platform/camera/v4l2.h.orig 2015-06-12 10:53:59 UTC
+--- src/platform/camera/v4l2.h.orig 2015-11-14 22:51:30 UTC
+++ src/platform/camera/v4l2.h
@@ -24,7 +24,7 @@
#include <QPair>
diff --git a/net-im/qTox/files/patch-src_video_cameradevice.cpp b/net-im/qTox/files/patch-src_video_cameradevice.cpp
new file mode 100644
index 000000000000..88a28521c434
--- /dev/null
+++ b/net-im/qTox/files/patch-src_video_cameradevice.cpp
@@ -0,0 +1,65 @@
+--- src/video/cameradevice.cpp.orig 2015-11-15 08:11:58 UTC
++++ src/video/cameradevice.cpp
+@@ -31,7 +31,7 @@ extern "C" {
+ #ifdef Q_OS_WIN
+ #include "src/platform/camera/directshow.h"
+ #endif
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ #include "src/platform/camera/v4l2.h"
+ #endif
+
+@@ -105,7 +105,7 @@ CameraDevice* CameraDevice::open(QString
+
+ AVDictionary* options = nullptr;
+ if (!iformat);
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ else if (devName.startsWith("x11grab#"))
+ {
+ QSize screen;
+@@ -142,7 +142,7 @@ CameraDevice* CameraDevice::open(QString
+ av_dict_set(&options, "framerate", QString().setNum(mode.FPS).toStdString().c_str(), 0);
+ }
+ #endif
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ else if (iformat->name == QString("video4linux2,v4l2") && mode)
+ {
+ av_dict_set(&options, "video_size", QString("%1x%2").arg(mode.width).arg(mode.height).toStdString().c_str(), 0);
+@@ -264,7 +264,7 @@ QVector<QPair<QString, QString>> CameraD
+ else if (iformat->name == QString("dshow"))
+ devices += DirectShow::getDeviceList();
+ #endif
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ else if (iformat->name == QString("video4linux2,v4l2"))
+ devices += v4l2::getDeviceList();
+ #endif
+@@ -307,7 +307,7 @@ QVector<VideoMode> CameraDevice::getVide
+ else if (iformat->name == QString("dshow"))
+ return DirectShow::getDeviceModes(devName);
+ #endif
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ else if (iformat->name == QString("video4linux2,v4l2"))
+ return v4l2::getDeviceModes(devName);
+ #endif
+@@ -327,7 +327,7 @@ bool CameraDevice::getDefaultInputFormat
+ avdevice_register_all();
+
+ // Desktop capture input formats
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ idesktopFormat = av_find_input_format("x11grab");
+ #endif
+ #ifdef Q_OS_WIN
+@@ -335,7 +335,7 @@ bool CameraDevice::getDefaultInputFormat
+ #endif
+
+ // Webcam input formats
+-#ifdef Q_OS_LINUX
++#ifdef Q_OS_UNIX
+ if ((iformat = av_find_input_format("v4l2")))
+ return true;
+ #endif