aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-07 03:06:05 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-07 03:06:05 +0000
commitd348b46e8daa4173060af53438532db8a2e79688 (patch)
treea17ff505acbb5bc5326970455705406fcdf9db75 /net-im
parent165d12a15c2320fb87dccd898f757e73ee955474 (diff)
downloadports-d348b46e8daa4173060af53438532db8a2e79688.tar.gz
ports-d348b46e8daa4173060af53438532db8a2e79688.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile4
-rw-r--r--net-im/centericq/files/patch-msnhook.cc20
2 files changed, 16 insertions, 8 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 220f53ec494f..c0aa12a53f23 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,11 +8,11 @@
PORTNAME= centericq
PORTVERSION= 4.9.7
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://konst.org.ua/download/
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= clsung@dragon2.net
COMMENT= A text mode menu- and window-driven IM interface
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
index a99dce40718e..d33decdd28ae 100644
--- a/net-im/centericq/files/patch-msnhook.cc
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -1,6 +1,14 @@
---- src/hooks/msnhook.cc.orig Mon Oct 6 01:01:52 2003
-+++ src/hooks/msnhook.cc Mon Oct 6 01:05:37 2003
-@@ -248,7 +248,8 @@
+--- src/hooks/msnhook.cc.orig Tue Sep 30 19:38:43 2003
++++ src/hooks/msnhook.cc Tue Oct 7 10:20:29 2003
+@@ -33,6 +33,7 @@
+ #include "accountmanager.h"
+ #include "eventmanager.h"
+ #include "imlogger.h"
++#include "utf8conv.h"
+ #include "connwrap.h"
+
+ #include "msn_bittybits.h"
+@@ -248,7 +249,8 @@
}
icqcontact *c = clist.get(ev.getcontact());
@@ -10,7 +18,7 @@
if(c)
if(c->getstatus() != offline || !c->inlist()) {
-@@ -378,11 +379,11 @@
+@@ -378,11 +380,11 @@
void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
string oldnick = c->getnick();
@@ -24,7 +32,7 @@
c->setdispnick(newnick);
face.relaxedupdate();
}
-@@ -602,7 +603,8 @@
+@@ -602,7 +604,8 @@
mhook.checkinlist(ic);
@@ -34,7 +42,7 @@
em.store(immessage(ic, imevent::incoming, text));
}
-@@ -779,5 +781,139 @@
+@@ -779,5 +782,139 @@
log(string("[OUT] ") + buf);
}
}