aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-11-01 11:26:03 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-11-01 11:26:03 +0000
commit000670075ab1a049d83880165161ccb694938d8b (patch)
treea1138282a72b18005b2de0bfb0347eb7f3553c8e /net-im
parentac32af25066762ba7c644c40283cb52b34f4eca9 (diff)
downloadports-000670075ab1a049d83880165161ccb694938d8b.tar.gz
ports-000670075ab1a049d83880165161ccb694938d8b.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skype-devel/Makefile49
-rw-r--r--net-im/skype-devel/distinfo3
-rw-r--r--net-im/skype-devel/pkg-descr5
-rw-r--r--net-im/skype-devel/pkg-plist31
4 files changed, 88 insertions, 0 deletions
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
new file mode 100644
index 000000000000..f16c85dfce30
--- /dev/null
+++ b/net-im/skype-devel/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: skype
+# Date created: Jun 21. 2004
+# Whom: netchild@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= skype
+PORTVERSION= 1.4.0.99
+CATEGORIES= net
+MASTER_SITES= http://download.skype.com/linux/
+PKGNAMESUFFIX= -devel
+DISTNAME= skype_static-${DISTVERSION}
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= P2P VoIP software
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib \
+ ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20
+
+.ifdef WITH_NVIDIA_GL
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+USE_GL= linux
+.endif
+
+BROKEN= alsa sound not working
+USE_BZIP2= yes
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386 amd64
+
+RESTRICTED= Redistribution not allowed
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}
+DATADIR= ${PREFIX}/share/${PKGBASE}
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/skype
+
+do-install:
+ @${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/skype-devel_bin
+ @${ECHO_CMD} -e "#!/bin/sh\n\nSKYPE_RESOURCES_PATH='${DATADIR}' skype-devel_bin \"\$$@\" 2>&1 | ${GREP} -v 'SOUND_MIXER_WRITE_IGAIN failed'" >${PREFIX}/bin/skype-devel
+ @${CHMOD} a+rx ${PREFIX}/bin/skype-devel
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sounds LICENSE README" ${DATADIR}/
+ @${ECHO} "There are known problems with some soundcards in 5.x. This is due to a bug in the kernel. It is fixed in 6.x. Additionally there is some further work in the sound subsystem going on which fixes some related problems. This work will not be available in 6.0-RELEASE. If you experience problems update to the most recent 6.x-RELEASE, if this does not fix your problems ask on multimedia@FreeBSD.org." | fmt
+
+.include <bsd.port.mk>
diff --git a/net-im/skype-devel/distinfo b/net-im/skype-devel/distinfo
new file mode 100644
index 000000000000..e7e83da924f4
--- /dev/null
+++ b/net-im/skype-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (skype_static-1.4.0.99.tar.bz2) = 879418eb6a64cd5ff561465a41bb78ab
+SHA256 (skype_static-1.4.0.99.tar.bz2) = bfa236e74b00222360d8e4a83fac7560e6043d264d29911645bcdea8be5fe14c
+SIZE (skype_static-1.4.0.99.tar.bz2) = 17543204
diff --git a/net-im/skype-devel/pkg-descr b/net-im/skype-devel/pkg-descr
new file mode 100644
index 000000000000..5d92fde2ea4f
--- /dev/null
+++ b/net-im/skype-devel/pkg-descr
@@ -0,0 +1,5 @@
+Skype is a free program that uses the latest P2P technology to bring
+affordable and high-quality voice communications to people all over
+the world.
+
+WWW: http://www.skype.net/
diff --git a/net-im/skype-devel/pkg-plist b/net-im/skype-devel/pkg-plist
new file mode 100644
index 000000000000..350acf4c74de
--- /dev/null
+++ b/net-im/skype-devel/pkg-plist
@@ -0,0 +1,31 @@
+bin/skype-devel
+bin/skype-devel_bin
+%%DATADIR%%/LICENSE
+%%DATADIR%%/README
+%%DATADIR%%/icons/SkypeBlue_16x16.png
+%%DATADIR%%/icons/SkypeBlue_32x32.png
+%%DATADIR%%/icons/SkypeBlue_48x48.png
+%%DATADIR%%/sounds/CallBusy.wav
+%%DATADIR%%/sounds/CallConnecting.wav
+%%DATADIR%%/sounds/CallHangup.wav
+%%DATADIR%%/sounds/CallHold.wav
+%%DATADIR%%/sounds/CallRemoteHangup.wav
+%%DATADIR%%/sounds/CallResume.wav
+%%DATADIR%%/sounds/CallRingingIn.wav
+%%DATADIR%%/sounds/CallRingingOut.wav
+%%DATADIR%%/sounds/ChatIncoming.wav
+%%DATADIR%%/sounds/ChatIncomingInitial.wav
+%%DATADIR%%/sounds/ChatOutgoing.wav
+%%DATADIR%%/sounds/ContactAdded.wav
+%%DATADIR%%/sounds/ContactAuthRequest.wav
+%%DATADIR%%/sounds/ContactOffline.wav
+%%DATADIR%%/sounds/ContactOnline.wav
+%%DATADIR%%/sounds/SkypeLogin.wav
+%%DATADIR%%/sounds/SkypeLogout.wav
+%%DATADIR%%/sounds/TransferComplete.wav
+%%DATADIR%%/sounds/TransferFailed.wav
+%%DATADIR%%/sounds/TransferRequest.wav
+%%DATADIR%%/sounds/VoicemailReceived.wav
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%