aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-08-17 15:50:19 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-08-17 15:50:19 +0000
commit7d6be0d7efc219e9a0c5398cccfcc2fa3f6a3395 (patch)
tree9eb2621a318da9f557b1b0c59b70dd7ff9622150 /net-im
parentdcfc3ebc2a4004b39ea6317ed1ea12a63e2468d3 (diff)
downloadports-7d6be0d7efc219e9a0c5398cccfcc2fa3f6a3395.tar.gz
ports-7d6be0d7efc219e9a0c5398cccfcc2fa3f6a3395.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber-pyicq/Makefile19
-rw-r--r--net-im/jabber-pyicq/files/patch-src_main.py16
2 files changed, 13 insertions, 22 deletions
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index 9b4a248dd319..bc307879aaec 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pyicq
PORTVERSION= 0.7b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= http://www.blathersource.org/download.php/pyicq-t/
PKGNAMEPREFIX= jabber-
@@ -18,10 +18,10 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Python ICQ-Transport for Jabber
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl \
- ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-OPTIONS= EJABBERD "Use transport with ejabberd" off
+OPTIONS= EJABBERD "Use transport with ejabberd" off \
+ TWISTED1 "Use old py-twisted 1.x" off
NO_BUILD= yes
USE_PYTHON= yes
@@ -45,17 +45,24 @@ JABBER_USER?= jabber
SUB_LIST+= JABBER_REQUIRE=jabberd
.endif
+.if defined(WITH_TWISTED1)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted
+.else
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twistedCore \
+ ${PYTHON_SITELIBDIR}/twisted/web/__init__.py:${PORTSDIR}/www/py-twistedWeb \
+ ${PYTHON_SITELIBDIR}/twisted/words/__init__.py:${PORTSDIR}/net-im/py-twistedWords
+.endif
+
SUB_LIST+= JABBER_USER=${JABBER_USER}
post-patch:
- @${REINPLACE_CMD} -e '/spooldir/s|\.|/var/spool/jabber|' \
+ @${REINPLACE_CMD} -i "" -e '/spooldir/s|\.|/var/spool/jabber|' \
-e '/pid/s|PyICQt.pid|/var/jabberd/pid/PyICQt.pid|' \
${WRKSRC}/config_example.xml
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g; s|%%PYTHON_CMD%%|${LOCAL_PYTHON}|g' \
+ @${REINPLACE_CMD} -i "" -e 's,"config.xml","${PREFIX}/etc/jabber-pyicq.xml",' \
${WRKSRC}/src/main.py
@${REINPLACE_CMD} -i "" 's|^#!.*$$|#!${LOCAL_PYTHON}|' \
${WRKSRC}/PyICQt.py
- @${RM} ${WRKSRC}/src/main.py.*
do-install:
${MKDIR} ${INST_DIR}/src ${INST_DIR}/data
diff --git a/net-im/jabber-pyicq/files/patch-src_main.py b/net-im/jabber-pyicq/files/patch-src_main.py
deleted file mode 100644
index 485bc7d15308..000000000000
--- a/net-im/jabber-pyicq/files/patch-src_main.py
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/main.py.orig Mon Mar 6 21:58:50 2006
-+++ src/main.py Mon Mar 20 13:34:50 2006
-@@ -1,3 +1,4 @@
-+#!%%PYTHON_CMD%%
- # Copyrigh 2004-2006 Daniel Henninger <jadestorm@nc.rr.com>
- # Licensed for distribution under the GPL version 2, check COPYING for details
-
-@@ -25,7 +26,7 @@
-
- import config
- import xmlconfig
--conffile = "config.xml"
-+conffile = "%%PREFIX%%/etc/jabber-pyicq.xml"
- profilelog = None
- options = {}
- daemonizeme = False