aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-27 13:14:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-27 13:14:16 +0000
commit7e0f6ddec51ba21d5e446324f4a1cbd7e8d320a1 (patch)
treeebada9de741a4614417df30aed8ebe6c030513ed /net-im
parent80b83b4e258947b133315f5f507412ff49130c02 (diff)
downloadports-7e0f6ddec51ba21d5e446324f4a1cbd7e8d320a1.tar.gz
ports-7e0f6ddec51ba21d5e446324f4a1cbd7e8d320a1.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber-conference/Makefile37
-rw-r--r--net-im/jabber-conference/files/README.jabberd14.in (renamed from net-im/jabber-conference/pkg-message)36
-rw-r--r--net-im/jabber-conference/files/patch-Makefile10
-rw-r--r--net-im/jabber-conference/files/patch-aa12
-rw-r--r--net-im/jabber-conference/files/pkg-message.in2
-rw-r--r--net-im/jabber-conference/pkg-plist3
6 files changed, 67 insertions, 33 deletions
diff --git a/net-im/jabber-conference/Makefile b/net-im/jabber-conference/Makefile
index e6777192b0c4..3008b6489070 100644
--- a/net-im/jabber-conference/Makefile
+++ b/net-im/jabber-conference/Makefile
@@ -6,29 +6,46 @@
PORTNAME= conference
PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= http://freebsd.unixfreunde.de/sources/
PKGNAMEPREFIX= jabber-
DIST_SUBDIR= jabber
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= martin@matuska.org
COMMENT= Jabber Conferencing module
-BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net-im/jabber
+LIB_DEPENDS= jabberd.1:${PORTSDIR}/net-im/jabber
-PLIST_FILES= lib/jabber/conference.so
USE_GMAKE= yes
-CONFIGURE_ARGS+= --with-jabberd=${PREFIX}/include/jabber
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/jabber \
+ -I${LOCALBASE}/include/pth
-post-patch:
- @echo "${PREFIX}" > ${WRKSRC}/.prefix-freebsd
+MAKE_ARGS+= MCFLAGS="-shared" \
+ LDFLAGS="-L${LOCALBASE}/lib/pth -L${LOCALBASE}/lib/jabber"
+
+SUB_FILES+= pkg-message README.jabberd14
+DOCSDIR= ${TARGETDIR}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PKGMESSAGE= ${WRKDIR}/pkg-message
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
do-install:
- ${INSTALL_DATA} ${WRKSRC}/conference.so ${PREFIX}/lib/jabber/
+ ${INSTALL_PROGRAM} ${WRKSRC}/conference.so ${TARGETDIR}/lib/jabber/
post-install:
- @cat pkg-message
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKDIR}/README.jabberd14 ${DOCSDIR}
+ @${CAT} ${PKGMESSAGE}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/jabber-conference/pkg-message b/net-im/jabber-conference/files/README.jabberd14.in
index e69d51816582..61c86b1105b4 100644
--- a/net-im/jabber-conference/pkg-message
+++ b/net-im/jabber-conference/files/README.jabberd14.in
@@ -1,3 +1,9 @@
+The sample configuration file for jabberd14 may be located in:
+%%TARGETDIR%%/etc/jabber.xml.sample
+
+Please make necessary changes to your configuration file which may be:
+%%TARGETDIR%%/etc/jabber.xml
+
NOTE: if you want this service to be accessible from other servers,
change any 'conference.localhost' or 'private.localhost' listed below
to a fully qualified domain name! Please make sure that your directives
@@ -5,11 +11,12 @@ NOTE: if you want this service to be accessible from other servers,
Conference can be configured as a private conferencing server (no browse,
all rooms locked up). Add the following to make a private conferencing
-server (around line 446 in the sample configuration file):
+server (around line 921 in the sample configuration file):
+-------------------------------------------------------------------------------
<service id='private.localhost'>
- <load><conference>${PREFIX}/lib/jabber/conference.so</conference></load>
- <conference xmlns="jabberd:config:conference">
+ <load><conference>%%TARGETDIR%%/lib/jabber/conference.so</conference></load>
+ <conference xmlns="jabber:config:conference">
<private/>
<history>30</history>
<vCard>
@@ -25,20 +32,23 @@ server (around line 446 in the sample configuration file):
</conference>
</service>
+-------------------------------------------------------------------------------
Add this section to the browse area of the jsm service to advertise it
-to your users (around line 246 of the sample config file):
+to your users (around line 382 of the sample config file):
+-------------------------------------------------------------------------------
- <conference type="private" jid="private.localhost" name="Private Conferencing"/>
+ <item category="conference" type="text" jid="private.localhost" name="Private Conferencing"/>
-
-Conference can ALSO be configured as a public chatroom server (add this
-around line 446 in the sample config file):
+-------------------------------------------------------------------------------
+Conference can ALSO be configured as a public chatroom server
+(add this around line 921 in the sample config file):
(NOTE: don't forget to change the secret and note that this is transmitted
in plain text.)
+-------------------------------------------------------------------------------
<service id='conference.localhost'>
- <load><conference>${PREFIX}/lib/jabber/conference.so</conference></load>
+ <load><conference>%%TARGETDIR%%/lib/jabber/conference.so</conference></load>
<conference xmlns="jabber:config:conference">
<public/>
<vCard>
@@ -68,8 +78,12 @@ around line 446 in the sample config file):
</conference>
</service>
-Add this section to the browse area of the jsm service to advertise it
+-------------------------------------------------------------------------------
+Add this section to the browse area of the jsm service to advertise it
to your users (around line 246 of the sample configuration file):
+-------------------------------------------------------------------------------
- <conference type="public" jid="conference.localhost" name="Public Chatrooms"/>
+ <item category="conference" type="text" jid="conference.localhost" name="Public Chatrooms"/>
+-------------------------------------------------------------------------------
+Be sure to restart your server after reconfiguring.
diff --git a/net-im/jabber-conference/files/patch-Makefile b/net-im/jabber-conference/files/patch-Makefile
new file mode 100644
index 000000000000..d30c58ee3a34
--- /dev/null
+++ b/net-im/jabber-conference/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Wed Feb 21 15:43:41 2007
++++ Makefile Wed Feb 21 15:44:15 2007
+@@ -1,7 +1,3 @@
+-include ../platform-settings
+-
+-CFLAGS:=$(CFLAGS) -I../jabberd
+-
+ conference_OBJECTS=conference.o conference_room.o conference_user.o
+
+ all: conference
diff --git a/net-im/jabber-conference/files/patch-aa b/net-im/jabber-conference/files/patch-aa
deleted file mode 100644
index f430df919a23..000000000000
--- a/net-im/jabber-conference/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig Mon Apr 15 00:17:50 2002
-+++ Makefile Mon Apr 15 00:18:33 2002
-@@ -1,6 +1,7 @@
--include ../platform-settings
-+INCDIR= ${PREFIX}/include/jabber
-+include ${INCDIR}/platform-settings
-
--CFLAGS:=$(CFLAGS) -I../jabberd
-+CFLAGS:=$(CFLAGS) -I${INCDIR}
-
- conference_OBJECTS=conference.o conference_room.o conference_user.o
-
diff --git a/net-im/jabber-conference/files/pkg-message.in b/net-im/jabber-conference/files/pkg-message.in
new file mode 100644
index 000000000000..c51d212244f8
--- /dev/null
+++ b/net-im/jabber-conference/files/pkg-message.in
@@ -0,0 +1,2 @@
+You can find a configuration example in:
+%%DOCSDIR%%/README.jabberd14
diff --git a/net-im/jabber-conference/pkg-plist b/net-im/jabber-conference/pkg-plist
new file mode 100644
index 000000000000..09bfdfd18b29
--- /dev/null
+++ b/net-im/jabber-conference/pkg-plist
@@ -0,0 +1,3 @@
+lib/jabber/conference.so
+%%PORTDOCS%%%%DOCSDIR%%/README.jabberd14
+%%PORTDOCS%%@dirrm %%DOCSDIR%%