aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-03-19 18:14:39 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-03-19 18:14:39 +0000
commit841549049f794bd473f83f463665e7b098202105 (patch)
treec1895d7fd1a9be940d93411877820cf4fa77356b /net-im
parent874ff25b8e85bacaee4631b5e23db40e2bc2fc29 (diff)
downloadports-841549049f794bd473f83f463665e7b098202105.tar.gz
ports-841549049f794bd473f83f463665e7b098202105.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/Makefile7
-rw-r--r--net-im/telegram-desktop/distinfo6
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_history_history__inner__widget.cpp6
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_qt__static__plugins.cpp10
4 files changed, 14 insertions, 15 deletions
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index 4c3d01831ffe..41569b3e4be3 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -1,8 +1,10 @@
# $FreeBSD$
PORTNAME= telegram-desktop
-DISTVERSION= 1.9.14
+DISTVERSION= 1.9.21
CATEGORIES= net-im
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
+DISTNAME= tdesktop-${DISTVERSION}-full
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= Telegram Desktop messaging app
@@ -32,9 +34,6 @@ LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
USES= cmake compiler:c++17-lang desktop-file-utils \
gnome pkgconfig python:3.7,build qt:5 ssl xorg
-MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
-DISTNAME= tdesktop-${DISTVERSION}-full
-
GH_ACCOUNT= telegramdesktop
GH_PROJECT= tdesktop
USE_GNOME= glib20
diff --git a/net-im/telegram-desktop/distinfo b/net-im/telegram-desktop/distinfo
index 4174be6d2b4b..2da5282f3bbb 100644
--- a/net-im/telegram-desktop/distinfo
+++ b/net-im/telegram-desktop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583109660
-SHA256 (tdesktop-1.9.14-full.tar.gz) = 864d1d5e810e30368e60d4ea389c644387abbc803b3b5426268efa5016d15a4b
-SIZE (tdesktop-1.9.14-full.tar.gz) = 25324084
+TIMESTAMP = 1584582797
+SHA256 (tdesktop-1.9.21-full.tar.gz) = e1f9b58c1475a5044bc4d7a7ed5f89777e717ea5e6126707105e2c2d3032ffac
+SIZE (tdesktop-1.9.21-full.tar.gz) = 25848026
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_history_history__inner__widget.cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_history_history__inner__widget.cpp
index 5e39985c24f5..8f1a34092277 100644
--- a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_history_history__inner__widget.cpp
+++ b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_history_history__inner__widget.cpp
@@ -1,6 +1,6 @@
---- Telegram/SourceFiles/history/history_inner_widget.cpp.orig 2020-02-18 08:28:06 UTC
+--- Telegram/SourceFiles/history/history_inner_widget.cpp.orig 2020-03-16 18:49:16 UTC
+++ Telegram/SourceFiles/history/history_inner_widget.cpp
-@@ -1403,7 +1403,7 @@ void HistoryInner::mouseActionFinish(
+@@ -1420,7 +1420,7 @@ void HistoryInner::mouseActionFinish(
_widget->noSelectingScroll();
_widget->updateTopBarSelection();
@@ -9,7 +9,7 @@
if (!_selected.empty() && _selected.cbegin()->second != FullSelection) {
const auto [item, selection] = *_selected.cbegin();
if (const auto view = item->mainView()) {
-@@ -1412,7 +1412,7 @@ void HistoryInner::mouseActionFinish(
+@@ -1429,7 +1429,7 @@ void HistoryInner::mouseActionFinish(
QClipboard::Selection);
}
}
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_qt__static__plugins.cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_qt__static__plugins.cpp
index 70e4ff18de6d..ba930533952f 100644
--- a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_qt__static__plugins.cpp
+++ b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_qt__static__plugins.cpp
@@ -1,4 +1,4 @@
---- Telegram/SourceFiles/qt_static_plugins.cpp.orig 2020-02-18 08:28:06 UTC
+--- Telegram/SourceFiles/qt_static_plugins.cpp.orig 2020-03-16 18:49:16 UTC
+++ Telegram/SourceFiles/qt_static_plugins.cpp
@@ -19,7 +19,7 @@ Q_IMPORT_PLUGIN(QWindowsIntegrationPlugin)
#elif defined Q_OS_MAC // Q_OS_WIN
@@ -6,10 +6,10 @@
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
-#elif defined Q_OS_LINUX // Q_OS_WIN | Q_OS_MAC
+#elif defined Q_OS_LINUX || defined Q_OS_FREEBSD // Q_OS_WIN | Q_OS_MAC
- Q_IMPORT_PLUGIN(QXcbIntegrationPlugin)
- Q_IMPORT_PLUGIN(QGenericEnginePlugin)
- Q_IMPORT_PLUGIN(QComposePlatformInputContextPlugin)
-@@ -33,4 +33,4 @@ Q_IMPORT_PLUGIN(QHimePlatformInputContextPlugin)
+ Q_IMPORT_PLUGIN(ShmServerBufferPlugin)
+ Q_IMPORT_PLUGIN(DmaBufServerBufferPlugin)
+ Q_IMPORT_PLUGIN(DrmEglServerBufferPlugin)
+@@ -45,4 +45,4 @@ Q_IMPORT_PLUGIN(QHimePlatformInputContextPlugin)
Q_IMPORT_PLUGIN(NimfInputContextPlugin)
Q_IMPORT_PLUGIN(QXdgDesktopPortalThemePlugin)
#endif // !TDESKTOP_DISABLE_DBUS_INTEGRATION