aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-09-14 12:31:45 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-09-14 12:31:45 +0000
commit13f0ee370b030e59e4d761a4e4319f834e7ae2d7 (patch)
treec0d799a5c8f8778f28acc809ce824baac1f46616 /net-im
parentb6247ca1f12b1e42a65831d0673a6c9fab28b86b (diff)
downloadports-13f0ee370b030e59e4d761a4e4319f834e7ae2d7.tar.gz
ports-13f0ee370b030e59e4d761a4e4319f834e7ae2d7.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/wooztalk/Makefile114
-rw-r--r--net-im/wooztalk/distinfo3
-rw-r--r--net-im/wooztalk/pkg-descr9
-rw-r--r--net-im/wooztalk/pkg-message2
-rw-r--r--net-im/wooztalk/pkg-plist99
6 files changed, 0 insertions, 228 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 1eaf60beea6b..347dbe795d86 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -179,7 +179,6 @@
SUBDIR += vacuum-im
SUBDIR += vicq
SUBDIR += vqcc-gtk
- SUBDIR += wooztalk
SUBDIR += xfce4-messenger-plugin
SUBDIR += ysm
SUBDIR += zephyr
diff --git a/net-im/wooztalk/Makefile b/net-im/wooztalk/Makefile
deleted file mode 100644
index b8b52de51954..000000000000
--- a/net-im/wooztalk/Makefile
+++ /dev/null
@@ -1,114 +0,0 @@
-# New ports collection makefile for: wooztalk
-# Date created: 2008-07-18
-# Whom: David <tech@wooztalk.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= wooztalk
-PORTVERSION= 0.9.9a
-PORTREVISION= 5
-CATEGORIES= net-im
-MASTER_SITES= http://www.wooztalk.com/download/
-DISTNAME= ${PORTNAME}_v${PORTVERSION}-freebsd
-
-MAINTAINER= tech@wooztalk.com
-COMMENT= Meet your World Wide Web neighbors
-
-DEPRECATED= wooztalk website not responding as of 20100731
-EXPIRATION_DATE= 2010-08-31
-
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
- boost_serialization.4:${PORTSDIR}/devel/boost-libs \
- boost_regex.4:${PORTSDIR}/devel/boost-libs \
- boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
- curl.6:${PORTSDIR}/ftp/curl
-
-USE_BZIP2= yes
-NO_BUILD= yes
-USE_WX= 2.8
-WX_UNICODE= yes
-
-OPTIONS= FIREFOX "Firefox extension (required)" On \
- DAILYMOTION "Dailymotion extension" On \
- DEEZER "Deezer extension" On \
- GOOGLEVIDEO "GoogleVideo extension" On \
- IMEEM "Imeem extension" On \
- JIWA "Jiwa extension" On \
- LASTFM "Last.fm extension" On \
- VIMEO "Vimeo extension" On \
- VLC "VLC extension" On \
- YOUTUBE "Youtube extension" On
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_FIREFOX)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/firefoxonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-firefoxonwooztalk
-.endif
-
-.if defined(WITH_DAILYMOTION)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/dailymotiononwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-dailymotiononwooztalk
-.endif
-
-.if defined(WITH_DEEZER)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/deezeronwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-deezeronwooztalk
-.endif
-
-.if defined(WITH_GOOGLEVIDEO)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/googlevideoonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-googlevideoonwooztalk
-.endif
-
-.if defined(WITH_IMEEM)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/imeemonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-imeemonwooztalk
-.endif
-
-.if defined(WITH_JIWA)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/jiwaonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-jiwaonwooztalk
-.endif
-
-.if defined(WITH_LASTFM)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/lastfmonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-lastfmonwooztalk
-.endif
-
-.if defined(WITH_VIMEO)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/vimeoonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-vimeoonwooztalk
-.endif
-
-.if defined(WITH_VLC)
-RUN_DEPENDS+= ${LOCALBASE}/share/vlc/http/wooztalk.html:${PORTSDIR}/multimedia/vlconwooztalk
-.endif
-
-.if defined(WITH_YOUTUBE)
-RUN_DEPENDS+= ${LOCALBASE}/lib/xpi/youtubeonwooztalk@wooztalk.com:${PORTSDIR}/www/xpi-youtubeonwooztalk
-.endif
-
-.if ${OSVERSION} < 700000
-BROKEN= run only on 7.x
-.endif
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not install on sparc64
-.endif
-
-do-install:
- @${MKDIR} ${DATADIR}/img
- @${MKDIR} ${DATADIR}/sounds
- @${MKDIR} ${DATADIR}/resources
- @${MKDIR} ${DATADIR}/resources/en
- @${MKDIR} ${DATADIR}/resources/fr
- @${MKDIR} ${PREFIX}/share/locale/en
- @${MKDIR} ${PREFIX}/share/locale/fr
- @${INSTALL_PROGRAM} ${WRKSRC}/wooztalk ${PREFIX}/bin/wooztalk
- @${INSTALL_DATA} ${WRKSRC}/WoozTalk.ico ${DATADIR}/
- @${INSTALL_DATA} ${WRKSRC}/wooztalk.pem ${DATADIR}/
- @${INSTALL_DATA} ${WRKSRC}/img/*.* ${DATADIR}/img/
- @${INSTALL_DATA} ${WRKSRC}/sounds/*.* ${DATADIR}/sounds/
- @${INSTALL_DATA} ${WRKSRC}/resources/en/wooztalk.po ${PREFIX}/share/locale/en/LC_MESSAGES/wooztalk.po
- @${INSTALL_DATA} ${WRKSRC}/resources/fr/wooztalk.po ${PREFIX}/share/locale/fr/LC_MESSAGES/wooztalk.po
- @${INSTALL_DATA} ${WRKSRC}/resources/en/wooztalk.po ${DATADIR}/resources/en/wooztalk.po
- @${INSTALL_DATA} ${WRKSRC}/resources/fr/wooztalk.po ${DATADIR}/resources/fr/wooztalk.po
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/net-im/wooztalk/distinfo b/net-im/wooztalk/distinfo
deleted file mode 100644
index 5716084e1144..000000000000
--- a/net-im/wooztalk/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (wooztalk_v0.9.9a-freebsd.tar.bz2) = 1de87018c7048fc9eb670d561f1c0793
-SHA256 (wooztalk_v0.9.9a-freebsd.tar.bz2) = a5432a7534ee46443f1243cb44f4eec3d72d8e053e9bda50730129fe7b3b03d2
-SIZE (wooztalk_v0.9.9a-freebsd.tar.bz2) = 1358516
diff --git a/net-im/wooztalk/pkg-descr b/net-im/wooztalk/pkg-descr
deleted file mode 100644
index d8d3fc2b3baf..000000000000
--- a/net-im/wooztalk/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-WoozTalk is a new innovative and free Internet service that let you see and
-chat with anyone else visiting the same website, listening to the same music,
-or watching the same video at the same time as you!
-
-As soon as you install WoozTalk, when you visit one of your favorite websites,
-you will see others net surfers currently connected and you will be able to chat
-with them!
-
-WWW: http://www.wooztalk.com
diff --git a/net-im/wooztalk/pkg-message b/net-im/wooztalk/pkg-message
deleted file mode 100644
index aa7a65ea5dce..000000000000
--- a/net-im/wooztalk/pkg-message
+++ /dev/null
@@ -1,2 +0,0 @@
-
-Please restart firefox and vlc to enable WoozTalk extensions.
diff --git a/net-im/wooztalk/pkg-plist b/net-im/wooztalk/pkg-plist
deleted file mode 100644
index 367821c5dac4..000000000000
--- a/net-im/wooztalk/pkg-plist
+++ /dev/null
@@ -1,99 +0,0 @@
-bin/wooztalk
-%%DATADIR%%/WoozTalk.ico
-%%DATADIR%%/wooztalk.pem
-%%DATADIR%%/img/about.png
-%%DATADIR%%/img/add.png
-%%DATADIR%%/img/all.png
-%%DATADIR%%/img/ampoule.png
-%%DATADIR%%/img/arrow_down.png
-%%DATADIR%%/img/arrow_left.png
-%%DATADIR%%/img/arrow_right.png
-%%DATADIR%%/img/arrow_up.png
-%%DATADIR%%/img/assistant.png
-%%DATADIR%%/img/bell.png
-%%DATADIR%%/img/belldef.png
-%%DATADIR%%/img/blush.png
-%%DATADIR%%/img/chat.png
-%%DATADIR%%/img/chatnotsubscribed.png
-%%DATADIR%%/img/chatsubscribed.png
-%%DATADIR%%/img/check.png
-%%DATADIR%%/img/cheeky.png
-%%DATADIR%%/img/close_event.png
-%%DATADIR%%/img/configURL.png
-%%DATADIR%%/img/confused.png
-%%DATADIR%%/img/cool.png
-%%DATADIR%%/img/crying.png
-%%DATADIR%%/img/defaultavatar.png
-%%DATADIR%%/img/disconnect.png
-%%DATADIR%%/img/emptybell.png
-%%DATADIR%%/img/emptypopup.png
-%%DATADIR%%/img/exit.png
-%%DATADIR%%/img/expand.png
-%%DATADIR%%/img/happy.png
-%%DATADIR%%/img/mars.png
-%%DATADIR%%/img/newmsg.png
-%%DATADIR%%/img/nochat.png
-%%DATADIR%%/img/nogender.png
-%%DATADIR%%/img/plugins_config.png
-%%DATADIR%%/img/popup.png
-%%DATADIR%%/img/popupdef.png
-%%DATADIR%%/img/postit.png
-%%DATADIR%%/img/preferences.png
-%%DATADIR%%/img/question.png
-%%DATADIR%%/img/reconnect.png
-%%DATADIR%%/img/redclose.png
-%%DATADIR%%/img/reduce.png
-%%DATADIR%%/img/roomempty.png
-%%DATADIR%%/img/roomgreen.png
-%%DATADIR%%/img/roomgrey.png
-%%DATADIR%%/img/roomred.png
-%%DATADIR%%/img/sad.png
-%%DATADIR%%/img/sendfile.png
-%%DATADIR%%/img/separator.png
-%%DATADIR%%/img/smallassistant.png
-%%DATADIR%%/img/smallpostit.png
-%%DATADIR%%/img/smileys.png
-%%DATADIR%%/img/star_demi.png
-%%DATADIR%%/img/star_empty.png
-%%DATADIR%%/img/star_full.png
-%%DATADIR%%/img/star_none.png
-%%DATADIR%%/img/target.png
-%%DATADIR%%/img/tb_away.ico
-%%DATADIR%%/img/tb_busy.ico
-%%DATADIR%%/img/tb_disconnected.ico
-%%DATADIR%%/img/tb_message.ico
-%%DATADIR%%/img/tb_noactivity.ico
-%%DATADIR%%/img/tb_offline.ico
-%%DATADIR%%/img/tb_online.ico
-%%DATADIR%%/img/texte.png
-%%DATADIR%%/img/treeclosed.xpm
-%%DATADIR%%/img/treeempty.xpm
-%%DATADIR%%/img/treeopened.xpm
-%%DATADIR%%/img/updownload.png
-%%DATADIR%%/img/user.png
-%%DATADIR%%/img/user_add.png
-%%DATADIR%%/img/users.png
-%%DATADIR%%/img/users2.png
-%%DATADIR%%/img/venus.png
-%%DATADIR%%/img/wait.png
-%%DATADIR%%/img/website.png
-%%DATADIR%%/img/close.png
-%%DATADIR%%/img/wink.png
-%%DATADIR%%/img/wooztalk.png
-%%DATADIR%%/img/woozie.png
-%%DATADIR%%/sounds/message.wav
-%%DATADIR%%/sounds/offline.wav
-%%DATADIR%%/sounds/online.wav
-%%DATADIR%%/resources/fr/wooztalk.po
-%%DATADIR%%/resources/en/wooztalk.po
-share/locale/fr/LC_MESSAGES/wooztalk.po
-share/locale/en/LC_MESSAGES/wooztalk.po
-@dirrm %%DATADIR%%/resources/fr
-@dirrm %%DATADIR%%/resources/en
-@dirrm %%DATADIR%%/resources
-@dirrm %%DATADIR%%/img
-@dirrm %%DATADIR%%/sounds
-@dirrmtry %%DATADIR%%/plugins
-@dirrmtry %%DATADIR%%
-@dirrmtry share/locale/fr
-@dirrmtry share/locale/fr/LC_MESSAGES