aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-02 07:14:54 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-02 07:14:54 +0000
commit18fe7bff1b1820eeb87a84638ec6e5abab42feb1 (patch)
treec83a2f07c4e162cad7d2f8713a2cf635474f9acc /net-im
parent002202f5ae600e68086795892c9b8b30d5389b9e (diff)
downloadports-18fe7bff1b1820eeb87a84638ec6e5abab42feb1.tar.gz
ports-18fe7bff1b1820eeb87a84638ec6e5abab42feb1.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ttytter/Makefile23
-rw-r--r--net-im/ttytter/distinfo6
2 files changed, 19 insertions, 10 deletions
diff --git a/net-im/ttytter/Makefile b/net-im/ttytter/Makefile
index 2406ce0f6506..d543c3d7533a 100644
--- a/net-im/ttytter/Makefile
+++ b/net-im/ttytter/Makefile
@@ -5,15 +5,21 @@
# $FreeBSD$
PORTNAME= ttytter
-PORTVERSION= 2.0.04
+PORTVERSION= 2.1.00
CATEGORIES= net-im perl5
-MASTER_SITES= http://www.floodgap.com/software/ttytter/dist2/
-DISTNAME= ${PORTVERSION}
-EXTRACT_SUFX= .txt
+MASTER_SITES= http://www.floodgap.com/software/ttytter/dist2/:dist \
+ http://www.floodgap.com/software/ffsl/:license
+DISTFILES= ${PORTVERSION}.txt:dist license.txt:license
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= jdunn@aquezada.com
COMMENT= Command-line Twitter client in Perl
+LICENSE= FFSL
+LICENSE_NAME= Floodgap Free Software License
+LICENSE_FILE= ${WRKSRC}/license.txt
+LICENSE_PERMS= auto-accept dist-mirror dist-sell pkg-mirror pkg-sell
+
RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
@@ -34,17 +40,18 @@ RUN_DEPENDS+= p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
.endif
.if ${PORT_OPTIONS:MRLTTYTTER}
-RUN_DEPENDS+= p5-ReadLine-TTYtter>=1.3:${PORTSDIR}/devel/p5-ReadLine-TTYtter
+RUN_DEPENDS+= p5-ReadLine-TTYtter>=1.4:${PORTSDIR}/devel/p5-ReadLine-TTYtter
.endif
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}/${DISTFILES}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${PORTVERSION}.txt ${WRKSRC}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/license.txt ${WRKSRC}
post-patch:
- @${REINPLACE_CMD} -e 's|^\#!/usr/bin/perl|\#!${PERL}|' ${WRKSRC}/${DISTFILES}
+ @${REINPLACE_CMD} -e 's|^\#!/usr/bin/perl|\#!${PERL}|' ${WRKSRC}/${PORTVERSION}.txt
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${DISTFILES} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTVERSION}.txt ${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/net-im/ttytter/distinfo b/net-im/ttytter/distinfo
index 860a37bae196..6b1070815c42 100644
--- a/net-im/ttytter/distinfo
+++ b/net-im/ttytter/distinfo
@@ -1,2 +1,4 @@
-SHA256 (2.0.04.txt) = bb679a2f592bb4034e8b19bdc02f5a4e0909a740930fb3efbb8a7948b0fc0ac5
-SIZE (2.0.04.txt) = 221442
+SHA256 (ttytter/2.1.00.txt) = 6292ada5d238009c74345c48a66e59b3c0e4e084a733715953e408bb18191898
+SIZE (ttytter/2.1.00.txt) = 238284
+SHA256 (ttytter/license.txt) = 42c576fcacb5bd6c8f8e64c479b0f8e4445c7e6c9ac013485c51b8f05f2352fd
+SIZE (ttytter/license.txt) = 14876