aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 04:01:14 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 04:01:14 +0000
commit4177135638cc8d30881ba8226a147cdfbbe0da51 (patch)
treeb3979297b3280768ed1265f3b7b074e93287aa89 /net-im
parent418baa2d2968e5ea339f2904742c79d8d46d345f (diff)
downloadports-4177135638cc8d30881ba8226a147cdfbbe0da51.tar.gz
ports-4177135638cc8d30881ba8226a147cdfbbe0da51.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile2
-rw-r--r--net-im/centericq/files/patch-msnhook.cc6
2 files changed, 6 insertions, 2 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 1eeb9e11c015..d30428bc491e 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,7 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.8.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://konst.org.ua/download/
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
index 12ceb55cf702..1e4940bb8926 100644
--- a/net-im/centericq/files/patch-msnhook.cc
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -39,7 +39,7 @@
em.store(immessage(ic, imevent::incoming, text));
if(c)
-@@ -453,3 +456,117 @@
+@@ -453,3 +456,121 @@
clist.get(contactroot)->playsound(imevent::email);
}
}
@@ -98,6 +98,7 @@
+ iconv_t handle = iconv_open( "utf-8", guess_current_locale_charset() );
+ ret = safe_iconv( handle, (const char **) &inbuf, &length, &outbuf, &outmaxlength );
+
++ *outbuf = '\0';
+ iconv_close( handle );
+
+ return outbuf_save;
@@ -115,6 +116,7 @@
+ iconv_t handle = iconv_open( "utf-8", guess_current_locale_charset() );
+ ret = safe_iconv( handle, (const char **) &inbuf, &length, &outbuf, &outmaxlength );
+
++ *outbuf = '\0';
+ iconv_close( handle );
+
+ std::string return_me = outbuf_save;
@@ -133,6 +135,7 @@
+
+ ret = safe_iconv( handle, (const char **) &inbuf, &length, &outbuf, &outmaxlength );
+
++ *outbuf = '\0';
+ iconv_close( handle );
+
+ return outbuf_save;
@@ -151,6 +154,7 @@
+
+ ret = safe_iconv( handle, (const char **) &inbuf, &length, &outbuf, &outmaxlength );
+
++ *outbuf = '\0';
+ iconv_close( handle );
+
+ std::string return_me = outbuf_save;