aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-02 22:18:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-02 22:18:37 +0000
commit5eca12ed529c03d1d71ee11c539a1e2e62ae58f7 (patch)
tree97c7bff91114b0c22a95642bac8a5d6d776f7182 /net-im
parentd0b7717b641c61c45f43ca1a3850e577e36ac559 (diff)
downloadports-5eca12ed529c03d1d71ee11c539a1e2e62ae58f7.tar.gz
ports-5eca12ed529c03d1d71ee11c539a1e2e62ae58f7.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/Makefile13
-rw-r--r--net-im/qutim/distinfo6
-rw-r--r--net-im/qutim/files/patch-protocol-oscar-icq-contactlist.cpp26
-rw-r--r--net-im/qutim/files/patch-src-qutim.cpp16
4 files changed, 35 insertions, 26 deletions
diff --git a/net-im/qutim/Makefile b/net-im/qutim/Makefile
index 717a3db514d1..95cba6a5982a 100644
--- a/net-im/qutim/Makefile
+++ b/net-im/qutim/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= qutim
-PORTVERSION= 0.1
+PORTVERSION= 0.1.1
CATEGORIES= net-im
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= qutIM-${PORTVERSION}
+MASTER_SITES= http://qutim.org/download/ \
+ http://dl.kibab.com/distfiles/qutim/ \
+ ftp://ftp.inferra.ru/pub/qutIM/
+DISTNAME= qutim_${PORTVERSION}
MAINTAINER= webmaster@kibab.com
COMMENT= A Qt4-based lightweight ICQ client with advanced features
-WRKSRC= ${WRKDIR}/qutIM
-USE_BZIP2= yes
USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui network xml moc_build qmake_build rcc_build uic_build
@@ -27,6 +26,6 @@ pre-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o Makefile qutIM.pro
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/qutIM ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/build/bin/qutIM ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/net-im/qutim/distinfo b/net-im/qutim/distinfo
index 1d046c7e76e4..13929b106436 100644
--- a/net-im/qutim/distinfo
+++ b/net-im/qutim/distinfo
@@ -1,3 +1,3 @@
-MD5 (qutIM-0.1.tar.bz2) = da28697dfba1d345b0cc45e0cc3e7cad
-SHA256 (qutIM-0.1.tar.bz2) = cc67e9c19a0dbf52826550b4f98bdf50d50c905785e0d66e54a28a53d95a66f6
-SIZE (qutIM-0.1.tar.bz2) = 359666
+MD5 (qutim_0.1.1.tar.gz) = 0c43b30c1f428d0557f9d68f6cb4cff2
+SHA256 (qutim_0.1.1.tar.gz) = db62de671d9d6d5462dc2330ba9039cc1db74169eeefad8a2d3bc5609967df3c
+SIZE (qutim_0.1.1.tar.gz) = 805600
diff --git a/net-im/qutim/files/patch-protocol-oscar-icq-contactlist.cpp b/net-im/qutim/files/patch-protocol-oscar-icq-contactlist.cpp
new file mode 100644
index 000000000000..2d01ad9f62b5
--- /dev/null
+++ b/net-im/qutim/files/patch-protocol-oscar-icq-contactlist.cpp
@@ -0,0 +1,26 @@
+--- protocol/oscar/icq/contactlist.cpp.orig 2008-07-22 19:34:21.000000000 +0400
++++ protocol/oscar/icq/contactlist.cpp 2008-07-22 20:14:46.000000000 +0400
+@@ -16,6 +16,7 @@
+ //#include <QtGui>
+ #include <QTcpSocket>
+ #include <QNetworkProxy>
++#include <sys/time.h>
+ #include "treegroupitem.h"
+ #include "treebuddyitem.h"
+ #include "icqmessage.h"
+@@ -1559,8 +1560,14 @@
+ msg->message = codec->toUnicode(socket->read(length - 1));
+
+ QDateTime curTime = QDateTime::currentDateTime();
++
++ // Use POSIX-compatible way to get daylight saving correction
++ struct timeval tp;
++ struct timezone tzp;
++ gettimeofday(&tp, &tzp);
++
+ int offset = (curTime.toLocalTime().time().hour() - curTime.toUTC().time().hour()) * 3600 +
+- (curTime.toLocalTime().time().minute() - curTime.toUTC().time().minute()) * 60 - daylight * 3600;
++ (curTime.toLocalTime().time().minute() - curTime.toUTC().time().minute()) * 60 - tzp.tz_dsttime * 3600;
+ offlineDateTime = offlineDateTime.addSecs(offset);
+
+ msg->date = offlineDateTime;
diff --git a/net-im/qutim/files/patch-src-qutim.cpp b/net-im/qutim/files/patch-src-qutim.cpp
deleted file mode 100644
index c37412795015..000000000000
--- a/net-im/qutim/files/patch-src-qutim.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ur qutIM/src/qutim.cpp qutIM.mine/src/qutim.cpp
---- src/qutim.cpp 2008-06-11 16:11:00.000000000 +0400
-+++ src/qutim.cpp 2008-06-15 21:49:52.000000000 +0400
-@@ -59,10 +59,10 @@
- offlineList = NULL;
- setAttribute(Qt::WA_AlwaysShowToolTips, true);
- setFocus(Qt::ActiveWindowFocusReason);
-+ createActions();
-+ createTrayIcon();
- if ( QSystemTrayIcon::isSystemTrayAvailable() )
- {
-- createActions();
-- createTrayIcon();
- trayIcon->show();
- connect(trayIcon, SIGNAL(activated(QSystemTrayIcon::ActivationReason)),
- this, SLOT(trayActivated(QSystemTrayIcon::ActivationReason)));