aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-07-30 09:39:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-07-30 09:39:44 +0000
commitca18c5b1d871a92954334d7e56906b51e1c2d086 (patch)
tree69ab1e6d1c3aa62d8921d89f1d46c51f48b49f3a /net-im
parent769329177b45b3221adba2ec0ddb4d734343d53e (diff)
downloadports-ca18c5b1d871a92954334d7e56906b51e1c2d086.tar.gz
ports-ca18c5b1d871a92954334d7e56906b51e1c2d086.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/folks/Makefile1
-rw-r--r--net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala109
-rw-r--r--net-im/telepathy-glib/Makefile7
-rw-r--r--net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in22
-rw-r--r--net-im/telepathy-glib/pkg-plist4
5 files changed, 138 insertions, 5 deletions
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
index dc4484a65f19..1083d01f2888 100644
--- a/net-im/folks/Makefile
+++ b/net-im/folks/Makefile
@@ -8,6 +8,7 @@
PORTNAME= folks
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= GNOME
diff --git a/net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala b/net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala
new file mode 100644
index 000000000000..8e8e86cd2da2
--- /dev/null
+++ b/net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala
@@ -0,0 +1,109 @@
+--- backends/telepathy/lib/tpf-persona-store.vala.orig 2011-07-22 14:19:09.000000000 +0200
++++ backends/telepathy/lib/tpf-persona-store.vala 2011-07-22 14:30:40.000000000 +0200
+@@ -22,7 +22,6 @@
+ using GLib;
+ using Gee;
+ using TelepathyGLib;
+-using TelepathyGLib.ContactFeature;
+ using Folks;
+
+ /**
+@@ -36,6 +35,15 @@ public class Tpf.PersonaStore : Folks.Pe
+ {
+ private string[] undisplayed_groups = { "publish", "stored", "subscribe" };
+
++ private static ContactFeature[] _contact_features =
++ {
++ ContactFeature.ALIAS,
++ ContactFeature.AVATAR_DATA,
++ ContactFeature.AVATAR_TOKEN,
++ ContactFeature.CAPABILITIES,
++ ContactFeature.PRESENCE
++ };
++
+ private HashTable<string, Persona> _personas;
+ /* universal, contact owner handles (not channel-specific) */
+ private HashMap<uint, Persona> handle_persona_map;
+@@ -407,7 +415,7 @@ public class Tpf.PersonaStore : Folks.Pe
+ if (change_maps.size < 1)
+ return;
+
+- foreach (var entry in change_maps)
++ foreach (var entry in change_maps.entries)
+ {
+ var changes = entry.key;
+
+@@ -640,7 +648,7 @@ public class Tpf.PersonaStore : Folks.Pe
+ /*
+ * remove all persona-keyed entries
+ */
+- foreach (var entry in this.channel_group_personas_map)
++ foreach (var entry in this.channel_group_personas_map.entries)
+ {
+ var channel = (Channel) entry.key;
+ var members = this.channel_group_personas_map[channel];
+@@ -648,9 +656,8 @@ public class Tpf.PersonaStore : Folks.Pe
+ members.remove (persona);
+ }
+
+- foreach (var entry in this.group_outgoing_adds)
++ foreach (var name in this.group_outgoing_adds.keys)
+ {
+- var name = (string) entry.key;
+ var members = this.group_outgoing_adds[name];
+ if (members != null)
+ members.remove (persona);
+@@ -866,14 +873,6 @@ public class Tpf.PersonaStore : Folks.Pe
+ Channel channel,
+ Array<uint> channel_handles)
+ {
+- ContactFeature[] features =
+- {
+- ALIAS,
+- AVATAR_DATA,
+- AVATAR_TOKEN,
+- PRESENCE
+- };
+-
+ uint[] contact_handles = {};
+ for (var i = 0; i < channel_handles.length; i++)
+ {
+@@ -891,7 +890,7 @@ public class Tpf.PersonaStore : Folks.Pe
+
+ GLib.List<TelepathyGLib.Contact> contacts =
+ yield this.ll.connection_get_contacts_by_handle_async (
+- this.conn, contact_handles, (uint[]) features);
++ this.conn, contact_handles, (uint[]) _contact_features);
+
+ if (contacts == null || contacts.length () < 1)
+ return;
+@@ -918,19 +917,11 @@ public class Tpf.PersonaStore : Folks.Pe
+ private async GLib.List<Tpf.Persona>? create_personas_from_contact_ids (
+ string[] contact_ids) throws GLib.Error
+ {
+- ContactFeature[] features =
+- {
+- ALIAS,
+- AVATAR_DATA,
+- AVATAR_TOKEN,
+- PRESENCE
+- };
+-
+ if (contact_ids.length > 0)
+ {
+ GLib.List<TelepathyGLib.Contact> contacts =
+ yield this.ll.connection_get_contacts_by_id_async (
+- this.conn, contact_ids, (uint[]) features);
++ this.conn, contact_ids, (uint[]) _contact_features);
+
+ GLib.List<Persona> personas = new GLib.List<Persona> ();
+ uint err_count = 0;
+@@ -1027,7 +1018,7 @@ public class Tpf.PersonaStore : Folks.Pe
+
+ private void channel_groups_add_new_personas ()
+ {
+- foreach (var entry in this.channel_group_incoming_adds)
++ foreach (var entry in this.channel_group_incoming_adds.entries)
+ {
+ var channel = (Channel) entry.key;
+ var members_added = new GLib.List<Persona> ();
diff --git a/net-im/telepathy-glib/Makefile b/net-im/telepathy-glib/Makefile
index ff25c75aec3a..7273ab234f2d 100644
--- a/net-im/telepathy-glib/Makefile
+++ b/net-im/telepathy-glib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= telepathy-glib
PORTVERSION= 0.12.7
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
@@ -17,12 +18,12 @@ LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
- vapigen-0.10:${PORTSDIR}/lang/vala-vapigen \
+ vapigen:${PORTSDIR}/lang/vala-vapigen \
g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g} \
- vapigen-0.10:${PORTSDIR}/lang/vala-vapigen
+ vapigen:${PORTSDIR}/lang/vala-vapigen
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
@@ -35,7 +36,7 @@ CONFIGURE_ARGS= --enable-vala-bindings
post-patch:
@${REINPLACE_CMD} -e 's|\(^pkgconfigdir =\).*|\1 ${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/telepathy-glib/Makefile.in
- @${REINPLACE_CMD} -e 's|datarootdir)/vala/vapi|datarootdir)/vala-0.10/vapi|g' \
+ @${REINPLACE_CMD} -e 's|datarootdir)/vala/vapi|datarootdir)/vala-0.12/vapi|g' \
${WRKSRC}/vala/Makefile.in
.include <bsd.port.mk>
diff --git a/net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in b/net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in
new file mode 100644
index 000000000000..d88266770456
--- /dev/null
+++ b/net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in
@@ -0,0 +1,22 @@
+--- telepathy-glib/Makefile.in.orig 2011-07-22 13:41:13.000000000 +0200
++++ telepathy-glib/Makefile.in 2011-07-22 14:00:23.000000000 +0200
+@@ -1649,7 +1649,7 @@
+ @HAVE_INTROSPECTION_TRUE@ $(AM_V_GEN)$(INTROSPECTION_SCANNER) -v \
+ @HAVE_INTROSPECTION_TRUE@ --namespace TelepathyGLib \
+ @HAVE_INTROSPECTION_TRUE@ --nsversion=0.12 \
+-@HAVE_INTROSPECTION_TRUE@ $(gi_identifier_prefix_arg)=Tp \
++@HAVE_INTROSPECTION_TRUE@ --identifier-prefix=Tp \
+ @HAVE_INTROSPECTION_TRUE@ -I$(top_builddir) \
+ @HAVE_INTROSPECTION_TRUE@ -I$(top_srcdir) \
+ @HAVE_INTROSPECTION_TRUE@ --include=GLib-2.0 \
+@@ -1658,7 +1658,9 @@
+ @HAVE_INTROSPECTION_TRUE@ --library=libtelepathy-glib.la \
+ @HAVE_INTROSPECTION_TRUE@ --pkg gio-2.0 \
+ @HAVE_INTROSPECTION_TRUE@ --pkg dbus-glib-1 \
+-@HAVE_INTROSPECTION_TRUE@ $(gi_warn_all_arg) \
++@HAVE_INTROSPECTION_TRUE@ --pkg-export telepathy-glib \
++@HAVE_INTROSPECTION_TRUE@ --c-include="telepathy-glib/telepathy-glib.h" \
++@HAVE_INTROSPECTION_TRUE@ --warn-all \
+ @HAVE_INTROSPECTION_TRUE@ --output _gen/$@.tmp \
+ @HAVE_INTROSPECTION_TRUE@ $(INTROSPECTION_FILES)
+ @HAVE_INTROSPECTION_TRUE@ @xsltproc $(srcdir)/kludge.xsl _gen/$@.tmp > $@
diff --git a/net-im/telepathy-glib/pkg-plist b/net-im/telepathy-glib/pkg-plist
index 6295b7ff9285..457fc925a6f1 100644
--- a/net-im/telepathy-glib/pkg-plist
+++ b/net-im/telepathy-glib/pkg-plist
@@ -236,8 +236,8 @@ share/gtk-doc/html/telepathy-glib/telepathy-glib-util.html
share/gtk-doc/html/telepathy-glib/telepathy-glib.devhelp
share/gtk-doc/html/telepathy-glib/telepathy-glib.devhelp2
share/gtk-doc/html/telepathy-glib/up.png
-share/vala-0.10/vapi/telepathy-glib.deps
-share/vala-0.10/vapi/telepathy-glib.vapi
+share/vala-0.12/vapi/telepathy-glib.deps
+share/vala-0.12/vapi/telepathy-glib.vapi
@dirrm share/gtk-doc/html/telepathy-glib
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc