aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2013-08-14 08:22:59 +0000
committerCarlo Strub <cs@FreeBSD.org>2013-08-14 08:22:59 +0000
commitdb59ea0c3ac10569cae84b2bc7b2b997a4095ce5 (patch)
tree243034a2f699ad1edf47a509ef8c13a8f6c87256 /net-im
parent6c40ef386e05eddcaede2c5ca719cfdcbe95e7c2 (diff)
downloadports-db59ea0c3ac10569cae84b2bc7b2b997a4095ce5.tar.gz
ports-db59ea0c3ac10569cae84b2bc7b2b997a4095ce5.zip
Notes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jitsi/Makefile16
-rw-r--r--net-im/jitsi/distinfo4
-rw-r--r--net-im/jitsi/files/jitsi.160
3 files changed, 71 insertions, 9 deletions
diff --git a/net-im/jitsi/Makefile b/net-im/jitsi/Makefile
index 939133989bcc..22c92ee420ab 100644
--- a/net-im/jitsi/Makefile
+++ b/net-im/jitsi/Makefile
@@ -2,22 +2,20 @@
# $FreeBSD$
PORTNAME= jitsi
-PORTVERSION= 1.1
+PORTVERSION= 2.2
CATEGORIES= net-im java
-MASTER_SITES= https://download.jitsi.org/jitsi/nightly/src/ \
- http://aetos.it.teithe.gr/~tzabal/files/
-DISTNAME= jitsi-src-1.1.4456.10418
+MASTER_SITES= http://www.c-s.li/ports/ \
+ https://download.jitsi.org/jitsi/src/
+DISTNAME= jitsi-src-2.2.4603.9615
MAINTAINER= tzabal@it.teithe.gr
COMMENT= Open source IM and VoIP application
+MAN1= jitsi.1
USE_ZIP= yes
USE_JAVA= yes
USE_ANT= yes
MAKE_ARGS= rebuild
-USE_LDCONFIG= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
DESKTOP_ENTRIES="Jitsi" \
"VoIP and Instant Messenger" \
@@ -65,6 +63,10 @@ do-install:
@${ECHO_CMD} ">> Installing wrapper script..."
@${INSTALL_SCRIPT} ${FILESDIR}/jitsi.sh ${PREFIX}/bin/jitsi
+# Manual page
+ @${ECHO_CMD} ">> Installing the manual page..."
+ @${INSTALL_MAN} ${FILESDIR}/jitsi.1 ${MANPREFIX}/man/man1
+
# Desktop related
@${ECHO_CMD} ">> Installing Jitsi's logo..."
@${INSTALL_DATA} ${WRKSRC}/resources/images/logo/sc_logo_128x128.png \
diff --git a/net-im/jitsi/distinfo b/net-im/jitsi/distinfo
index 6cd3606b2923..0366e53f32fa 100644
--- a/net-im/jitsi/distinfo
+++ b/net-im/jitsi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jitsi-src-1.1.4456.10418.zip) = 07f3ff843ed583f54697892e3311a82f2fa6d15f69b7aa79eb3978be90d65d85
-SIZE (jitsi-src-1.1.4456.10418.zip) = 61050111
+SHA256 (jitsi-src-2.2.4603.9615.zip) = abee87346f2732d1e55f383c1bddafed7aee1e63b92b9d1854cde0679fc85ecf
+SIZE (jitsi-src-2.2.4603.9615.zip) = 64168863
diff --git a/net-im/jitsi/files/jitsi.1 b/net-im/jitsi/files/jitsi.1
new file mode 100644
index 000000000000..084ba27913ef
--- /dev/null
+++ b/net-im/jitsi/files/jitsi.1
@@ -0,0 +1,60 @@
+.Dd August 05, 2013
+.Dt JITSI 1
+.Os
+.Sh NAME
+.Nm jitsi
+.Nd a VoIP, videoconferencing and instant messaging application
+.Sh SYNOPSIS
+.Nm
+.Op Ar options
+.Op Ar uri-to-call
+.Sh DESCRIPTION
+.Nm Jitsi
+is a VoIP, videoconferencing and instant messaging application available in a variety of operating systems. It supports several protocols including SIP and SIMPLE, XMPP and Jingle, MSNP, YMSG, and OSCAR. These protocols are used by major communication services/networks (Google Talk, Facebook Chat, MSN, Yahoo! Messenger, AIM, ICQ). Voice and video calls can be done using SIP and XMPP, file transfers with XMPP, MSNP, YMSG, and OSCAR, and instant messaging with SIP (no multi-user chats), XMPP, MSNP, YMSG, and OSCAR.
+.Pp
+The following options are available:
+.Bl -tag -width indent
+.It Fl c, -config= Ar DIR
+Use the directory
+.Ar DIR
+for the configuration files. The default directory is
+.Pa $HOME/.jitsi
+.It Fl d, -debug
+Print debugging messages to stdout.
+.It Fl h, -help
+Print the current version, the list of available options, and exit.
+.It Fl m, -multiple
+Allow more than one instance launch.
+.It Fl 6, -ipv6
+Force use of IPv6 addresses where possible.
+.It Fl 4, -ipv4
+Force use of IPv4 addresses only.
+.It Fl v, -version
+Print the current version and exit.
+.El
+.Pp
+The optional
+.Ar uri-to-call
+parameter can be specified to start a call from the command-line. If Jitsi is already running then the call is handled by the running instance, except when it is explicitly told to allow multiple instance launch.
+.Sh IMPLEMENTATION NOTES
+Jitsi is an open source application mostly written in Java with some parts (such as audio/video capture and rendering) written in native code. Its GUI is based on the widget toolkit Swing. Its architecture is build upon the OSGi framework, using the implementation provided by Apache Felix.
+.Pp
+A good resource about the internals of Jitsi can be found in the
+.Sq Jitsi Chapter
+of the
+.Sq The Architecture of Open Source Applications
+book.
+.Ad http://www.aosabook.org/en/jitsi.html
+.Sh FILES
+.Pa $HOME/.jitsi
+The default directory for the configuration files of jitsi
+.Sh AUTHORS
+.An -nosplit
+Jitsi was created by
+.An "Emil Ivov" Aq emcho@jitsi.org
+and currently is being developed by the
+.An "Jitsi Team and Contributors" Aq https://jitsi.org/Development/TeamAndContributors
+.Pp
+This manual page was written by
+.An "Tzanetos Balitsaris" Aq tzabal@it.teithe.gr
+as part of the Jitsi FreeBSD port.